Remove libwacom

I use Opensuse TW KDE.
I try to make a lightweight distribution. I uninstall everything I did not need.
I tried to uninstall libwacom-data and libwacom2. Zypper want to uninstall everything.
Are this packages so important so that i cannot remove it without remove everything?
Thank you.

Well, libwacom2 is required by libinput which is indeed a very important package (if you want a graphical system at least):

$ rpm -e --test libwacom2
error: Failed dependencies: is needed by (installed) libinput10-1.5.0-3.5.x86_64 is needed by (installed) gnome-control-center-3.20.1-17.1.x86_64 is needed by (installed) gnome-settings-daemon-3.20.1-15.1.x86_64

It’s removing libinput that causes “everything” to be removed as a consequence…

I suppose it would be possible to build libinput without libwacom2, but that would result in disabling the corresponding functionality completely, for everybody.

But is this really a problem for you?
libwacom2 and libwacom-data are together about 300 KiB on the hard disk…

No it is not a big problem.
For me libwacom was not a important package (but it seems that I am wrong) so I was wondering why I cannot remove it.
And I did not know that command “rpm -e --test …”. But every day people learn something.
I tried with “zypper info --requires libwacom2”. But was not enough.
One of the reasons I use Opensuse is because this forum.
Thank you very much.

Just to add: removing packages is not going to make your system ‘lighter’. Lots of libraries will just sit there on your harddisk, doing nothing until you start something that needs them.

I am aware of that that.
I only try to make my menu “lighter”.
I remove applications that I don’t need (games, digikam, software updates etc.) with “zypper rm -u package”. When I try to remove Wacom Tablet, zypper wanted to remove all system.
So, after I read and I did not find a solution, I ask a question on this forum and received a good answer faster than I expected.
Thank you.

Ok, but libwacom2 or libwacom-data don’t have a menu entry either… :wink:

You are right.
But when I want to remove “Wacom Tablet” from menu with “zypper rm -u …” this probleme arose (because when I remove a package I want to remove all dependencies I did not need). And I started to dig to find the package who wanted to remove my whole system.
This is the way I have come to want to remove this packages.

And what “menu” are you talking about here then?

And/or what exactly did you try to uninstall with “zypper rm …”?

The only “Wacom Tablet” menu entry I found on my system is part of gnome-control-center itself, i.e. you cannot uninstall it without removing the whole gnome-control-center.
That one has a “NoDisplay=true” though, so should not be displayed in the standard application menu (if the desktop you use does show it, it’s a bug).

When I want to remove Wacom Tablet, I cannot because zypper want to remove my whole system.
I begin to seach…
A write “zypper search wacom” and I begin to remove all wacom’s packages.
I was able to remove some packages without problems (and Wacom Tablet disappeared from my menu).
When I trid to remove this 2 packages, the problem arose.
This is the way I did it. :shame:

PS. Yes, my desktop show it. I did not realize that is a bug. I install Opensuse on two PC (intel and amd) and both show it.

But how exactly did you try to remove “Wacom Tablet”?
There’s no package by that name…

PS. Yes, my desktop show it. I did not realize that is a bug. I install Opensuse on two PC (intel and amd) and both show it.

And what desktop is this?

My desktop - Opensuse Tumbleweed KDE.

How I try to remove:
zypper seach wacom; then zypper rm -u “all wacom packages that I find and was installed on my system”; I remove one or two packages and “Wacom Tablet” from my menu disappeared; I continued to remove wacom packages until I reached these two packages.
When I remove a package I try to remove all dependencies except those required by other packages.
I use “zypper rm -u package” or “zypper rm -t pattern pattern_name” (then I lock, packages or patterns, so that “zypper dup” will not install them anymore).
If “zypper rm -u” want to remove a lot of packages I stop and I begin to search.
Thank you.

Then you must mean a different “Wacom Tablet”.
The one from gnome-control-center does not show up in Plasma’s application menu here.

It does show KDE’s “Wacom Tablet” systemsettings module when you search for “Wacom” (or similar), but that’s on purpose AFAIK.
That one is not displayed in the menu itself either.

The corresponding package is wacomtablet, but it should only get installed (automatically) if xf86-input-wacom is installed too.

I use “zypper rm -u package” or “zypper rm -t pattern pattern_name” (then I lock, packages or patterns, so that “zypper dup” will not install them anymore).

Removing a pattern does not uninstall any packages though.

If “zypper rm -u” want to remove a lot of packages I stop and I begin to search.

As mentioned, “-u” will also try to remove all dependencies of packages that will be uninstalled, which might be too much…

Wacom tablet was form “Utilities” - “Wacom tablet finder”.
Yes, when I remove xf86-input-wacom, this entry disappeared.
About “u”. You are right. But I am trying to be careful. :slight_smile:
I know about the patterns. I remove pattern and all packages from that patern. Then I use “zypper al …”

Right, “Wacom tablet finder” does have an application menu entry.
It’s part of the same package though.

And sorry, the package name is actually kcm_tablet, wacomtablet is the upstream name…
But uninstalling xf86-input-wacom (the tablet “driver”) will remove that as well, and should prevent it from being installed again automatically.

Thank you very much for your help.

Since you’re talking about zypper, you’re using a terminal. Please use your mouse or touchpad to select and copy the output incl command and prompt and paste it here, between CODE tags, the # in the layout ribbon.

I try to write the output but…

 The text that you have entered is too long (39323 characters). Please shorten it to 15000 characters long.

So, this is the output (part of it) :

zypper rm libwacom2
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 99 applications are going to be REMOVED:
  Activities "Activity Bar""Activity Pager"Akregator "Analog Clock""Application Dashboard""Application Launcher"
  "Application Menu""Application Menu Bar"Ark "Audio Volume""Battery and Brightness""Binary Clock"Bluetooth Breeze
  "Breeze Dark""CPU Load Monitor"Calculator Calendar Clipboard "Color Picker""Comic Strip""Declarative Toolbox"
  "Default Panel"Desktop "Desktop Containment""Device Notifier"Dictionary "Digital Clock"Discover "Disk Quota"Dolphin
  "Empty Panel""Fifteen Puzzle""Folder View""Fuzzy Clock""Global Menu""Grouping Plasmoid"Gwenview Haenau "Hard Disk
  I/O Monitor""Hard Disk Space Usage"Hunyango "Icons-only Task Manager"Image "Input Method Panel"KAddressBook KCalc
  "KDE Connect""KDE Plasma Desktop"KGpg KHelpCenter KNotes KOrganizer KRuler Kate "Kate Sessions"Kleopatra Kompare
  Konsole "Konsole Profiles"Konversation Lock/Logout "Media Player""Media frame""Memory Status""Minimize all Windows"
  "Network Monitor"Networks Notes Notifications Okular "OwnCloud KAccounts QML plugin"Pager "Panel Toolbox""Picture of
  the Day""Plain Color"Printers "Quick Share"Quicklaunch Search "Show Desktop"Showfoto Slideshow Spectacle "System Load
  Viewer""System Tray""Task Manager"Timer Trashcan Updates "User Switcher"VLC "Weather Forecast""Web browser""Window
  list"YaST calibre kmag

The following 458 packages are going to be REMOVED:
  NetworkManager-vpnc NetworkManager-vpnc-lang akonadi-calendar-lang akonadi-calendar-tools akonadi-calendar-tools-lang
  akonadi-contact akonadi-contact-lang akonadi-import-wizard akonadi-import-wizard-lang akonadi-notes-lang akonadi-server
  akonadi-server-lang akonadi-server-sqlite akregator akregator-lang ark ark-lang baloo5-file baloo5-imports
  baloo5-kioslaves baloo5-tools baloo5-widgets baloo5-widgets-lang bluedevil5 bluedevil5-lang bluez-qt-imports breeze
  breeze5-decoration breeze5-style breeze5-style-lang calibre discover discover-lang dolphin dolphin-part drkonqi5
  drkonqi5-lang ffmpegthumbs frameworkintegration-plugin ft2demos ftinspect grantlee5 grantleetheme grantleetheme-lang
  gwenview5 gwenview5-lang kaccounts-integration kaccounts-integration-lang kaccounts-providers kaccounts-providers-lang
  kactivities5-imports kactivitymanagerd kaddressbook kaddressbook-lang kamera-lang kate kate-lang kate-plugins kcalc
  kcalc-lang kcalutils ...............sddm sddm-branding-openSUSE sddm-theme-openSUSE showfoto
  signon-plugin-oauth2 signon-plugins signon-ui signond solid-imports solid-tools spectacle spectacle-lang
  syntax-highlighting systemsettings5 systemsettings5-lang vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt
  xdg-desktop-portal-kde xdg-desktop-portal-kde-lang xf86-input-libinput yast2-control-center yast2-control-center-qt

The following 4 patterns are going to be REMOVED:
  kde kde_imaging kde_plasma kde_yast

458 packages to remove.
After the operation, 957.3 MiB will be freed.
**Continue? [y/n/...? shows all options] (y): **n

What I don’t understand is, why you want to remove this library? I’d rather have a couple of unused things on my system, than break it.

I did not have a real reason. I want to remove things that I thought I did not need (like dragon player, k3b, games, marble etc.).

I’d rather have a couple of unused things on my system, than break it.

I think you have right. I will keep it all. :slight_smile:
Thank you.