Remove 5.14.21-150400.42.49 files in boot directory?

I’ve noticed some KDE GUI programs not working or working with issues after latest up to 15.4. I had the system running from a read only snapshot before until “Bugzilla – Bug 1209436” until the .49 issue was posted as resolved/fixed.
I’m having issues with some programs that won’t open or run if opened. They are:
Luckybackup, Ark, Gwenview, Kate and Dolphin.
I was looking through my files and found in the boot directory:
initrd …49-default and 55-default
symvers .49 and.55-default
sysctl.conf, and vmlinux all with both .49 and .55 defaults.
Do I need to remove the .49 files and might this be the cause of the issues I’m having?
Thanks for the patience,

It is unlikely that those files would cause problems. Best to just leave them there.

Thanks nrickert, any suggestions on how I might try and resolve these issues. I’ve done a systems update from the the latest image, uninstalled and reinstalled a few programs and the problem persists.

Which issues? You did not describe any issue at all.

You haven’t describe what you are doing to “run” or “open” these applications. Do you select from menu? Or do you click on an icon? Or do you run at the command line? And what happens then?

It can be useful to try starting at a command line (try the command name in all lower case). You will often get better error message that way.

I think my file system is broken.
From the command line, When I ls the home directory…no output and locks up the terminal whether as a user or root.
Other issues:
Opening Kate on the KDE desktop also never stops loading the home directory even after 10+ hours.
Note pad opens and accepts input but will not save the txt file and locks up.
Clamscan and rsync also start will start but continue to run with no results. Either from the commad line or ClamTK and luckyBackup from the KDE desktop.

All this started after …24.49 update.
I rebooted to …24.46 until …24.55 came out.
I’m thinking I need to reinstall.

Did you try to create a new user to rule out a broken user profile?

I have not. I’ll give it a try.

Created new user.
ls command works.
How might I fix my old broken user profile?

You should use the new user profile as it is in most cases nearly impossible to find the culprit in the old profile. You “may” copy some config files from your old profile but with the risk to import the culprit again…

So restoring from a backup of the home directory from 04/04/23 isn’t advised?

It could be that you somehow acquired errant permissions on or in your homedir. If you would Ctrl-Alt-F3 from the login screen and login as root you could try to restore proper permissions:

chown -R <username>:<groupname> /home/username

That might not fix hidden files or directories, so you might also need:

chown -R <username>:<groupname> /home/username/.*

Log out of root and Alt-F7 to return to login screen, then login normally to test whether solved.

chown -R <username> : <groupname> /home/username

returned :

chown: cannot access ‘/home/jim/pCloudDrive’: permission denied

chown -R <username> : <groupname> /home/username/.*


chown: cannot access ‘/home/jim/./pCloudDrive’: permission denied

chown: cannot access ‘/home/jim/…/pCloudDrive’: permission denied

(screen added 3rd ., wouldn’t accept only two . between jim/ /pColudDrive)

Still cannot see home directory files with Dolphin or command line.

homedir is working again.
All programs that weren’t working are back now. I did my daily zypper up yesterday followed by a reboot. Reboot took about 20 minutes then appeared to hang. Rebooted again and everything is good.

chown -R jim:users /home/jim/.* is an example of what should have worked, presuming you did login as root to run the command. Alternatively, logged in as jim you could have prepended sudo to the command. /home/ is normally writable only by root user. Regular users only have write access to their own homedirs, not /home/ itself.

What happened in the interim? You’ve been using jim to login for over a week and only just today the problem resolved itself?

I did login as root to chrown as suggested by mrmazda. It didn’t resolve the issue, at that time, of not being able to access the homedir as user - jim.
I did create another user as hui recommend but only used it to test if it was all profiles or just mine. I deleted that user after the test ls from the command line worked for the new user.
I haven’t done anything different since this began only debating whether to reinstall or not.
Only logged in as jim.
Daily zypper up and reboot if there were updates.