Removable drivers mount just first time

Hello I found around a lot of question about this but none of the answers can solve my problem…

First I mount properly the drive automatically both if this is my Wacom tablet or my usb external drives.
But after I unplug or umount the drives they never comes up if plugged again until I reebot the system.

I have installed dbus, I tried to read about HAL deamon and config but some person say it is not the solution, autofs I understood it is not the service that mount plugged devices.

Is there a work around to activate the devices plugged in USBs?
Does someone can advice me about a tutorial?

Which openSUSE (11.0, 11.1, 11.2)?

Which desktop (KDE/Gnome/…)?

How could we know/guess?

In any case, normaly when you connect an USB storage device, this should work. And before you disconnect you should of course do something like “remove savely”. And this can be repeated.

So better explain exeactly and precise what you have/ do.

openSUSE 11.2
with Gnome

I have the latest up to date packages from the official repository.

Any way I unmount,

remove savely

I re-plug the same or new device and I can’t see the external disk or use the device.
If is needed some output from terminal or anything ask me please.
Thank you so much.

Brief update (just to see if anyone has an idea).
The icon of my external drive is still there after I eject the drive.
It disappear from the desktop but it is still visible in the Nautilus sidebar.

If I try to unmount again from the icon I got this error window:

DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

If I try to eject again:

One or more partitions are busy on /dev/sdb

If I try to mount again from icon menu (left click):

Error mounting: mount exited with exit code 32: mount: no medium found on /dev/sdb1

But the drive is still in the USB. I hope I did not mess up the errors messages…

After a while the icon disappear also from the sidebar but I can’t see the drive again even if I re-plug it. Same for mouse or other USB devices (but they don’t show on the sidebar so I can’t test error messages).

Thanks in advance.

I am trying to keep up to date the post to see if someone has any idea…

I discovered that if the drive is 1Gb it mounts and unmounts fine with every command from left click of the mouse and this does not affects any other USB port or the reading of any other device (like the wacom tablet).

I don’t have a range from 1Gb to 8Gb of usb stick but I have one of 8Gb and an external USB 2.0 drive of 400Gb.
In both cases the CPU goes up to more of 50% while using and after the unmount, from that point I can’t plug any USB device and just the already plugged keep work but if I unplug and re-plug the device in the same or different USB port I can’t make openSUSE read again the device.

Is there any option to mount/unmount disks of big size that I am ignoring?

This is for me annoying, at least, because every time I have to look for files in my external drive (that are quite a number) I have to reboot the system to make it read.

I am thinking to change distro if I can’t fix the problem (any of the fix I found on the net worked so far) to see if other OS have the same problem.
It is a shame because I really like the openSUSE that is quick and simple to configure.

I also receive this message when I insert an USB drive or insert a DVD disc:
“DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending”

Or when I eject a DVD or USB drive by clicking the eject icon in Nautilus:
“Error starting job: Failed to execute child process “eject” (No such file or directory)”

When I use the “Safely Remove Drive” option by right-clicking I do not receive an error and the mounted drive disappears.

I also get a four instances of Nautilus windows open all stacked when I put a DVD or USB drive in.