Removable device notification in Dolphin

I’m running Leap 15.1 with KDE Plasma 5.12.8 and Dolphin 18.12.3. In the past removable devices showed up in the devices section on the left of the Dolphin screen. By clicking on it one could mount it or unmount it before removal. This feature has disappeared on my system recently. So when I plug in a USB stick I get three action choices of which I choose the one that starts another instance of Dolphin. I find that less handy than what I used to do. Is there a setting in the system settings to go back to what was before? What did I miss? Thanks for any hint!

Works OK here, same plasma/dolphin versions…

Maybe you’ve inadvertently hidden the “Removable Devices” section - right click on the panel and choose “Show Hidden Places” from the context menu.

You’re right. I must have done. Why is it a ‘hidden place’?
Thanks so much for your hint!

Because not everybody likes the junk that may show up there. :wink:

I do like to see that junk :)Before, there was a setting to “Show Hidden Places” (in the settings) which was a permanent toggle. Now it seems it can only be set by clicking on the side panel - that’s not a problem except it doesn’t remember the setting and everytime Dolphin is (re)started I have to go and enable “Show Hidden Places” again. This started happening over year or so ago. Is there any way to make “Show Hidden Places” permanent?

If you click on the panel to “Show Hidden Places” it shows all hidden places and only applies to that dolphin session.

To make a (section) setting permanent you need to right click on the section, in this case “Removable Devices”, and either “Hide…” or “Show Removable Devices” see the screen shot I posted earlier in the thread:
Edit: Just noticed it’s your first post. Welcome to the forums.

I didn’t know there were further options to be revealed when “Show Hidden Places” is enabled :shame:. The “Show Removable Devices” was already enabled. I also enabled “Show Devices”. I restarted Dolphin and those options seems to be still enabled, so hopefully that does the trick (when “Show Devices” is enabled, the “Show Hidden Places” option is greyed out. :good:

Restarting Dolphin brings up another peeve: Dolphin didn’t used to save session/tabs at all. Then it did, but only when you logout out and login to KDE (I was set KDE to save and restore sessions automatically).

And then it seemed to have acquired the ability to restore tabs whether or not it was part of a KDE session, ie if I started up multiple instances of Dolphin they would each restore previous tabs. I’m not sure whether this is a bug or a buggy feature because it doesn’t restore tabs all the time. And it didn’t this time when I restarted Dolphin.

Thanks. Yeah I specifically registered to post this, since this was something that had been bugging me for ages rotfl!

Dolphin has a new option (enabled by default) to restore it’s previous state, you’ll find it under “Settings -> Configure Dolphin -> Startup”

Ah, thanks. That was probably what I was using until a few days ago. I had been using the KDE_Applications, KDE_Frameworks5 and KDE_Qt5 repos since Leap 15.1. Some time after I upgraded to Leap 15.2 a few months ago, a bunch of KDE stuff stopped working - but enough was working so I ignored it. Until a few days ago, when I decided to remove those extra repos and did a “zypper dup --allow-vendor-change” to revert back to the stock repos which restored functionality to the KDE stuff. But this means I’m running on what looks like a fairly old Dolphin - Version 20.04.2 (©2006-2018).

Yes, Dolphin 20.04.2 is the version currently in the Leap 15.2 repo.

The restore previous state option was introduced, if I recall correctly, in 20.07.

If you want newer versions of KDE, with a good degree of stability, you could consider switching to Tumbleweed; but if absolute stability (if there is such a thing) is your need then stay with 15.2

I couldn’t remember why I started using the newer KDE stuff. Probably a bugfix or something. Whatever it was, the base distro has probably caught up now, so I’m going to stick to that for the moment. Thanks.