Remote printing : Unable to connect to server


I recently upgaded my office desktop from 15.4 to 15.5. From the desktop i fire printouts from a printer connected to a central server. My organisation uses PaperCut for managing printer services. I need to run a shell script given by PaperCut for firing the prints through the server.

I faced no issues when i was using Leap 15.4. But with 15.5 i am getting the error:

Unable to successfully retrieve valid data from secure connection to server

I searched online and have tried the following changes:

  • In /etc/sysconfig/displaymanager i have made these changes:
DISPLAYMANAGER_REMOTE_ACCESS="yes" # default is "no"
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" # default is "no"
  • In /etc/gdm/custom.conf i have made this change (to enable anydesk and teamviewer):
  • I have also tried setting the bash environment variable DISPLAY:
export DISPLAY:N

Here N = 0/1/2. None of these values have helped.

I don’t know if it is relevant: In /etc/ssh/sshd_config this is uncommented → X11Forwarding yes

Thanks for your help.

Please, please, do not post the contents of the shell script your organisation has provided on this Forum.

Please, inspect the shell script for obvious errors.
You could also execute the script with verification options enabled when the script is called.

For example, if you have to use Bash to execute the script, the command syntax is:

> bash -vx «the filename of the script»

If another shell is needed for the script then, you’ll have to inspect the man page for the appropriate option values.

I’ll not post the contents of the script. The shell script is provided by the Australian company PaperCut to my organisation.

PaperCut was informed about the problem i am facing. They have got back and told that nothing is wrong with their shell script and something about OpenSuse 15.5 must be the issue. I did not have any problem with Leap 15.4.

So i am still unable to fire remote prints.

@samrat_rao Firewall running? See

1 Like