Remote NFS mount hangs unless local firewall is turned off

The local system is currently running 13.2 32bit openSuse fully updated.

I run long term backups from a second server which connects via NFS twice a month. The backups ran fine on 2/15 but on 3/1 would not connect. I rebooted both systems with no change. I finally tried turning off the firewall on the local system and the remote connected immediately. I verified the firewall settings on the local system and NFS server service was allowed. Added NFS client which obviously didn’t help so I added udp and tcp ports 1110 and 4045. Still no success.

Did the NFS ports change or is this a bug?


What makes you believe that those ports have anything to do with NFS? Really curious.

By default nfsd is listeneing on port 2049 and mountd takes it from /etc/services, at least here it is 20048.

I saw those ports mentioned in someone else’s post and I assumed “NFS server services” opened port 2049. Anyway, the problem is solved even though I don’t know what the real problem was. I did an UPDATE install on the local server to 13.2 again and loaded the new updates and everything is functioning as expected now. I hate problems that can’t be explaned but at least it’s working.

Thanks again.