Remote desktop to OpenSuSe 11.4 / KDE4 - from windows client

Hi guys.

I have a NAS/Htpc here, which (right now) is connected only with a power and network cable.
Everything works fine, but from time to time I might need to log on to it, using a windows pc.
I have windows 7 and I wanna make use of the built-in remote desktop (mstsc.exe).
I use putty right now to connect to the box, so programs that can be configured that way would be best ^^

I’ve tried the standard krfb/krdp, but that didn’t work.
Xrdp created a new session every time i want to login, i very dislike that.
And some other one, can’t recall its name, works only with invitations, which is impossible to work with.

What’s a good program to use for this? I want to have 1 session alone, no more. Whenever i’m logged in and i try to connect from another PC, i want the first one to log out, and the second remote to take over where the first left.

Windows -> Opensuse remote desktop using windows native
Only 1 session at a time, not multiple
Invitations are a no-go; just username/password as login “security”.


Have you tried nx?

I use freenx on/as the server and nomachine’s client to login NoMachine NX - Desktop Virtualization and Remote Access Management Software

If I’m going to run just one or two programs in a session I also use ssh x11 forwarding, check out xming for windows: Xming - PC X Server (xming uses a built-in putty client)

Someone else (Martin Helm I think) mentioned another way on a recent thread about nx, haven’t checked it out myself yet but here’s the link: x2go - server based computing: index

Does mean you wouldn’t be using windows built-in client but I’m not sure why one would insist on using that to connect to a linux server when more efficient methods are available

Reason I dislike anything but the built-in remote desktop on windows, is that occasionally i find myself at a windows computer without any administrative rights. So i can only use software that comes pre-installed.

However, main computer i will use is my own desktop, so I will give nx a shot :slight_smile:
Also ssh x11 forwarding looks like an option, I’ll look into Xming as well, ty :slight_smile:

Well, Freemachine’s NX didn’t seem to work.

Reason why Xrdp stopped working was that “authentication failed”. That’s why I couldn’t get in. And yes, I know my username and password very well :stuck_out_tongue:

But now with NX server/client installed, it gives me the same error. It connects fine -> asks me to add fingerprint to trusted sources.

NX> 200 Connected to address: on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Even though I tell it to log in as “iced” it still tries to authenticate “nx”? Anyway, login fails, same as with xRDP…

Any thoughts?

It has nothing to do with your username and password. You need to import the right client key (usually called client.id_dsa.key) in the client. The keys need to be located in /varl/ib/nxserver/home/.ssh for FreeNX,belong to the nx user and the file /var/lib/nxserver/home/.ssh/known_hosts needs to be present and include the server’s host key defined in /etc/ssh/ Easy isn’it? :slight_smile:

This is what i read:
“It has nothing to do with your username and password. import right client key (…). located somewhere, userwhat, hosts, key defined… Easy isn’it” :smiley:
Other then that, i think i got it working now, reinstalled the NX packages (appearantly you need 3, for server side). And loggin in now seems to work. YAY.
Also set the box to autologin, so that i can autostart applications from within ./kde4/Autostart. created symlinks there for Deluge (that works, yay) and for PS3 media server (but that doesn’t :<)

Anyway, thanks! :slight_smile: NX server/client seems to do what i wanted :slight_smile: Too bad its a 3rd party thing for windows.


What!!! So, when something is good, it’s too bad that it is not part of Windows? Too bad that I’m still alive then! Too bad that so many Linux distros and Unix variants exist and are not part of Windows because if they were … they would become as bad as Windows within a couple weeks.

Anyway, if you don’t want to install 3rd party software on Windows (which by the way already houses the greatest choice of 3rd party malware, spyware and nagware), NoMachine has a web companion that you can install on the server if it runs a web server (like Apache). Then you just need to connect to the web server with Firefox … or do you prefer Internet Explorer - which is not 3rd party software, but just one of the worst technology products of all time? Web companion will offer to download a java client. I don’t know if it works with FreeNX. But you can have both FreeNX and NoMachine servers listening on different ssh ports.

Nonononono… Don’t get me wrong. I don’t like windows! But I have to make use of it for various reasons. And like I’ve stated in a previous post; every once in a while im behind a windows PC with no admin rights, so i can’t install the NX client software. THAT is why i wanted to use the built-in client… And I know that windows houses alot of stuff one doesn’t need, but thats kinda off-topic isn’t it :wink: You’re on a linux forum, im sure 90% of users will agree with you (us) :wink:

I will take a look at the web companion, ty for that. Must’ve overlooked it on their site. And I will use Opera to connect. IE obviously is out of the question, but firefox isn’t as good as opera, nor is chrome. So it’s weird that you suggest firefox when you blame windows for being bad, but hmkay ^^


I would say that FF is way better than opera. It’s truly opensource and usually displays the pages opera fails to :slight_smile: As an example opera 11.03 or something around that version had problems with displaying gmail properly… It even worked ok in IE 9 at that time…

Best regards,

Been using Gmail since the early beta’s, and Opera since before that, never had ANY problems xD
Only page I can’t use opera for is a school website thing, for that I use IE (Even FF and Chrome fail there). So nah, Opera is just fine.

Plus, every ‘new thing’ FF or Chrome add, Opera has had for years already xD

YMMV gmail was not working (only the standard html worked) for me in one of the Opera versions and it works now so I’m almost sure it was a bug they fixed at some place.

Best regards,