Remote DeskTop like TeamViewer

About remote desktop access, what do you recommend?
Which package do you think can replace TeamViewer?

That really depends on your particular requirements and/or host network environments really. Teamviewer employs servers to facilitate connections between clients, and can use different mechanisms to establish this connectivity depending on the firewalls between hosts (which typically means no firewall adjustments required)…

If you have administrator rights with respect to your hosts and firewalls you may choose to use RDP

NoMachine may also be an option worth considering (uses NX protocol).

If you want a cross-platform Teamviewer-like experience, check out AnyDesk. It’s free for personal use.

Hi sergelli

I’ve been using Zoho Assist lately, after TeamViewer blocked me once more for “suspected commercial usage” >:(

I’m tired of writing them to explain that I’m not using their software commercially but only to help friends; due to this last block I’ve been reading more about their “commercial usage” definition and I discovered that they define commercial usage even something that has no commercial content at all, so I decided to look for something else.
It’s a shame because TV is a really good piece of software, but SOHO Assist is quite viable, too.
I’ll also check out AnyDesk as per Deano’s suggestion.

I already tried to use AnyDesk, but it does not work correctly in older versions of OpenSuse that I have to keep due to some software that I use does not work with version 15.0 or 15.1

Are you trying to make a remote control graphical connection to your DOSEMU box? In which case do you really need a third party hosted conferencing system? Perhaps you could just use VNC. There will be a package for almost any o.s. from the last twenty years.

I tried to use TigerVNC, but there is no minimum guidance. The documentation they present is more for us to guess how it works than to teach.
The logical result of the attempt is that I was not able to guess how Tiger VNC should be used

Just forward your Xorg sessions through ssh; tunnel them through VPN, or via similarly secured and encrypted connections.
It’s X, after all — X server and X client are designed to run on seperate systems over networks.

Hi deano

I’ve downloaded AnyDesk but I was unable to install it because it needs a library that is not in the repos:

~> LANG=C sudo zypper in anydesk_5.5.4-1_x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides needed by anydesk-5.5.4-1.x86_64
 Solution 1: do not install anydesk-5.5.4-1.x86_64
 Solution 2: break anydesk-5.5.4-1.x86_64 by ignoring some of its dependencies

**Choose from above solutions by number or cancel [1/2/c/d/?] (c):**

So I tried to download libpangox from but (besides the fact that it is indicated as deprecated) it does not install:

~> LANG=C sudo zypper in libpangox-1_0-0-64bit-0.0.2-3.4.aarch64_ilp32.rpm
Loading repository data...
Reading installed packages...
'_tmpRPMcache_:libpangox-1_0-0-64bit=0:0.0.2-3.4' not found in package names. Trying capabilities.
No provider of '_tmpRPMcache_:libpangox-1_0-0-64bit=0:0.0.2-3.4' found.
Resolving package dependencies...

Nothing to do.

I do not know what this message means.
How did you manage to install it?

Thank you in advance

Hi Cris
Your installing the wrong arch (aarch64_ilp32) rpm… You need x86_64

A quick test here on Leap 15.1 and had to install via the standard repositories;

zypper in libpangox-1_0-0 libgtkglext-x11-1_0-0

Hi malcolmlewis

oh my… I must be completely blind, I didn’t even noticed it. I’m sorry.
However, there’s no libpangox package in Tumbleweed’s repos, I had to get it from

Thank you!!

Google is offering a desktop remote service but asks to install a .deb package
Has anyone used it?
How do I install a .deb package?

I’m not sure how successful that would be. I note a bugzilla request here…

Here’s some information about Alien…
There’s no guarantee this would work though.

I believe the problem is solved.
I’m using Realvcn
It was enough to register an email and password to log in to the system, install the server, put a password for connections and now I can install the client on any machine and I have access to the server instantly

It is not possible to transfer files, but I can do this by other means.
Thank you all