Remote desktop from windows to suse

I am really a noob using Suse or any linux configuration. I have to work in a computer that uses Suse 10.3 from another computer that uses Windows.
What I am looking for is for some programe that works most similarly to windows remote desktop or logmein. What I mean is that I want is to see my actual desktop, not to log as a new user (when I do that I loose my work when I log out)
As I said I new at this so it would be great if you could recomend me some easy program to do what I need and with a detailed tutorial.
Thank you very much

P.S: sorry if this post allready exists, but I couldnt find it

Nx (by nomachine) will let you log on as your self, in a parallel session to your exisiting user (ie what you do as a user is NOT obsevable on the remote desktop). Purportedly ‘nx’ will also let you take over the exisiting desktop (so that your remote session can be seen) but I could never get that ‘nx’ feature to work.

Nx is available for Linux and Windows to access a Linux remote desktop.

You can also use vnc, which is what I use to maintain my mother’s Linux PC. I suspect there must be an MS-Windows VNC client to access a Linux desktop where the Linux desktop is running x11vnc. I can’t recommend an MS-Windows vnc client as I do not access my MS-Windows PC via vnc, but I supect ‘tightvnc’ or ‘ultravnc’ (both for MS-Windows) should work well with this.

thanks for your answer. I have managed to install NX in both computers, but I still can’t manage to connect both of them. As far as I know first I need to create a system account by using “nxserver --useradd nxtest --system”. The problem is that when I do that i receive an error message that says that that command does not exist.
Any idea of what is going on?

metzer52 wrote:
> Any idea of what is going on?

my guess: either the install didn’t go well, or you must be root to
make that command work:

did you install it with YaST or zypper? if not, how?

are you following a guide? did it mention the need to be “root” or
“super user” or preface it with “su -” to run “nxserver --useradd [etc]”??

if so you need to follow this to become root:

CAVEAT: [posted via NNTP w/openSUSE 10.3]

All I did was install the software, open the firewall ports, and it just worked. No messing around with system accounts !!! No messing with ANY config files. Are you certain you opened the appropriate ssh and vnc ports?

hello, and thank you for your answers

I am allways working as root, so I guess the problem is not there.

Are you certain you opened the appropriate ssh and vnc ports?

I am certain I did not. I am also certain I have no clue of how to do it XD
Any oway, once i have learned how to do that (I would apreciate some help), what user name and password shoud I use on the nxclient?

metzer52 wrote:

> I am allways working as root, so I guess the problem is not there.

heh! then, maybe that is your problem…if you wanna always work as
Administrator in your Windows machine that is (i guess) ok…but it is
not what you should be doing in Linux.

CAVEAT: [posted via NNTP w/openSUSE 10.3]

why not?
Anyway, what I mean is that ia was working as root during the instalation and configuration process

Have you tried installing remote desktop rdp on openSUSE? Then you could attach with the rdp client that comes with windows.

There’s more on that here: Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)

It might surprise you then, to learn, that some software is DELIBERATELY coded (or differently packaged) NOT to run with root permissions.

The view that “always working as root” means “the problem is not there” is in my view falacious. You could have inadvertently messed up your configuration at various times in the past, and only now suffering the consequences, of working with root constantly.

I have a policy that I do not support users who always run as root, because the consequences can be difficult to pin down at times. Hence I am very glad you brought this up, as I will now depart this thread and not waste my time (nor your time reading my posts which are made on an assumption you NEVER run nominally as root).

I finally managed to open the ports and now I can conect using NX.
Thank you very much for all your help, and olcpu, dont take it personally

Hey you may try using RHUB` remote support servers for remotely sharing desktops, screen sharing, application sharing, file transfer etc. It works on Windows, Linux, Unix, MAC etc.