Remote desktop access

ok - so it’s been a while [a long while!] since I needed any desktop access to my suse server…

what are my options for an RDP server these days? VNC and…? is there anything else? anything better?


The only time I’ve ever done it (install over a network) was with VNC. Most of the time, I just ssh -X in (to forward the x session back) and launch what I need from the command line.


One of our advanced users, oldcpu, posts occasionally about how to connect to X sessions using ssh. Here’s an example: Tight VNC
In addition the ssh you can use TightVNC or XRDP, have a read of these:
TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)
I think XRDP is better than TightVNC at the moment (openSUSE 11.2/11.3)

I just replaced vinagre with Remmina. imho, better in every respect.

More Info:
Remmina - The GTK+ Remote Desktop Client

It’s available in factory-contrib
Index of /repositories/openSUSE:/Factory:/Contrib

Another alternative is to use NX from NoMachine. See FreeNX - openSUSE

Just want to add to that: If you plan to use FreeNX on openSUSE 11.3 there is a bug (#615164) but here is a workaround:
SDB:FreeNX server - openSUSE

Get FreeNX! It’s amazing good and fast. There is no comparaison with any VNC solution. I don’t know about the bug mentionned by ah7013, as I don’t use the FreeNX from the openSUSE repo. Version 0.7.2 has other bugs not described here, but if you only need to log in into KDE or Gnome session, it should be OK. Otherwise, get Version 0.7.3 or NoMachine (which is commercial software and only allows 1 connection in its free version). FreeNX and NoMachine also work well together if you configure them to use different ssh ports. You can connect to your Linux server with the NoMachine client free available for Window and Mac OSX. There is also a java applet if your server is running a web server. The server itself doesn’t need to be running a X session.

I have used the NoMachine NX Free version and it works really well

I tried NoMachine - got all kinds of weird problems & gave up, then tried vnc server… completely broken. Thought since it was the default with Suses it should be fine… no dice.

I get a blank screen with just the x cursor in it - then it times out after a minute or so
Spent a good 2 hours trying to figure out what was going on, followed several threads here nothing helped [fiddling with hosts, xinet, gdm etc]

I could run & connect by running “dbus-launch vncserver :0 -geometry 1024x768 -depth 32” from the command line, but that’s not a long term solution.

I’m running a new install of 11.3, trying to run the gnome desktop VIA VNC - any thoughts?

Under Gnome, you just have to check “Allow other users to view your desktop” in the “Remote Desktop Preferences”. That could be under System -> Administration -> Remote Desktop. Or if you don’t find it, just type vino-preferences in a terminal. Then you can access your desktop from any VNC client. The one in Gnome appears in the menu as “Remote Desktop Viewer” and the executable is vinagre.

KDE has a similar feature. The server is called krfb and the client krdc.

However, a VNC server/client connection and a NX or FreeNX session are different things. With VNC, you’re just sharing/viewing a X session from a distance. With FreeNX or Nomachine, you’re opening an (ssh encrypted) remote session on your server.

I don’t know if NoMachine works on 11.3. I have been using it on 11.2. I read on some posts that it was broken. Others reported it worked well . It’s surely not totally easy to setup, neither is FreeNX. It relies entirely on ssh. So you have to generate a DSA key pair and install the private key on the client - or accept NoMachine defaut keys. For me FreeNX 0.7.2 , available from openSUSE RemoteDesktop repo, is buggy as it doesn’t handle xdm sessions correctly, but it works OK with KDE and Gnome sessions - that’s what most people want.

yes - thanks, I was playing around with that, but it became apparent that it was only if the user happned to be logged in…

in the end I cheated:


case "$1" in

                dbus-launch vncserver :1 -geometry 1024x768 -depth 24
                dbus-launch vncserver :2 -geometry 1280x1024 -depth 24
                killall Xvnc
                rm -rf /tmp/.X*-lock
                rm -rf /tmp/.X11-unix/*
                $0 stop
                $0 start
                echo "Usage: $0 {start|stop|restart|bite-me}"
                exit 1

I know that’s cheap and lazy - but I had it working in less than 10 minutes… there was just no point in fiddling around with xinet anymore!