Remote acces using window's rdc

Hey all,

I am trying to configure my openSUSE 11 installation such that I (and two other users) can remotely acces this machine over the internet using window’s standard ‘remote desktop application’ (can not use another client as they do not have administrator priviliges on these machines to install another client).

I have been reading several posts, but as a Linux-newbie, nothing helped me any further yet.

The installed desktop is Kde 4.0

Is there someone who could help me with this problem?

I don’t think it is possible to access your linux machine with RDP (Windows Remote desktop Protocal). You will need to use another option. I use VNC, which works OK. RDP is faster in my opinion. You can use RDP in a linux machine to access a windows computer, just not the other way around.

There is another option besides VNC, I think it is NXserver, but I have never used it.

Hope that helps you get started.


P.S. Oh yeah, VNC is cross platform. They even have a viewer for windows machines that don’t require an install at RealVNC - RealVNC remote control software

Thank you for the quick reply, I tried to install the VNC server, but must have done something wrong because it wasn’t working in any way.
Do you know where I can find a basical step-by-step guide how to properly install and configure the VNC program under openSUSE?

not sure in openSUSE, I’m new here, used Kubuntu before.

Are you using a router? If so you need to set up port forwarding on port 5900 (by default) to whatever computer you want to remote into.


P.S. I think SUSE also has a firewall on by default, which may be blocking traffic…hopefully someone with more SUSE experience can chime in on that one, but you could look in yast to find out, and open up the port if it is closed.

yep, I am familiar with port-forwarding on my router… got rdc working for a windows-pc…

Also figured out how I can open port in openSUSE firewall…

only need to find the correct progam and properly install and configure it…

There’s one here: TightVNC Tutorial: OpenSUSE as Client or Server (Remote Desktop)

Hello Swerdna,

Thank you for the perfect tutorial, this really saved me a lot of time.
Unfortunatly I am only able to acces with the standard environment - when I modify ‘xstartup’ into:
or into:
/usr/bin/kde &
I only get a respectively black and grey screen with mouse - but no sign of a desktop/buttons or even shell.
Could you tell me what I am missing here? btw, I have kde4 running.
Is it also possible that after configuring the vnc server that taking over another linux machine by ‘ssh…’ is not possible anymore?

Coincidence: Last night I read in the publication “Linux Magazine” Startpage - Linux Magazine Online the article “Seamless Integration”, subarticle “Terminal Boss”: you can use xrdp to connect to and run Linux boxes from remote windows and Linux boxes. In teresting! RPM xrdp is on openSUSE repository for 11.1 (haven’t checked any others) but is not installed by default.

Use this one for KDE4:
There’s a bug in KDE4/openSUSE/VNC where the normal command to start vncserver will serve up a broken desktop. For KDE4 in openSUSE (until they fix the bug) start it with this different console command:

dbus-launch vncserver

Regarding ssh: I haven’t used it in openSUSE, so can’t answer the question.

hmm - got the following message;
dbus: command not found

tried by installing searching for it whithin ‘Yast’ but couldn’t figure out which to install… I tried ‘kdbus’ but this didn’t work out either…

Oh dear, I have made the same typo over and over in these forums – its this:

dbus-launch vncserver

Tnx swerdna,
Problem solved with Tightvnc - able to acces my machine via both explorer option and tightvnc client. Really easy software to use.
Also tried the other option, but could get this to work.


Getting back to your original request…

Check out NOMAD: Nomad - openSUSE

Caution regarding Nomad and the repo recommended on the project page:

Nomad’s project page (Nomad - openSUSE) recommends the use of a problematic repository for the XRDP packages. If you use the recommnded repo, you cannot server a KDE3 or a KDE4 desktop with XRDP. This bug exists for openSUSE versions 11.1 and 11.2 alpha – I haven’t tried it with any other versions. I believe that it’s a flaw in the RPMs on the repository recommended on the Nomad-openSUSE page (

But if you use the standard OSS openSUSE repo for XRDP as supplied in the release media for 11.1, then it works fine for KDE.

Bug report:
Background: Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)