Remap key under KDE

openSUSE 13.2 64bit KDE 4.14.6

I’m sure I’ve asked this question before but I can’t find the answer here. My notebook does not have a <HOME> key. I would like to remap the <F10> key to <HOME> and I believe I can do that under Configure Desktop>Input Devices>Keyboard or possibly with xmodmap in a startup file. Could someone please show me the way?

Thanks in advance.

Hello
Configure desktop > Shortcuts and gestures > Custom shortcuts

In ‘Name’-frame, create a new group (right click ‘New Group’).
In the new group, ‘New’ > ‘Global shortcut’ > ‘Send keyboard Input’
In the right frame of window, in ‘Trigger’ > ‘shortcut’ input your F10
In ‘Action’ you write “Home” without ".

Thank you quinness.

Could someone please explain how to remap keys AGAIN under LEAP 42.1 KDE. The menus appear completely different from 13.2

Not really much different than in KDE4/13.2:
“Configure Desktop”->Shortcuts->Custom Shortcuts
(compare this to the previous reply by quinness… :wink: )

The settings module itself looks exactly the same as in KDE4 too.

Btw, in case you haven’t noticed, systemsettings/“Configure Desktop” has a search field… :wink:

My keyboard has no <Home> key. I went to System Settings > Shortcuts > Application Keyboard Shortcuts > Standard Shortcuts > Beginning of Line…

It showed the Beginning of Line shortcut as being the default <Home> key. I clicked on “Custom” and then on the “None” box which switched to “Input”. It told me I should press the key/combination I want to assign. I tried the <F10> key and applied the change. I then opened a console typed some letters and pressed <F10>. Nothing happened. Then I tried again with <ctl + m> re-applied. Same results. Then I logged out of KDE and back in again in case that might be the problem. Nothing changed.

What am I doing wrong?

I solved the problem with an xmodmap script that runs at KDE startup. It works.

I thought the point was to remap “Home” to another key? :wink:

That’s what the above mentioned procedure should do: create a shortcut assigned to another key that sends a “Home” key event.
I.e. make another key act like the “Home” key.

I went to System Settings > Shortcuts > Application Keyboard Shortcuts > Standard Shortcuts > Beginning of Line…

That’s something else, and only works for applications that use KDE’s “Beginning of Line” action.

I clicked on “Custom” and then on the “None” box which switched to “Input”. It told me I should press the key/combination I want to assign. I tried the <F10> key and applied the change. I then opened a console typed some letters and pressed <F10>. Nothing happened. Then I tried again with <ctl + m> re-applied. Same results. Then I logged out of KDE and back in again in case that might be the problem. Nothing changed.

What am I doing wrong?

I just tried it and followed quinness’ instructions to the letter, and it works fine here (in Plasma5).

Did you enter “Home” on the “Action” tab as instructed?

One thing that hasn’t been mentioned is that you need to activate the shortcut though, i.e. click on the checkbox so it is enabled.

That’s another option, and works with every desktop.
It remaps the key on a lower level (Xorg).