(Release) key problem.

**Hi! :slight_smile:

**I was trying to install some DEB packages from OBS repositories at my (Debian based) system.However, I wasn’t able to do it properly.

When following the authors instructions, tried to add the repo key (apt-key add - < Release.key), I received error messages about it, like this:

key A41001039EC56A71:
1 signature not checked due to a missing key

I contacted the authors, but no proper solution could be found.
Any idea-suggestion about it?**
TIA! :nerd:

Looking at that, I cannot tell whether that is an error message or an informational message.

I think you need to ask about this on a Debian forum or similar place.

**THANKS **nrickert! :wink:

It’s definitely an error. Means that the key is invalid or expired.
It must be corrected from the repo manager (the developer).
Nothing can be done from the user.

Please let me, be more specific.
Is there any way (for the developer) to generate a new key or something?
Preferably a non-expired one? :)[LEFT]Rebuilding the package, already tried, but didn’t help.


Can you provide details of the OBS project and package (a link)?

Gsmartcontrol’s official Debian repo: https://software.opensuse.org/download.html?project=home%3Aalex_sh&package=gsmartcontrol
Before s a month or so, I had the same problem with Steven Pusher’s Veracrypt repo.
I can’t find the link now. Maybe the author took it down.
I think this is the related link: https://build.opensuse.org/package/show/home:stevenpusser:veracrypt/veracrypt

Can you see the email at this link? Profile of stevenpusser - openSUSE Build Service

If you have an OBS account, you can always leave a comment on the project or package page…

You can see the gpg key, I can import via osc and rpm, not sure on Deb…

sudo rpm --import - <<_END_KEY
$(osc signkey offending-project)

What makes you believe this key is expired?

pub   dsa1024 2008-10-06 [SC] [expires: 2021-03-01]
uid           home:alex_sh OBS Project <home:alex_sh@build.opensuse.org>

You show some message out of context and request that we guess what you did. Copy and paste full command invocation and its output that was used to emit error message, someone may be able to suggest next step.

You don’t have to take my word!
Try it for yourself.

Just go to Install package home:alex_sh / gsmartcontrol and try to follow the instructions (1. add the key and 2. add the repo) for Debian stable (9).

You expect me to waste my time installing Debian for something you would need 5 seconds? Well, I do not have any problems with this key and if I would I know how to troubleshoot it. I would not demand others to do it for me.

  1. I expect **NOTHING **from you!

  2. I don’t have any problem myself, because I don’t need these repos.
    My personal preference is compiling packages locally.
    I was just tried to help other people (mostly newcomers) who needs a repo.

  3. I really don’t expected such a hostile behaviour, but it’s your project, your way.

  4. Personally I’ve lost interesting if OBS malfunctioning or not.
    I’ll inform the 2 involved developers, just in case who wants to participate in this thread.

Over and out.

The problem with that repository key is that it is only 1024 bits and modern versions of apt and apt-get will not accept anything less than 2048. Unfortunately, the error messages from apt/apt-get do not make any of this clear.