Release candidate 42.1 RC1 -- post your comments

I have installed 42.1 RC1.

It mostly looks pretty good. Things that didn’t work for Beta1 are now working.

However, I get a kdeinit5 crash notification whenever I login to Plasma5, though everything seems to work. And I sometimes get a KMix crash notification (I have not tried playing sounds).

Yes, that’s a known problem, and apparently a bug in the pulseaudio upgrade to 0.7.
http://bugzilla.opensuse.org/show_bug.cgi?id=950487

Thanks for the bugzilla reference.

Thanks for that. Modifying in /etc/pulse/default.pa to replace the line

load-module module-native-protocol-unix

with

load-module module-native-protocol-unix srbchannel=no

worked for me, removing the constant plasma5 problem with the kmix/kdeinit crash.

Yesterday i did a ‘zypper dup’ with openSUSE 42.1 beta 1. Since then the kdeinit5-problem described by nrickert plus two more problems showed up:

  1. ‘nm-applet’ did not react to any mouse action
  2. ‘hp-devicemanager’ showed the “No systemtray” message, although the recommended “sleep=20” work around was in place.

Just now i tried the fix mentioned by oldcpu and now everything is fine again !

Thanks oldcpu !

Best regards

susejunky

Me too. Thanks oldcpu.

Hi!

Updated my old laptop (daily used Hp Compaq 6730B) from Leap42.1 Beta1 KDE yesterday to RC1. It was a mess. Endless problems of kded5, kdeinit5, kmix, kmixcontrol bla bla… Crashed. No more then to use as a browser based PC.
The only thing that was working better was that suspend was working whiteout “fan-panic” on start again. Good ;).

Tried a fresh KDE instal (openSUSE-Leap-42.1-DVD-x86_64-Build0235-Media.iso) on my main DE, the same story multiplied. Not useable at all. Uack. I hope that not to many newcomers will try that one.

The problems are in many parts solved by reading post #4 Thanks!

It still exist problems but not any worst than earlier RC’s. I’m optimistic.

If I have something to add is that I think I have notice that “multitasking” is getting worst. Yes the Lan performance is excellent but it lock up almost all resources. Start a large backup and take a cop of coffee. It also shows in other situations, -it have accelerate trow Leap42.1 versions. That my is own opinion.

regards

Plasma 5 seems to be running well with nouveau. This is with a 6150LE graphics card (Nvidia). I’ll leave it this way for now, though I will probably install the G02 driver when the final release is out and the Nvidia repo is up.

Here’s what I did:

1: Boot with “nomodeset”.
2: Login to Plasma 5
3: Turn off desktop effects. I had to uncheck a whole bunch of them. There does not seem to be a single control as there was with KDE4.
4: Reboot, this time without “nomodeset”, so that I am using nouveau.
5: Login to Plasma, and finish configuring my desktop.

I did go to Power settings, and set it to never turn of the graphics. My prior experience with nouveau, is that after it is turned off, the cursor may disappear and not be recoverable until a reboot. I left the dim screen enabled, as that does not cause problems.

So far, so good.

There’s an option to enable/disable compositing as a whole (including desktop effects) in “Display and Monitor”->“Compositor”.
That’s actually the same as the global desktop effects setting in KDE4’s “Desktop Effects”->Global.

Thanks. I’ll look for that when I next boot Leap (I just finished shutting down).

I loaded RC1 into a VBox 5.0.6 VM

Running the KDE Plasma interface
Found that Dolphin would not launch from the default Desktop folder.
Dolphin launched OK from Application launch menu.

At first I thought this was a VM issue - appears to be issue with desktop folder Exec setup
thread is here https://forums.opensuse.org/showthread.php/510279-Leap-RC1-on-Vbox-5-0-6-VM-display-issue-VM-setup-or-Leap

Upgrading a Beta1 on VM with the RC1 Network Installer, kernel-4.1.6-desktop was replaced with the default flavour: kernel-4.1.10-default.
It works, so might remain unnoticed; but it is not expected IMHO.
Can somebody else check that?

A clean install also gets you the default kernel.

I expected this. Apparently the kernel folk have merged the desktop kernel into the default kernel. They are no longer separate. Tumbleweed will probably make a similar change in the near future.

It would be expected by those reading the Factory ML/archive. I would hope to see it mentioned as part of GA announcement in openSUSE news, at least.

I installed using all the defaults except for only ext4 formatting and no firewall. The very first application I opened was Konqueror pointing to my home directory. It started using FSview and clicking on View>View Mode presented me with only one choice…File Size View. Dolphin offers icon and details views.

Right, Konqueror is still KDE4 based, but the KDE4 based dolphin has been removed in Leap (and Tumbleweed), so Konqueror is broken now (as file manager at least).
The only Dolphin included is the KF5 version.

See also the discussion here:
http://lists.opensuse.org/opensuse-factory/2015-10/msg00517.html

Hello

Just a quick note for Leap RC1…

I get a kdeinit5 crash notification whenever I login to the kde desktop. I also get a KMix crash notification upon login and last but not least
whenever I am in the Configure Desktop application, it randomly segv’s on me as well.

After these basic login segv’s I did not go any further in testing as the system does not appear to be stable enough for me
to continue with anything.

If I get notification that these issues have been resolved and a new download is available I will be happy to continue
testing.

This is for an English 64bit installation from the downloaded RC1 64bit ISO.

I certainly hope these basic issues are resolved before Leap is released…

Yes, that’s a problem in PulseAudio, and there are a few other threads about this.
It has been fixed already, but the fix is not in Leap yet.

A simple workaround is to make a change in pulseaudio’s config file /etc/pulse/default.pa.
Replace:

load-module module-native-protocol-unix

with

load-module module-native-protocol-unix srbchannel=no

And yes, this will definitely be fixed in the final release. Probably the fix will be in the repo before that, but I cannot tell you when.

It sounds like you didn’t bother to read posts #1 to #4 in this thread, never mind other threads. It will be resolved and the workaround is mentioned among those posts. Well it was just a quick note… :slight_smile:

I had previously upgraded systend to fix Vbox guest issues. As an experiment, a few days ago post RC1, I upgraded my Beta1 guest (Xfce version, no Packman) using 42.1-Current oss repo to see how it handled RC1’s kernel and virtualbox 5.0.4 to 5.0.6 package changes, which are linked through the -kmp package. Previously I had to lock the virtualbox 5.0.4 packages to prevent them from upgrading when Vbox 5.0.6 was a general failure with missing -kmp (fixed by RC1).

First I removed all obsolete packages using YaST. Since I wasn’t sure of the exact status of 42.1-Current wrt RC1, although close to it, I used “zypper up” resulting in about 1240 package changes. Compared to a “zypper dup”, the only diifference was that “libreoffice-branding-opensuse” didn’t replace the upstream version. I did that manually, followed by removing kernel-desktop, installing kernel-default, and upgrading Vbox packages:

kernel-firmware-20150907git-1.2
kernel-default-4.1.10-1.1
virtualbox-guest-kmp-default-5.0.6_k4.1.10_1-2.2
virtualbox-guest-x11-5.0.6-2.2
virtualbox-guest-tools-5.0.6-2.2

I only needed to make cosmetic changes to default Xfce settings e.g. reset to preferred fonts, and it all worked fine. No PulseAudio or desktop issues, as it’s not installed for Xfce. I particularly like the way YaST works on Leap.

VirtualBox guest-Leap 42.1, including Shared Folders, was a breeze hosted wherever on openSUSE 13.1 (Vbox 4.3.30), Tumbleweed (Vbox 5.0.6, KVM), or Leap Beta1 (VBox 5.0.4, KVM). Now looking forward to the GA…