reinstalled 15.3 and have lots of

I was having problems so I reinstalled leap 15.3 with the net image installation.
I ended up with all theses repositories now?

ypper lr -u 
Repository priorities in effect:                        (See 'zypper lr -P' for details) 
      90 (raised priority)  :  2 repositories 
      99 (default priority) : 20 repositories 

#  | Alias                                | Name                                        
                                                | Enabled | GPG Check | Refresh | URI 
---+--------------------------------------+---------------------------------------------
------------------------------------------------+---------+-----------+---------+-------
-------------------------------------------------------------------------------------- 
 1 | http-download.opensuse.org-97ace8ce  | openSUSE:Leap:15.3:Update                   
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/update/leap/15.3/oss/ 
 2 | https-download.opensuse.org-586e0ced | SUSE:SLE-15-SP1:GA                          
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/ 
 3 | https-download.opensuse.org-5d4da0bb | openSUSE:Backports:SLE-15-SP3:Checks        
                                                | Yes     | (r ) Yes  | Yes     | https:
//download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3:/Checks/standard/ 
 4 | https-download.opensuse.org-758f5a47 | openSUSE:Backports:SLE-15-SP3               
                                                | Yes     | (r ) Yes  | Yes     | https:
//download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3/standard/ 
 5 | https-download.opensuse.org-8e5d0252 | mozilla                                     
                                                | Yes     | (r ) Yes  | Yes     | https:
//download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.3/ 
 6 | https-download.opensuse.org-9be64db8 | SUSE:SLE-15-SP1:GA                          
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/ 
 7 | https-download.opensuse.org-9ccb8a98 | SUSE:SLE-15-SP2:Update                      
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool/ 
 8 | https-download.opensuse.org-9eaa5dc6 | SUSE:SLE-15-SP2:GA                          
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/ 
 9 | https-download.opensuse.org-db8aa77a | SUSE:SLE-15-SP3:GA                          
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/ 
10 | https-download.opensuse.org-e293e7c5 | SUSE:SLE-15-SP1:Update                      
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool/ 
11 | https-download.opensuse.org-ed1708a8 | SUSE:SLE-15:Update                          
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool/ 
12 | https-download.opensuse.org-f0d51679 | SUSE:SLE-15-SP3:Update                      
                                                | Yes     | ( p) Yes  | Yes     | https:
//download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/Update/pool/ 
13 | https-download.opensuse.org-f3b4e39a | openSUSE:Backports:SLE-15-SP3:Update        
                                                | Yes     | (r ) Yes  | Yes     | https:
//download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3:/Update/standard/ 
14 | mozilla                              | mozilla                                     
                                                | Yes     | (r ) Yes  | Yes     | https:
//download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.3/ 
15 | openSUSE-Leap-15.3-1                 | openSUSE-Leap-15.3-1                        
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/distribution/leap/15.3/repo/oss/ 
16 | packman-essentials                   | packman-essentials                          
                                                | Yes     | (r ) Yes  | Yes     | https:
//ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/Essentials 
17 | repo-backports-debug-update          | Update repository with updates for openSUSE 
Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    | http:/
/download.opensuse.org/update/leap/15.3/backports_debug/ 
18 | repo-backports-update                | Update repository of openSUSE Backports     
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/update/leap/15.3/backports/ 
19 | repo-debug                           | Debug Repository                            
                                                | No      | ----      | ----    | http:/
/download.opensuse.org/debug/distribution/leap/15.3/repo/oss/ 
20 | repo-debug-non-oss                   | Debug Repository (Non-OSS)                  
                                                | No      | ----      | ----    | http:/
/download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/ 
21 | repo-debug-update                    | Update Repository (Debug)                   
                                                | No      | ----      | ----    | http:/
/download.opensuse.org/debug/update/leap/15.3/oss/ 
22 | repo-debug-update-non-oss            | Update Repository (Debug, Non-OSS)          
                                                | No      | ----      | ----    | http:/
/download.opensuse.org/debug/update/leap/15.3/non-oss/ 
23 | repo-non-oss                         | Non-OSS Repository                          
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/distribution/leap/15.3/repo/non-oss/ 
24 | repo-oss                             | Main Repository                             
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/distribution/leap/15.3/repo/oss/ 
25 | repo-sle-debug-update                | Update repository with debuginfo for updates
 from SUSE Linux Enterprise 15                  | No      | ----      | ----    | http:/
/download.opensuse.org/debug/update/leap/15.3/sle/ 
26 | repo-sle-update                      | Update repository with updates from SUSE Lin
ux Enterprise 15                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/update/leap/15.3/sle/ 
27 | repo-source                          | Source Repository                           
                                                | No      | ----      | ----    | http:/
/download.opensuse.org/source/distribution/leap/15.3/repo/oss/ 
28 | repo-update                          | Main Update Repository                      
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/update/leap/15.3/oss 
29 | repo-update-non-oss                  | Update Repository (Non-Oss)                 
                                                | Yes     | (r ) Yes  | Yes     | http:/
/download.opensuse.org/update/leap/15.3/non-oss/



I have 18 repos, though some of those are not really necessary.

I’m not seeing any obvious problems with your list of repos. With the addition of some “sle” repos, the number of repos has gone up from what we used to see.

ok thanks, i was used to a lot less and wanted to keep it simple.

The repositories whose URL contain “:GA” can be removed, they all return a 404 error, I’m not sure where they came from :\ …

FWIW these are the default repositories on a fresh install of 15.3:

#  | Alias                       | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
---+-----------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
 1 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/          | 
 2 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                | 
 3 | repo-debug                  | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/     | 
 4 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/ | 
 5 | repo-debug-update           | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                | 
 6 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/            | 
 7 | repo-non-oss                | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/       | 
 8 | repo-oss                    | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/           | 
 9 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                | 
10 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                      | 
11 | repo-source                 | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/    | 
12 | repo-update                 | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss/                      | 
13 | repo-update-non-oss         | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                  | 

Here I see also a “source Non-OSS” repo.

Default install:

**erlangen:~ #** **zypper --reposd-dir /mnt/@/.snapshots/4/snapshot/etc/zypp/repos.d/ lr -uEP** 
#  | Alias                 | Name                                                         | Enabled | GPG Check | Refresh | Priority | URI 
---+-----------------------+--------------------------------------------------------------+---------+-----------+---------+----------+------------------------------------------------------------------------ 
 2 | openSUSE-Leap-15.3-1  | openSUSE-Leap-15.3-1                                         | Yes     | ( p) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.3/repo/oss/ 
 4 | repo-backports-update | Update repository of openSUSE Backports                      | Yes     | ( p) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/20210703/backports/ 
 9 | repo-non-oss          | Non-OSS Repository                                           | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/20210703/repo/non-oss/ 
10 | repo-oss              | Haupt-Repository                                             | Yes     | ( p) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/20210703/repo/oss/ 
11 | repo-sle-update       | Update repository with updates from SUSE Linux Enterprise 15 | Yes     | ( p) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/20210703/sle/ 
13 | repo-update           | Hauptaktualisierungs-Repository                              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/20210703/oss 
14 | repo-update-non-oss   | Aktualisierungs-Repository (Nicht-Open-Source-Software)      | Yes     | ( p) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/20210703/non-oss/ 
**erlangen:~ #**

Above list uses URLs of release candidate. Running ‘zypper update’ fixed that:

**Leap-15-3:~ #** zypper lr -uEP 
#  | Alias                 | Name                                                         | Enabled | GPG Check | Refresh | Priority | URI 
---+-----------------------+--------------------------------------------------------------+---------+-----------+---------+----------+---------------------------------------------------------------------- 
 2 | openSUSE-Leap-15.3-1  | openSUSE-Leap-15.3-1                                         | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.3/repo/oss/ 
 4 | repo-backports-update | Update repository of openSUSE Backports                      | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/backports/ 
 9 | repo-non-oss          | Non-OSS Repository                                           | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/ 
12 | repo-sle-update       | Update repository with updates from SUSE Linux Enterprise 15 | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/sle/ 
14 | repo-update           | Hauptaktualisierungs-Repository                              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/oss 
15 | repo-update-non-oss   | Aktualisierungs-Repository (Nicht-Open-Source-Software)      | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/non-oss/ 
**Leap-15-3:~ #**

I removed all the ones with .GA and all the update errors went away.

now getting this error message
An error occurred during repository initialization. [https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/Update/pool/] Valid metadata not found at specified URL History: - [https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/Update/pool/] Repository type can’t be determined.

I think that’s a temporary error – probably a glitch at one of the mirrors.

Maybe wait an hour and try again. If the message was from the update applet, then try “zypper up” at the root command line (so that you don’t have to reboot your computer to try again).

That’s another one to be removed…

Error 404 The requested URL is no longer available on this server.

Prune your repository list so it matches that of post #4, but retaining your mozilla repository you’ve added, although you seem to have that twice, #5 and #15 in your original post.

Gave everything some time to work out.
Now I’m getting this


manny@localhost:~> su - 
Password:  
**localhost:~ #** zypper up 
Retrieving repository 'SUSE:SLE-15-SP2:Update' metadata .........................[error] 
Repository 'SUSE:SLE-15-SP2:Update' is invalid. 
[https-download.opensuse.org-9ccb8a98|https://download.opensuse.org/repositories/SUSE:/S
LE-15-SP2:/Update/pool/] Valid metadata not found at specified URL 
History: 
 - [https-download.opensuse.org-9ccb8a98|https://download.opensuse.org/repositories/SUSE
:/SLE-15-SP2:/Update/pool/] Repository type can't be determined. 

Please check if the URIs defined for this repository are pointing to a valid repository. 
Warning: Skipping repository 'SUSE:SLE-15-SP2:Update' because of the above error. 
Retrieving repository 'SUSE:SLE-15-SP1:Update' metadata .........................[error] 
Repository 'SUSE:SLE-15-SP1:Update' is invalid. 
[https-download.opensuse.org-e293e7c5|https://download.opensuse.org/repositories/SUSE:/S
LE-15-SP1:/Update/pool/] Valid metadata not found at specified URL 
History: 
 - [https-download.opensuse.org-e293e7c5|https://download.opensuse.org/repositories/SUSE
:/SLE-15-SP1:/Update/pool/] Repository type can't be determined. 

Please check if the URIs defined for this repository are pointing to a valid repository. 
Warning: Skipping repository 'SUSE:SLE-15-SP1:Update' because of the above error. 
Retrieving repository 'SUSE:SLE-15:Update' metadata .............................[error] 
Repository 'SUSE:SLE-15:Update' is invalid. 
[https-download.opensuse.org-ed1708a8|https://download.opensuse.org/repositories/SUSE:/S
LE-15:/Update/pool/] Valid metadata not found at specified URL 
History: 
 - [https-download.opensuse.org-ed1708a8|https://download.opensuse.org/repositories/SUSE
:/SLE-15:/Update/pool/] Repository type can't be determined.                             
                                                                                         
Please check if the URIs defined for this repository are pointing to a valid repository. 
Warning: Skipping repository 'SUSE:SLE-15:Update' because of the above error. 
Retrieving repository 'SUSE:SLE-15-SP3:Update' metadata .........................[error] 
Repository 'SUSE:SLE-15-SP3:Update' is invalid. 
[https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE:/S
LE-15-SP3:/Update/pool/] Valid metadata not found at specified URL                       
History:                                                                                 
 - [https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE
:/SLE-15-SP3:/Update/pool/] Repository type can't be determined.                         
                                                                                         
Please check if the URIs defined for this repository are pointing to a valid repository. 
Warning: Skipping repository 'SUSE:SLE-15-SP3:Update' because of the above error. 
Retrieving repository 'Update repository with updates from SUSE Linux Enterprise 1[done] 
Building repository 'Update repository with updates from SUSE Linux Enterprise 15'[done] 
Some of the repositories have not been refreshed because of an error. 
Loading repository data... 
Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider usi
ng a different mirror or server. 
Reading installed packages... 

The following 3 package updates will NOT be installed: 
  MozillaFirefox-branding-openSUSE kmozillahelper mozilla-nss-certs 
Nothing to do. 
**localhost:~ #**  






Hi
What happens if you force a refresh and add verbosity?


zypper -vvv ref -f

My system was an update and sitting on http, changed the SLE Update one to https and all working fine. One wonders if your locale and mirrorbrain is pushing you to a http mirror…

Retrieving repository ‘Main Update Repository’ metadata …[done]
Forcing building of repository cache
Building repository ‘Main Update Repository’ cache …[done]
Forcing raw metadata refresh
Retrieving: http://download.opensuse.org/update/leap/15.3/non-oss/media.1/med[not found]
Retrieving: http://download.opensuse.org/update/leap/15.3/non-oss/repodata/repomd.[done]
Retrieving: http://download.opensuse.org/update/leap/15.3/non-oss/repoda[done (988 B/s)]
Retrieving: http://download.opensuse.org/update/leap/15.3/non-oss/repodata/repomd.[done]
Repository: Update Repository (Non-Oss)
Key Fingerprint: 22C0 7BA5 3417 8CD0 2EFE 22AA B88B 2FD4 3DBD C284
Key Name: openSUSE Project Signing Key <opensuse@opensuse.org>
Key Algorithm: RSA 2048
Key Created: Mon May 5 04:37:40 2014
Key Expires: Thu May 2 04:37:40 2024
Rpm Name: gpg-pubkey-3dbdc284-53674dd4
Retrieving repository ‘Update Repository (Non-Oss)’ metadata …[done]
Forcing building of repository cache
Building repository ‘Update Repository (Non-Oss)’ cache …[done]
Some of the repositories have not been refreshed because of an error.
localhost:~ #


Hi
I don’t use non-oss, but the info is wrong for your one… I would suggest deleting, run a cleanup with zypper and add back in and see if that helps…

How do I get all the repositories back to standard installation?