Reinstall Yast


Is there a way to reinstall yast?

It was uninstalled during an update, not sure how, but it’s gone.
I’ve tried booting from a previous snapshot, and to reverse the changes from snapper (which I reinstalled with zypper), but none of these solutions worked.


You can see what is available vs installed using

zypper se -s yast

Check if the yast patterns are installed

 zypper se -s patterns-yast

Perhaps the following will help with reinstalling a working yast environment

zypper in --force patterns-yast-yast2_basis patterns-yast-x11_yast 

BTW, how are you updating here? As my forum colleague Knurpht is often reminding TW users, the correct way is to only use

zypper dup

According to the thread title, OP is using 15.0 :stuck_out_tongue:

IMO you should describe what makes you think YaST was uninstalled.
Perhaps it’s still in your system, but you’re not able to invoke it?

Try… From a command line…

sudo yast2

Some Desktops don’t list YaST as a menu entry any more (Why, I wouldn’t know and I lament its disappearance),
But instead list all the YaST Modules by their functional names.

What Desktop are you using?


Very true. Ignore that post. :X

AFAIK in LEAP 15 zypper dup does not do vendor changes so running it would make sure all installed packages are the same as the ones from the online repo’s
the OP should post his repo list

zypper lr -d

the only reason for yast to be broken is if he installed a package for a different distribution ie TW
if all of the OP’s repos are for LEAP 15 running

zypper ve

should fix things vorst case scenario running

zypper dup --from <OSS update repo alias>

should fix things