Reinstall Leap 15 again on the laptop

And I would like to know how to make it automatically connect to WiFi.
And how to get kdewallet out of my face. THe last install kdewallet has/had my router password. I hope there are better ways to auto connect to WiFi without having to go through that monster.

Also this is fdisk -l for the last install.

linux-w38i:~ # fdisk -lDisk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectorsUnits: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 036073BD-199A-4EDC-9D62-78837B4C2F1E

Device         Start       End   Sectors   Size Type
/dev/sda1         64    204862    204799   100M EFI System
/dev/sda2     204863    237630     32768    16M Microsoft reserved
/dev/sda3     237631  84123647  83886017    40G Linux filesystem
/dev/sda4  420597768 975743994 555146227 264.7G Microsoft basic data
/dev/sda5  975745024 976769023   1024000   500M Windows recovery environment
/dev/sda6   84123648 241410047 157286400    75G Linux filesystem
/dev/sda7  241410048 420597767 179187720  85.5G Linux filesystem

Partition 2 does not start on physical sector boundary.
Partition 3 does not start on physical sector boundary. 

Partition table entries are not in disk order.

What are the Part 2 and Part 3 lines telling me?
And should I do something about them?

Easiest way to deal with wallet is use a blank password then it will not bother you.:wink:

Well it means the partitions ar3e not aligned to natural block boundaries. It means a bit of wasted space but not hugely important these days

Partition table entries are not in disk order comes from the order you created and positioned the partitions. Note the number and the starting block. Again no big deal.

If you are using the KDE desktop on a laptop, the kdewallet is the way to go. But you can still get it out of your face.

I’ll start with the assumption that this is a new install. However, it you are using the old “/home”, then it won’t look like a new install as far as kdewallet is concerned. So I’ll get to that later.

New install. Start by plugging in an ethernet cable. That way you can connect to the network without a WiFi password and “kdewallet” won’t bother, at least while you are at home.

After installing, the very first step should be to install “pam_kwallet”. With that installed, “kwallet” should work unintrusively in the background.

So, okay, what if you don’t have an ethernet connection. In that case, you need a WiFi connection to use the network. So here’s how to do that:

  • when first prompted to setup “kwallet”, choose “blowfish” encryption (instead of the default gnupg encryption).
  • when prompted for a password, use your desktop login password.
  • take the defaults for everything else.
  • that probably all happened when setting up WiFi. So now that you are connected, you should be able to install “pam_kwallet”. And if you followed the advice, then in future “kwallet” should work unintrusively in the background and you won’t notice it.

If you already have KDE configured and are using the old “/home”, then you can make a fresh start with:

rm .config/kwalletrc
rm .local/share/kwalletd/*

And I should have mentioned that, after these changes and after installing “pam_kwallet” you should logout and then login again.

I will deal with kdewallet when I can get a session to actually shutdown from the KDE Power/Session.
This ‘new’ install did the same thing the one yesterday did. Everything seems to work, except I can’t configure the desktop, and I can’t shut down, maybe more but I haven’t found them yet.
If I hit the power button, it is just going to get me back to what I stated in the other thread,
No boot, just a black screen that will let me reach a ‘terminal’ type that does me no good.
And I don’t want to leave it on all night.

I have an nVidia card along with the onboard video. Could that be the problem?

I don’t want to go through another install!

Laptops with hybrid graphics (Intel+NVIDIA) is called primus and needs bumblebee to work right and share the GPUs

Stuck in power/session mode ‘won’t’ work again!
I accidentally hit the hibernate switch AND that one worked!
But I got a black screen with movable cursor, and after a few minutes a login prompt on that screen.
When I tried to do something with it it kept informing mo of a ‘bug’ soft something CPU#1 stuck.
So I hit the power button and now that black screen AGAIN with a cursor that won’t go farther than ctrl-alt-F1 to get a login prompt.

One more install and that is it. Back to windows only on the laptop.
I am sickened.

I tried to get to that, but read my last post above this one.

I am installing the nVIdia drivers per the article you sited from the ‘terminal’ actuated YaST. Only way I could get to it.
If that doesn’t work, then I will try bumblebee.

I will get this done.
Can I install bumblebee during the install?
It looks like bumblebee installs both 64 and 32bit. Is that true?

I also know the nvidia driver required, so can I add the nvidia community repo during install?
And then install it first after the install?
On nvidia driver site there is a download for ‘Linux 64 bit’. Another option maybe?

Any word on the so callled kernel ‘bug fix’ for this?

After a lot of reading in here and the SDB articles about Optimus machines, it is another install of Leap 15, and install bumblebee as quickly as possible.

The SDB article for bumblebee will be practically memorized and I hope I can get it before it Optimus does what it does to cause the Power/Session ‘lockups’.

Would be much easier if I could disable the nVidia card from the bios but unfortunately not.

I do not plan to,use the nVidia anyway, but I want the system to work.

Until you get all configured you should be able to boot with nomodeset to use the fall back drivers. At boot scree press e find line starting liux or linuxefi go to end of that line (it wraps) add space an nomodeset press F10 to continue boot. Note this is a temp change and will not be used next boot but it often will get you do a usable GUI to update or install needed things. Alternatively you can boot to a terminal following above but add a 3 instead of nomodeset. This will start a terminal session and you can log on as root and run yast or zypper as needed

I have gotten to the text only terminal, and added nomodeset and as suggested by deano_ferrari in another post ‘nouveau.modeset=0’ per the release notes. Neither worked to get me to the installed version(which is there, I an find everything with the keyboard that I could in the GUI).
I added each of those via the YaST boot loader as well. Still no ‘real’ boot’.

I ran ncurses YaST from that terminal and installed ‘bbswitch’ , again suggested by Knurpth in that same thread. bbswitch seems to do it’s job, but again I can’t get to the installed version except via the terminal mode.
I also installed bumblebee, but there are probably things I need(ed) to do besides just the installs.

If bbswitch will let me turn off the nvidia card in a new install(or if I can get the current install back), I can live with that.

Thanks for the response.