Reinstall KDE4 / Plasma trough zypper in bash

Hi Guys,

Something strange happened to me would really appreciate your input:

During the installation of Koffice2 my laptop went into sleep mode after awaking up again zypper hang up and even with kill I could not kill the process.

Any way after a reboot (normal shutdown) my GUI acts strange:

  1. Get Plasma error and asking for sending a Bug
  2. Gui is slow like hell
  3. Yast2 Software Management does not work
  4. Wine links have Question mark (Folder View)

However does anybody of you know how to reinstall the whole KDE4 including Plasma.

I tried it with: zypper -f -t pattern kde

But it does nothing actually. Would really appreciate if somebody could explain where to start and what to do if you want to troubleshoot the GUI.

Thank you in advance.:wink:

You may get lucky here, but this is a discussion forum. Suggest you re-post in the help forum called Applications and/or send a PM to a Moderator asking it to be moved there.

Thanks, for mentioning it. Will leave it here as the problem is fixed:

Tried to use the slow KDE to run a one click install of installing KDE 4.2 from the OpenSuse site. Still the same symptoms.

However started with another GUI i think called icewm and did the same thing. I had to resolve some depency issues trough Yast2 and after a restart see there it worked again.

Now i just have to reconfig my Plasma settings. Maybe it would be already enough to reset Plasma trough killing Plasma and delete the Plasma folder, however i did not try that, if it ever happen again will try.

Maybe this is a good point to discuess the issues you had already with the GUI and how you fixed it.