reinstall boot loader


I have installed OpenSuse 11.4 on windows-computer (on an separate partition). After a windows reinstall, the linux boot disappeared.
How could I reinstall the boot loader? I have the original linux DVD.

I believe you can boot the 11.4 DVD, and then go into Rescue / Repair mode, and then re-install the bootloader from there.

It’s probably enough to set the bootflag back on the linux root partition or the extended one - wherever you installed Grub (the default openSUSE setup doesn’t put it in MBR - unfortunately). You can use fdisk from a Linux live CD or even the Windows command diskpart … or any partitioning tool capable of activating partitions.

This situation occurs so often, there’s an openSUSE support db page about it.

Notice that while it will solve the problem, I do not consider it to be the solution, because it does not restore the situation you had before repairing Windows but creates a different situation by replacing the generic MBR (which boots only the active partition, which is now Windows) with a boot manager (capable of booting any partition, whether it is set active or not).

The “real” solution is to set the bootflag back on the Linux partition. Different ways to achieve that are explained in this post and in many others.

I tried the followings

Boot Suse DVD, select Rescue
Login root
Type grub

In the grub prompt
find /boot/grub/stage2
reported: hd1,1

root (hd1,1)
setup (hd1)

Reboot, but still no grub menu

This is normal. It will be booted from hd0 not from hd1. Having Grub installed in the MBR of your second hd doesn’t help. You should either swith BIOS disk order or install Grub in the MBR of your first hd (same as you did but using setup (hd0) )

When you said that you installed openSUSE on an separate partition, did it also mean on a separate hard disk? How many hard disks are there in this computer? Are you booting with an external hard disk plugged in? (you should rather not, especially while installing/reinstalling Grub).

No external disk. Two disk in the computer.

Then my advice in post #7 applies.

setup (hd0) solved the problem.