Regular AND failsafe boot hanging

I am using openSUSE 11.0 and have been quite happily for a couple of months now. I have never had any troubles with it until now.


  1. suse won’t boot up in regular OR failsafe mode. During regular boot, it seems to hang after the line “Starting VMWare Virtual machines done”.
  2. failsafe mode also hangs, with this being the last line on the bootscreen: “ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ-(11) MMIO=[ecbff000-ecbff7ff] Max Packet=[2048] IR/IT contexts=[8/8]”
    2a) I tried failsafe again, and now it hung after this line: “iTCO_vendor_support: vendor-support-0”

Possible causes:
The last time I saw my desktop, I was attempting to get my keyboard volume control buttons to work. They have never worked with suse and I had some free time. I changed some stuff with the sound card, but nothing that I haven’t done before. The only major thing I did was switch my keyboard type from the pre-selected Microsoft something-or-other, to the keyboard from the drop-down list that it should have been in the first place (dell latitude series keyboard). Upon my next reboot, everything hung.

I am using a Dell Latitude D820 laptop.
Running openSUSE 11.0 -

I am not very good at troubleshooting linux stuff like this. I know my way around inside a linux OS, but this is the first time I’ve encountered anything like this. What do I do when I can’t boot to anything??? :frowning: Is there something I can enter in the boot options at the loader screen? I looked through the F1 Help menu, but it only shows switches that get used during failsafe boot, nothing extra or added…


I left my laptop alone while it was booting and did some stuff on the server, and every time I looked over, it was stuck on the same spot. But now it finally booted me to a login prompt. It’s not my usual KDE4.1 gui, but it was a start. It let me log in as root and I have my root user prompt, but I still don’t know where to go from here. How do I get back to my KDE? Thanks in advance for all who took the time to look at this. :smiley: Cheers

Log messages during boot:
While regular boot is “hung”, I alt-arrowed over to another console which I assume is a display of the log messages. I saw a couple of lines that caught my attention and wondered if this is the reason I can’t load my kde::
“kdm[2595]: X server for display :0 terminated unexpectedly”
“kdm[2595]: Unable to fire up local display :0; disabling.”

So during boot, it’s trying to fire up a process with #2595 to load the display, but it can’t for some reason. Am I reading this correctly?

If anyone has any idea of where I can look for some answers, I’d be greatly appreciative. Another thing of note, I upgraded from KDE4 to KDE4.1 this morning, but did a couple of restarts afterwards with no problems.

The error message is telling you that kdm cannot start the X server. Try booting with init 3 (just put a 3 in the boot option box on your boot menu); that will boot the kernel, initialize everything, take you to a command prompt. Then as root do a “startx”. If the problem is specific to kdm, X and KDE will start; this is conceivable with all the KDE changes you’ve been downloading. If X doesn’t start, it will throw some error message(s), but you want to go to /var/log/Xorg.0.log; it should give you the reason X isn’t starting.

Thanks for the reply so quickly! :slight_smile: Here is what I did, and what I saw:
When the boot loader screen came up, I used the following boot options in the boot text field: vga=0x317 init=3. That didn’t work so then I just typed a “3” the next time and still the same results. I don’t think that did anything different, except used the factory vga settings. On the system load screen, it still hangs after it prints “Starting VMWare virtual machines… done”. Here is what the other screen (alt+f10) displays while it’s hung (starting with the display errors messages, everything else before that seems normal):
kdm[2553] X Server for display :0 terminated unexpectedly
kdm[2553] Unable to fire up local display :0; disabling.
kernel: Symbol init_mm is marked as UNUSED, however this module is using it.
kernel: This symbol will go away in the future.
kernel: Please evaluate if this is the right api to use, and if it really is, submit a report to the linux kernel mailinglist together with submitting your code for inclusion.

Am I not giving it the right boot arguments at the loader screen? This is strange because now I can’t even get to a login prompt, like I did once earlier after letting my laptop boot for 30 minutes or so. Now it’s just hung…again… Thoughts? Cheers! :smiley:

We don’t have enough data to determine what the problem is. Do you have an install DVD or live-CD? On the install DVD there is a “rescue mode” that will boot a kernel and give you a shell; with the live-CD similarly you will be put in a graphical environment running in RAM. (The live-CD is probably best for this.) In either you can mount the root partition and then investigate the log files. Some of your description seems to point to the kernel, other to the X server; the latter could be due to the former. But you need the log files to sort it out.

The files you’re concerned with are all in /var/log. The boot log is boot.msg, system log is messages, and the X log is Xorg.0.log. In boot.msg you will see the hardware and system initialization, the root partition is mounted followed by any others, runlevel 5 is entered and services started up, runlevel 5 is “reached”, i.e., completed and that is the point that kdm is called to in turn fire up X. Xorg.0.log tells you everything the X server did from startup; if it is failing, the reason will probably be near the end of the file, but may back reference something earlier in the file. Post back what you find, or the applicable sections of the logs, so we can figure out what is actually happening.

Thanks for the response. Unfortunately, I use my laptop for work (I’m a Network Technician), so I could ill-afford to be without it for long. I was able to use a knoppix cd to get my drives mounted and backed up some critical files. But I just went ahead and did a fresh install this morning. It’ll take me a few days to get everything back to the way I had it, but it’s always good to start fresh every now and then so you can leave off all the crap that you had on previously. :slight_smile:

I still have a question regarding my laptop keyboard volume buttons not working, but I’m headed to a different section for that issue. Thanks guys :smiley: