Reducing update frequency from hourly to weekly or monthly

My system is finally working stable and fine except for continuous call to update. Every hour I get recommended and security updates message. If I choose to install the updates they complete and 2 minutes later get another request to install more. I have Yast software updates set to weekly and only official to be notified. What else can I do to stop these persistent updates. Do I need to remove kpackage or something else. Maybe I need to delete or disable opensuse_updates repository cuz it is getting very annoying to be constantly asked to install updates.

if you are using plasma 5, right-click on the update applet select settings and chose between daily, weekly or monthly update checks.

It’s probably not the updates repo. More likely, it is one of the other repos.

At least in my observation, the update repo gets update every few days, but not every few hours. On the other hand, Packman gets updated more often. And when I was using the KDE:Extras repo with 13.2, that was updated more often.

But those more frequent updates are often just a recompile of the same version, giving an incremented second level (or 5th level or whatever) version number. So I use Yast Online Updates. If there are no updates, I do not do anything more. If there are updates, I follow that with “zypper up” (at the root command line) to update from the other repos.

Right-click the updates it says settings and I choose that and it just gives me shortcut key change and nothing else.
I am using packman repo @ 98 priority to get around problems with media codecs missing and phonon-backend errors present with default serepos

that priorety has nothing to do with update frequency but repo priority
are you using plasma 5, cos if you are and you right-click on the update applet and select Software Update Settings… this is what you should get
the update applet has nothing to do with yast so you can not configure it in yast, if you want you could remove it and update manually with zypper up

oops I didn’t read you wore using 13.2 in that case you have plasma 4 and you are using apper for update management
in that case start apper goto settings (hit the 3 horizontal lines) and chose update frequency

Wow this AM was totally depressing … my system says Plasma
5 on 13.2 and the update notifier says 1362 updates in 690 packages so I came here and read about apper settings. After changing apper to monthly/stable only from hourly/include all even unstable and clicked check for updates 1362 updates changed to 3 in 14 packages 1 recommended 2 security which seams much more reasonable. Rant part (why in the name of sanity would apper install with hourly-unstable … that is clear prescription for making things break). Thanks for the help, hopefully I will have a more stable experience now.

I ended up locking two packages in yast: youtube-download and tellico, that apparently get new a minor version in packman every few hours - at least that’s how it felt.

In system-settings apper is configured to “never” update. It runs, regardless, after each KDE login, which is fine for me.

System is openSUSE 13.2 (x86_64) KDE 4.14.9

It doesn’t.
The default is “daily”, and stable or unstable makes no difference on openSUSE anyway.

You only get “unstable” packages if you manually add unstable repos and switch your packages to them/explicitly install packages from them.