Red screen in text mode

Hi,

*I am not sure which forum section to post this in but I hope this one is appropriate.

For the last 2-3 months I have been using Tumbleweed and recently I downgraded to 13.2. But in both I have been seeing a full red screen (without text) on my main monitor when:

  1. Shutting down - as soon as the X switches to text mode, the whole screen turns red
  2. Pressing CTRL+ALT+F1 while in graphics mode. Then after some seconds spent in text mode the whole screen turns red (no text). Pressing ALT+F7 and back CTRL+ALT+F1 solves the problem and any subsequent switching from X to text mode and back doesn’t show the red screen any more (until the system is rebooted after which the whole thing needs to be repeated if console mode is to be switched to).
  3. Any attempt to suspend/hybernate from KDE Plasma results in that red screen and the machine doesn’t go to sleep at all. So basically it freezes in that red screen and I have to reset it. I suppose there might be some text messages showing behind but can’t see them, so I don’t know how to debug more.

Generally all that doesn’t affect normal work. Only when switching to console mode. Also maybe worth noting: running init 3 goes to text mode without red screen. Also in case that matters: in boot loader config video=2560x1440 (the native main monitor resolution) and vga=844 (as openSUSE has chosen) and everything else works fine with that. The card is NVIDIA GTX680.

Any idea how to solve this?

What video driver?

In Tumbleweed I used the latest one downloaded from nvidia.com.
Now in 13.2 I use the nvidia-gfxG04-kmp-desktop one which comes with the standard repo.


lspci -v -s 01:00.0
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 680] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Gigabyte Technology Co., Ltd Device 353c
        Flags: bus master, fast devsel, latency 0, IRQ 56
        Memory at f6000000 (32-bit, non-prefetchable) [size=16]
        Memory at e8000000 (64-bit, prefetchable) [size=128]
        Memory at f0000000 (64-bit, prefetchable) [size=32]
        I/O ports at e000 [size=128]
        [virtual] Expansion ROM at f7000000 [disabled] [size=512]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Capabilities: [900] #19
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia

[/size][/size][/size][/size][/size]

Maybe try the GO3 flavour it should work with your card. First though double check that all the packages for NVIDIA match and are the correct ones for your kernel

Why do you think it is driver related? As mentioned - in Tumbleweed I used the original drivers from nvidia.com (tried 3-4 different latest versions) and still the problem was there.
Considering everything else works fine - is there any particular reason to test another driver?

Sure won’t hurt to try

It sure sounds video related to me

Do you have a defined xorg.conf file if so maybe try renaming it

Could also be flaky hardware. It does happen you know

I thought it only happened after you down graded from Tumbleweed???

I just did (right after my previous post). And it actually did hurt: It broke the whole X but I recovered by switching back to G04.

Could also be flaky hardware. It does happen you know

No. The hardware is perfect.

I thought it only happened after you down graded from Tumbleweed???

No. I explained that in the OP:

Well to hardware how do you know it is perfect? Something is not switching to text mode gracefully

G03 should be compatible with your card… Oh well

If you boot to recovery mode (advanced in Grub) do you still get the red screen. What about boot straight to terminal??

As a thought check that the cables are well seated. Lose connections can do odd things

Because if it was hardware it would be consistently breaking in text mode and it does not (as explained in 2. in the OP) Which means it is the thing which controls the hardware, i.e. the software.

G03 should be compatible with your card… Oh well

Well…

If you boot to recovery mode (advanced in Grub) do you still get the red screen. What about boot straight to terminal??

Never tried recovery mode.
Bootin straight into terminal would be equivalent to init 3 I guess and there is no red screen in that case.

As a thought check that the cables are well seated. Lose connections can do odd things

No problems with that.

I am guessing it might be somehow related to the vga=844 mode and in that mode something might not be controlling the video as expected. I have tried to find a list of all vga modes but I can’t happen to find one with such high number. The tables around the web usually show lower resolution modes.

heyjoe donned his tin foil hat and penned:

> I am guessing it might be somehow related to the vga=844 mode and in
> that mode something might not be controlling the video as expected. I
> have tried to find a list of all vga modes but I can’t happen to find
> one with such high number. The tables around the web usually show lower
> resolution modes.
>
>

I doubt that the “vga” setting would affect the system after you have reached
the stage where the nvidia modules are loaded as they would take over.

Plus going to init 3 unloads the nvidia stuff and drops you back to frame
buffer.

Now I do not know the cure but it does seem as if the initial drop to
Ctrl+Alt+F1 is what is causing it, does it happen if you drop to another tty
like Ctrl+Alt+F2? or 3 or 4 etc?


Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

Hm. I just made this test:

  1. CTRL+ALT+F2 and I worked for some time on that console. No red screen.
  2. Switched to ALT+F3, worked for some time - again, no red screen.
  3. ALT+F1, worked - no red screen
  4. ALT+F7
  5. CTRL+ALT+F1 and after a few seconds the red screen appeared.

So it happens only when going from X to the first console (which also seems to be the case during shutdown etc). Does that tell anything about the possible reason?

On 2015-07-10 23:26, heyjoe wrote:

> So it happens only when going from X to the first console (which also
> seems to be the case during shutdown etc). Does that tell anything about
> the possible reason?

Rings a bell, yes.
The first one may use a different video mode. Some time ago, openSUSE
set that one with a graphic colour border, and I think the number of
lines and columns was different too than the other terminals. So maybe
VT1 is treated differently.

Also, I remember seeing a warning printed to the log by the nvidia
driver about the console framebuffer not being compatible or something —
sorry, the hardware where I see that is many kilometers away, I can’t
verify the exact wording. But have a look at yours and find out if it is
there :-?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Which log file is that?

Also does anyone know where I can find a full list of vga modes? I am curious to try how it will be with a different one while still keeping the full screen resolution.

heyjoe donned his tin foil hat and penned:

>
>
> robin_listas;2719180 Wrote:
>>
>> Also, I remember seeing a warning printed to the log by the nvidia
>> driver about the console framebuffer not being compatible or something
>
> Which log file is that?
>
> Also does anyone know where I can find a full list of vga modes? I am
> curious to try how it will be with a different one while still keeping
> the full screen resolution.
>
>

HI,

They used to list some of them in the kernel source, not at home for another
30 mins but have a look here and see if it helps:

https://wiki.sabayon.org/index.php?title=HOWTO:_Using_Custom_Framebuffer_Resolution_with_GRUB2

Just off the top of my head have you tried using the:

plymouth.enable=0

Parameter in the kernel, either add it as an extra param on boot grub
advanced settings and if it wirks then edit the bootloader in Yast.

It was carlos who jogged my memory that tty1 can use a pseudo “graphical”
console.

Worth a try?

HTH


Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

Thanks for the idea. Just tried that. The result is:

  1. The OK ] boot messages are a lot less
  2. Switching from X to CTRL+ALT+F1 does not
    show red screen 1. Attempting a Sleep from KDE again resulted in red screen, so hardware reset was necessary

BTW forgot to mention that when attempting to sleep the machine, as soon as the red screen shows the Caps Lock and Scroll Lock start blinking simultaneously. Not sure at all what this means and how it might be related to anything.

As for the vga modes - the highest res I could find online is 1920x. Cannot find a source for 2560x

heyjoe donned his tin foil hat and penned:

>
>
> baskitcaise;2719193 Wrote:
>>
>> plymouth.enable=0
>>
>
> Thanks for the idea. Just tried that. The result is:
>
>
> - The OK ] boot messages are a lot less
> - Switching from X to CTRL+ALT+F1 does not show red screen
> - Attempting a Sleep from KDE again resulted in red screen, so
> hardware reset was necessary

Now you are out of my league here, I never use sleep :slight_smile: as I have never had
it work right and clean shutdown is good enough for me.

>
> BTW forgot to mention that when attempting to sleep the machine, as soon
> as the red screen shows the Caps Lock and Scroll Lock start blinking
> simultaneously. Not sure at all what this means and how it might be
> related to anything.

The blinking lights indicate a kernel crash which is probably due to trying
to sleep/hibernate.

Anything in the logs?

This might be because of your graphics drivers, are you using the Nvidias?
and if so where did you get them ( repository or from Nvidia ).

Have a look in the Hardware forum, there are some posts there and people who
know more than me about the Nvidia gear there.

>
> As for the vga modes - the highest res I could find online is 1920x.
> Cannot find a source for 2560x
>
>

Maybe a “New” experimental feature that is hidden or not documented yet???

:slight_smile:

HTH


Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

Which ones? How do I find what happened in the exact moment of the problem?

This might be because of your graphics drivers, are you using the Nvidias?
and if so where did you get them ( repository or from Nvidia ).

I have given full info about that earlier in this thread.

Maybe a “New” experimental feature that is hidden or not documented yet???

:slight_smile:

Maybe. Maybe not. I don’t know that’s why I am asking and hopefully someone else knows the answers.

Have a look in the Hardware forum, there are some posts there and people who
know more than me about the Nvidia gear there.

If the thread is in the wrong forum - please some mod move it to the right place.

I am not an expert and I really don’t know who and where to ask. So far the only similar issue I have found on Google is on another forum but without a solution:
https://bbs.archlinux.org/viewtopic.php?id=175308

On 2015-07-11 14:26, heyjoe wrote:
>
> baskitcaise;2719193 Wrote:
>>
>> plymouth.enable=0
>>
>
> Thanks for the idea. Just tried that. The result is:
>
>
> - The OK ] boot messages are a lot less
> - Switching from X to CTRL+ALT+F1 does not show red screen
> - Attempting a Sleep from KDE again resulted in red screen, so
> hardware reset was necessary

Maybe tricking sleep to switch to text mode. I might have an idea about
it, I think I did it time ago. Otherwise, suspend/hibernate from VT1 by
command.

>
> BTW forgot to mention that when attempting to sleep the machine, as soon
> as the red screen shows the Caps Lock and Scroll Lock start blinking
> simultaneously. Not sure at all what this means and how it might be
> related to anything.

kernel panic!

But you can not report it, being video related, with the nvidia driver
loaded. It will be ignored.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2015-07-11 10:46, heyjoe wrote:
>
> robin_listas;2719180 Wrote:
>>
>> Also, I remember seeing a warning printed to the log by the nvidia
>> driver about the console framebuffer not being compatible or something
>
> Which log file is that?

It would be /var/log/messages, if you are using syslog. If not, it would
be in systemd journal, which you access via the command journalctl.

> Also does anyone know where I can find a full list of vga modes? I am
> curious to try how it will be with a different one while still keeping
> the full screen resolution.

It depends where you want to set them. During boot (ie, grub), you can
set something like vga=ask and it will prompt you for the number.
Another parameter printed them, maybe vga=list.

I have not tried this in a long time, though, and it was with grub1.
Plymouth might interfere, but /I/ always remove it.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2015-07-11 15:26, heyjoe wrote:
>
> baskitcaise;2719195 Wrote:
>>
>> The blinking lights indicate a kernel crash which is probably due to
>> trying to sleep/hibernate.
>>
>> Anything in the logs?
>>
> Which ones? How do I find what happened in the exact moment of the
> problem?

With experience… :slight_smile:

As to which log, see my previous post, the answer is the same. If you
look at the wall clock, you can find the timestamp near the event in the
log later. But a kernel crash might not be written to disk if it is
sufficiently bad to affect the disk system.

> If the thread is in the wrong forum - please some mod move it to the
> right place.

Dunno, I think this one is right.

> I am not an expert and I really don’t know who and where to ask. So far
> the only similar issue I have found on Google is on another forum but
> without a solution:
> https://bbs.archlinux.org/viewtopic.php?id=175308

Well, you are getting closer :slight_smile:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))