Recurring problem: can't boot after update

I have used opensuse for many years and on desktop computers this problem never happens.

Over the past few years I have a small netbook for work. Initially I had an Asus and now I have an Acer B-117 Travelmate. The problem occurred many times on both of them.

Every time I install the OS from scratch or do a simple online update of a few packages I have a 50-50 chance of not being able to reboot the system. Fresh from the update/install a reboot only displays the following on the screen:

Loading Linux 5.3.18-57-default (or a later version, depending on which one I try)
Loading initial ramdisk …

And that’s it - nothing more happens.

In the past I used to just wait patiently until more updates became available (I saw this on my desktop) and then tried a fresh reinstall on the netbook. Sometimes it even booted. But now this happens so often that I can’t really use my netbook like this.

What is even stranger is this: I have version 5.3.18-57 on a USB stick and when all fails with the latest version I install from this USB stick while disabling network connections, in an attempt to get back to a reliable baseline. Following this basic install my netbook still only boots sometimes and gets stuck after other - apparently identical - installs. What I am saying is that I could do one install that does not work, using the USB version, and then do the same thing again and this time it might work (although in most cases it doesn’t). This is very strange.

How can I diagnose this problem? Has anyone else had a similar experience on small laptops?



That might be a kernel problem – the kernel is not fully compatible with your hardware.

If this is the case, is there any way around this? Should I use a different linux distro, or do they all have this incompatibility in them?
What looks most bizarre is the intermittency of this problem. If the kernel is incompatible, why does it *sometimes *work? It should not work at all.



It might be a good idea to try other distros. But don’t try too hard. Finding which distros work might be useful. Trying with live media might be enough.

When building a kernel, there are options chosen. And perhaps the particular option matter.

Does the 15.3 installer reliably boot?

Have you tried booting the live media at

(That seems to be using kernel 5.3.18-59.16)

The installer always boots without difficulty, as far back as opensuse 11 (I didn’t have a netbook before that version was available).

I have tried live versions in the past and had no problems, either.

I don’t know, of course, which parameters to change on boot. The fact that I get no visual clue to what goes wrong on booting is the main issue here.

As far as other distros go, I know that I had the same problem when I tried Fedora a few months ago, but I haven’t tried other distros yet.

I’ll try the live media you suggested, thanks.


The live version of Leap 15.3 boots up fine, but operates very slowly. Opening Dolphin and closing it both take more than 10 seconds. Starting up Firefox takes about a minute.

The issue I have is beginning to look like an intermittent fault. I am getting the impression that there is something unstable in play here, which sometimes works fine and at other times does not. So I am back to square one: I don’t know how to diagnose the problem and perhaps bypass it.



Yes, I think so. But those are notoriously difficult to track down.


inxi -Fmxxxz

Maybe better, do:

sudo inxi -U

then post:

inxi -Fmayz

The inxi in Leap has lots of brokenness, and is missing multiple improvements.

Have you ever given it a really long time to finish, 10 or 20 minutes?

I have two 64 bit PCs that do this for as many as 15 minutes before proceeding to boot successfully. It began several years ago, and was mitigated somewhat by switching from HDD to SSD. I’ve never seen this happen on a 32 bit PC. I wrote about it here.