Recovery mode stops dead.

Tried to boot in ‘recovery mode’ from both GRUB and GRUB2 and it
reached the line ‘Reached target Graphical Interface’ and went no
further. On pressing [esc] I got the openSUSE splash screen but login
panel never arrived.

I wondered whether there was a problem with the install as I’d seen
some odd messages so tried a second machine on which I’d used a
different installation method. The same thing happened with apart
from [esc] just producing ‘^’ and not switching screens. Only tried
GRUB2 on this one.

Graham P Davis, Bracknell, Berks.
openSUSE 12.3-RC2 (64-bit); KDE 4.10.00; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

I tried that yesterday (for testing something).

After a while, I gave up, and hit CTRL-ALT-F2. That gave me a session where I could login.

Checking later, I did CTRL-ALT-F1, and I could now login there, too.

Still later, after leaving the system idle for a while, I discovered that it was shutdown. I rebooted, and checked the boot logs. They showed “fsck” being run and reporting that the system was not shut down cleanly. There’s probably some BIOS controlled timer that shut the system down, and that is circumvented with a normal boot but not with a recovery boot.