Recover corrupted USB stick data

I have an USB stick with some data I would like to recover. Unfortunately the USB was unplugged while still being mounted on a Windows device and is no longer being mounted.
When I plug it into my OpenSUSE system I hear the sound as if it would be mounted, though nothing pops up. I get a new device when I insert the drive.
I have seen the following

loop0         7:0    0  64,8M  1 loop /snap/gtk-common-themes/1514 
loop1         7:1    0  31,1M  1 loop /snap/snapd/10492 
loop2         7:2    0  55,4M  1 loop /snap/core18/1932 
loop3         7:3    0  93,3M  1 loop /snap/insomnia/118 
loop4         7:4    0 162,9M  1 loop /snap/gnome-3-28-1804/145 
loop5         7:5    0   3,8G  0 loop  
loop6         7:6    0   3,8G  0 loop  
sda           8:0    1   3,8G  0 disk


fdisk -l /dev/sda                                0 
Disk /dev/sda: 3,8 GiB, 4089446400 bytes, 7987200 sectors 
Disk model: Flash Disk       
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 

While I am not sure if the format is vfat, I get

fsck.vfat /dev/sda                               0 
fsck.fat 4.1 (2017-01-24) 
Logical sector size (39032 bytes) is not a multiple of the physical sector size.

Any ideas how I could recover the data?

Run parted -l to confirm filesystem etc but it looks like it’s lost the partition information…

# parted -l                                                               
Error: /dev/sda: unrecognised disk label 
Model: Generic Flash Disk (scsi)                                           
Disk /dev/sda: 4089MB 
Sector size (logical/physical): 512B/512B 
Partition Table: unknown 
Disk Flags:  

Does that mean I won’t be able to recover the data?

As I am not sure you are up-to-date with what people are trying to find out, there are two possibilities:

  1. The device is partitioned. But as neither fdisk nor parted find something that looks like a partition table, there is’nt one (or it is severely corrupted, which is in fact the same as there isn’t one).
  2. The device is not partitioned and the vfat file system you assume there should be on it is severely corrupted as you proved with your fsck.

Well, changes are bad. I think we have now to use your own memory. Do you know if, and when yes how, the device was partitioned. And also what the type of the file system was on the device or on the parttion(s)?

BTW, I am not sure you tried on a Windows system, the place where you say it was connected the last time it worked. After all it is a native Windows file system, thus repairing it on Windows looks to me a better idea then doing it on Linux for which it always will be a strange fellow.

Take a look at “photorec” despite it’s name it is able to recover many different file types.

You’ll find it in the opensuse standard repositories.

Alas, that is to use an USB stick again after you do not need what is still on it (in this case after having used it for an installation ISO).

The OP wants to recover what is on it. He needs it. Thus doing what is in the documenend you pointed him to will definitely destroy any chance to recover anything.

Can you use dd to make an image of it
Eg if it mounts as /dev/sdb or sdc
I’d use dd to make a .iso image of it as see if I could do anything with that. Perhaps actually use: ionice -c3 ddrescue /dev/sd*

Some firms are specialising in data recovery.
If you only lost FAT file tables, then there are good chances to recover info.

Great, that worked. Thanks!