Recording levels too low.

Here is the system info:
OS: Linux 3.4.11-2.16-desktop x86_64
System: openSUSE 12.2 (x86_64)
KDE: 4.8.5 (4.8.5) “release 2”
Snd Card: Asus Xonar DS

I had upgraded to Suse 12.2 and was very pleased with it; then my GRUB became corrupt. I figured the quickest way to deal with that was to do a fresh install. That went well with the exception of one thing. I have a few analog mics that I had worked very well. I plug them directly into the sound card. Now the input level is far too low. I have done recordings with Audacity and this script:

 ffmpeg -f alsa -ac 2 -i hw:0,0 -f x11grab -r 30 -s 1280x720 -i :0.0 -sameq -f mpeg testvideo.mp4

Both worked very well until I did the reinstall. Same machine. Same mics. Same OS. etc.

I installed S.M.A.R.T and this is the information I get from selection 6.

I ran alsamixer in a terminal and cranked everything up.

I also deleted the sound card in Yast and reconfigured it.

Further I tried various configurations with the PulseAudio Volume Control. At first it just confirmed that my mic input was very low even when levels were maxed out. Then, this is a little strange. While I was fooling around with the PulseAudio Volume Control the various devices kept coming up, but the pulsing horizontal blue level bars stopped functioning.

One more thing. I notice if I go to Yast->System Services->Runlevels alsasound has an asterisk (*) next to it in simple mode and in expert mode it is shown as not running. Is this normal? All of my sound works well. It is just the mic input that needs to be boosted.

I have looked around for a solution and not had any success. Thank you for your help.

OK. I found the solution. Here it is for anyone else that has the problem. In fact I probably made it worse goofing around with alsamixer. As I said above, in the mixer I cranked everything - meaning I put it all to the maximum. That was a mistake. Now I have set ALC Maximum Attenuation, ALC Maximum Gain and ALC Target Level all to 0 and I have my mic input back.

Oh ya, the blue bars in PulseAudio returned when I rebooted this morning.