Recording audio from file...


I’d like to be able to record audio from a webstream for later playback, but don’t seem to be able under KDE4.2.

Pulseaudio has been removed and replaced with xine.

I also tried by opening songbird, started playing some music. Then opened sound recorder and hit record. Nothing. I opened Kmix to see whether there was anyway to record from PCM (as works under XP), but this feature isn’t available.

Also, the overall volume through the PC speakers seems very low, even at full volume.

Any help would be greatly appreciated.

As a relative newbie, please reply with any commands you may require to help diagnose.

Thanks in advance.

I usually use the programme Audacity to do what you want. You may this already installed on your computer - if not it can be installed from the opensuse dvd or from the Packman website at:-

PackMan :: Package details for audacity

You need to select the recording source button and press the red button to start recording. There is also a facility - with Audacity - to increase the volume on any recording made.

On the low sound problem - if you click on the mixer button (from the sound tab on the bottom right of your screen) you should be able to increase the settings to make the sound louder.

If you have any problems please post back.

Thanks for the reply,

I tried changing the volume using Kmix but all the settings were already on high. Any other suggestions?

After installing audacity, i couldn’t seem to locate the recording source button you referred to. However I tried to record the audio of a video file I had, but to no avail. Didn’t matter what I tried, still recorded a blank file.

It seems though that I can record from internal or external mic and line sources fine, just not from an internal source.

Changing the aspect in the device toolbar (view/toolbars/device toolbar) didn’t help either.

Under vista, I can select to record from PCM in the mixer, which allows me to record from file, but Kmix or alsa doesn’t offer this feature. Is there any software which will?

Thanks again.

Reference low sound, try going to YaST > Hardware > Sound > Other > Volume and move the volume bars there for PCM and Master volume up to 95%. Close YaST. Then go to kmix and adjust the master and PCM volume levels there. For some hardware you may also have to adjust Speaker volume.

Thanks for that.

I’ve done what you suggested, except for the last part. At the risk of sounding somewhat dim, when you suggest adjusting the speaker volume, would that be a physical volume control on the PC or a software control? if a software control, it doesn’t appear obvious to be where that would be? Unless you mean the one associated with the Fn button?


It depends on the hardware and the alsa version. I intended that “speaker volume” suggestion to be included in the same context as the master/pcm, … ie a “kmix” control. Not every sound device will have a “speaker volume” control in kmix. For example, of the 6 PCs (7 if we count my mother’s) that I have openSUSE installed on, only ONE has “speaker volume” as a kmix control. In this case it is my Dell Studio 15 laptop with 1.0.19/1.0.20 of alsa. On that laptop, if one does not turn up “speaker volume” there will be no volume.

Further to this, users with 5.1 surround systems will need to move the volume up on different mixer controls.

Volume is still very low through the PC speakers, though pretty good through headphones/external powered speakers.

Kmix has a separate level for Master, Front and PCM. Could this indicate I have a 5.1 system? Even if there appears to be no Rear level option?

You need to look at your PC specs. I can’t answer this.

Ofcourse, silly me. Thanks for all your help! Much appreciated.

I am on a windows machine at work but on audacity there is a source button, showing various options stereo mix, cd, line-in etc. That is the bit you need to find.

If you want to copy just the sound from a video file then a good programme to use is audiokonverter. This is available from:-

PackMan :: Package details for audiokonverter

or if you are using kde4

PackMan :: Package details for audiokonverter

Once installed, you just right-click on the video file and select the option to extract the sound to a mp3 file etc.

Back to Audacity - i am at home now and see that by default in opensuse it does not show the source select button. If you select view / toolbars / reset - it will show the source for recording button.

You are da bomb! That is exactly what I was after. Though I’m really stoked to have found the other apps too.

Great work, thanks one & all! :rolleyes::):):stuck_out_tongue:

Oops, spoke to soon…

Works well for my desktop running opensuse 4.1.3, but does nothing for my laptop (the pc in question) running opensuse 4.2.

I’m starting to think that my laptop soundcard is simply not capable of recording from source or soundcard using the linux drivers supplied. Or could it be that the soundcard itself simply doesnt support recording?

So… What command would I use to identify the soundcard and driver associated with it? There maybe an updated version of the driver on-line. I’d also like to google the card’s specs once I can determine what it actually is.

Secondly, if all else fails, can anyone suggest a linux compatible external soundcard that could be plugged in via usb/firewire/pcicia ports, that also supports recording?

Thanks again in advance.


does sound work on your laptop normally (if you play a CD, system sounds, playing a video etc). If so - it might be worth trying all the different mixer options in Audacity. On an old laptop that I have I had a similar problem and the mixer option (that worked) was under a strange name.

I’ve now got the source to work in audacity on the lappy, however it options are only Mic boost, front mic boost, capture, capture 1 & Digital. None seem to work for recording audio from a file playing through the soundcard.

Doesn’t matter what I do, only the Intel device hw0,0 displays the source in audacity.

I’m really starting to believe either the drivers or the card itself just aren’t upto the task.

Hmmmm … A silly question from me: How confident are you that your alsa driver during the boot autoprobe correctly identified the precisely needed configuration of your PCs sound hardware?

Have you been able to do any checks to confirm this (ie run a diagnostic script, and check your hardware audio codec and see if its possible to force a superior configuration, and check dmesg to see if reports any errors on boot, and check for any updates on the alsa web site (to alsa) for your PC’s hardware audio codec and if using KDE4 check to see if you can add any mixer channels that are not currently showing up by default).

Not particularly confident.

Any chance you could post some commands I could run for a diagnostic script?

You could open a terminal or konsole, and with your PC connected to the Internet

  • if using openSUSE-11.1 copy and paste /usr/sbin/
    and post here the URL it gives. Just the URL. You may need to run it as user root the first time (to update the script) and then run a second time to get the URL; or
  • if using openSUSE-11.0 or older, copy and paste wget -O && bash

and post here the URL it gives. Just the URL.

Also provide the output of running the follow commands in a terminal/konsole one at a time:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
with that output, it may be possible to see what hardware audio codec your PC has, see what alsa version it has, search the alsa site to see if there are any alsa driver updates for that codec, check your PCs mixer settings, and check your PCs /etc/modprobe.d/sound file settings.

Ok, so here’s what I got when I entered /usr/sbin/ Git - alsa-driver.git/history - utils/

Then when I run…

rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I get…

linux-4vo8:/home/baldrick # rpm -qa | grep alsa
linux-4vo8:/home/baldrick # rpm -qa | grep pulse
linux-4vo8:/home/baldrick # rpm q libasound2
RPM version
Copyright (C) 1998-2002 - Red Hat, Inc.
This program may be freely redistributed under the terms of the GNU GPL

Usage: rpm -aKfgpWHqV] -aKfgpWHqVcdilPs] -aKfgpWHqVcdilPsaKfgpWHqV] -aKfgpWHqVcdilPsaKfgpWHqV] -aKfgpWHqVcdilPsaKfgpWHqV] -aKfgpWHqVcdilPsaKfgpWHqVK] -aKfgpWHqVcdilPsaKfgpWHqVK] -aKfgpWHqVcdilPsaKfgpWHqVKi] -aKfgpWHqVcdilPsaKfgpWHqVKiv] -aKfgpWHqVcdilPsaKfgpWHqVKiv] -aKfgpWHqVcdilPsaKfgpWHqVKiv?] -a|–all] -f|–file] -g|–group]
-p|–package] -W|–ftswalk] --pkgid] --hdrid] --fileid]
–specfile] --triggeredby] --whatrequires] --whatprovides]
–nomanifest] -c|–configfiles] -d|–docfiles] --dump] -l|–list]
-P|–patches] --queryformat=QUERYFORMAT] -s|–state] --nomd5]
–nofiles] --nodeps] --noscript] --comfollow] --logical]
–nochdir] --nostat] --physical] --seedot] --xdev]
–whiteout] --addsign] -K|–checksig] --delsign] --import]
–resign] --nodigest] --nosignature] --initdb] --rebuilddb]
–aid] --allfiles] --allmatches] --badreloc]
-e|–erase <package>+] --excludedocs] --excludepath=<path>]
–fileconflicts] --force] -F|–freshen <packagefile>+] -h|–hash]
–ignorearch] --ignoreos] --ignoresize] -i|–install] --justdb]
–nodeps] --nomd5] --nocontexts] --noorder] --nosuggest]
–noscripts] --notriggers] --oldpackage] --percent]
–prefix=<dir>] --relocate=<old>=<new>] --repackage]
–replacefiles] --replacepkgs] --test]
-U|–upgrade <packagefile>+] --quiet] -D|–define ‘MACRO EXPR’]
-E|–eval ‘EXPR’] --macros=<FILE:…>] --nodigest] --nosignature]
–rcfile=<FILE:…>] -r|–root ROOT] --querytags] --showrc]
–quiet] -v|–verbose] --version] -?|–help] --usage]
–scripts] --setperms] --setugids] --conflicts] --obsoletes]
–provides] --requires] --suggests] --recommends] --enhances]
–supplements] --basedon] --info] --changelog] --xml]
–triggers] --last] --dupes] --filesbypkg] --fileclass]
–filecolor] --filecontext] --fscontext] --recontext]
–fileprovide] --filerequire] --buildpolicy=<policy>]
–with=<option>] --without=<option>]
linux-4vo8:/home/baldrick # uname -a
Linux linux-4vo8 #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux
linux-4vo8:/home/baldrick # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.bSGbrXaHmp5:Realtek ALC268 audio codec

alias snd-card-0 snd-hda-intel

I hope this helps…