Recommended Nvidia-driver

Hi!
I run OS11.1 on Dell Latitude D830
It have a Nvidia Quadro NVS 140M w/512MB dedicated memory.

I installed the latest Nvidia-driver from Nvidia-repository; version 177.82

This driver is not fully supportet in OS11.1 and have some strange behavior.
If i click on a Shortcut on desktop, it takes 3-5sec before it registre it. KDE4 graphical effects are i kind of slow. Even my old Acer TM4001 with ATI Radeon 9700 feels quicker.

So is there i newer and better Nvidia-driver (Beta) i can try/use?

There are, but not from a repository or from an easy one click install.
You’ll have to do a manual install by grabbing the latest drivers from the NVIDIA site.

How to do install it is described on openSUSE.org/NVIDIA. From my own experience it can make quite a difference in performance.

You might want to download both the beta drivers (that are older than the stable for some reason) as well as the stable. As I can’t install the stable non-beta driver, yet I can install the beta ones… 99% sure that’s just my laptop though.

Hi!
I downloaded Nvidia 180.22 and installed it as root in init 3.
It say that there is no available supported kernel at Nvidias webserver, so it must compile new kernel.

It runs trough installation without any problems and then i have to activate settings with “Sax2 -r -m 0=nvidia”.
Now it failes and in the log-file it says the NVIDIA kernel modules has version 177.82 (old driver) and the driver is for 180.22 (new driver).

Now X does not start at all and yes i tried reboot. What now?

Did you install kernel-source?
zypper install kernel-source (as root)

In order to get a working GUI back, in the console type
yast
which brings up the curses interface of yast, use software management to install and uninstall the nvidia driver.
This should bring you back to the previous (slow) working version.

If you want it give another go, try with the latest beta version listed on the nvidia site… that one worked for me as I mentioned earlier.
(I do have to manually boot into a gui by use of the startx command though, but think that’s related to running kde 4.2 instead of 4.1)

Of course i have Kernel-source and all Linux development tools like make, gcc etc.

I did “sax2 -r -m 0=nv” and got X up again with the OpenSUSE nv-driver. Its working for me now.

You mention Beta-version, but i cant see any link to Beta. What version-number it should have? If you could past me link to the driver, then it will be easy for me to find it.

Hi
Did you ensure the Nvidia repository is disabled and any Nvidia rpms are
un-installed? Then run through the nvidia installer routine.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-pae
up 23:15, 2 users, load average: 0.01, 0.10, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

If the installer does not work, run this command:

nvidia-installer --uninstall

Then I would try the G01 and G02 drivers from the repo. I installed the G02 drivers for my 7950 GT, then ran

nvidia-xconfig

Then I logged out and back in, and I was good to go. YMMV.

Got them from the advanced search, can’t give you a direct link as I’m unaware if you’re running a 64 bits version of openSUSE or not.

Hello!
Now i’ve removed Nvidia-repository and undelete all Nvidia-software/drivers.
I run on OpenSUSE original “nv”-driver and its working, but with no 3D acceleration.

I then tried again to install 180.22 Stable, and now it works! :slight_smile:
Now the delay in clicking on icons are gone and everything seems to work great noe!

Tanx allot!

RS