REcent update (kernel?) killed my DVB-S card (Haupauge/TT 65550 / 94534)


Installed an older TT DVB-S PCI card last summer on a 64bit TW (KDE), simply copied the dvb-ttpci-01.fw to lib/firmware, Kaffeine found the card everything was well, until some recent update killed the card, it doesn’t show up in Kaffeine.

In KInfocenter I had earlier (when the card was up and running):

DVB-card Technotrend/Haupauge DVB card rev 2.3 (modprobe dvb-ttpci)

Now there is only a

Philips Semiconductors SAA7146

modprobe dvb-ttpci 

doesn’t give any output and doesn’t bring the card back in Kaffeine.

dmesg | grep dvb

gives me

   11.466482] dvb-ttpci: gpioirq unknown type=0 len=0
   11.496194] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80002622
   11.496196] dvb-ttpci: firmware @ card 0 supports CI link layer interface
   11.584190] dvb-ttpci: Crystal audio DAC @ card 0 detected
   11.912321] dvb-ttpci: found av7110-0.

Any way to get may card back to live? :frowning:

Many thanks in advance!

I tried the latest .fw from openeELEC, no difference.

Under /dev/dvb I see an adapter0, but all files in the directory (e.g. dvc0, frontend0, video0) have file size of 0 (zero) Bytes…

Please do not tell your conclusions (alone), but show on what they are based so that others can come to their own conclusions. In this case

ls -l /dev/dvb/adapter0

or maybe you did something different, but we do not know. :frowning:

/dev/dvb/adapter0> ls -al
total 0
drwxr-xr-x 2 root root     200 Jan  2 16:53 .
drwxr-xr-x 3 root root      60 Jan  2 16:53 ..
crw-rw---- 1 root video 212, 3 Jan  2 16:53 audio0
crw-rw---- 1 root video 212, 4 Jan  2 16:53 ca0
crw-rw---- 1 root video 212, 0 Jan  2 16:53 demux0
crw-rw---- 1 root video 212, 1 Jan  2 16:53 dvr0
crw-rw---- 1 root video 212, 7 Jan  2 16:53 frontend0
crw-rw---- 1 root video 212, 6 Jan  2 16:53 net0
crw-rw---- 1 root video 212, 5 Jan  2 16:53 osd0
crw-rw---- 1 root video 212, 2 Jan  2 16:53 video0

yep, what else, master?>:)

Looks normal. Why do you think they have a size and that that size is 0 bytes?
IMHO you are on the wrong path in solving your problem when you see strange things here.

So the card is registered? But not there in Kaffeine?

Did they recently increase the security levels in TW? I’m sure I could access the DVB-S card in Kaffeine via VNC (machine is somewhat remote…), did they kick me out of group video? I’m disturbed… :frowning:

upload the entire contents of dmesg to susepaste and then provide a link – we’ll want to see the entire process related to the dvb card, as grepping solely for dvb-ttpci may miss important info

… but from the looks of it (i.e. from your ls output of /dev/dvb) the card is being setup properly, so

  • you could also do some very basic functionality tests to see if the card is working in other software
  • I’m thinking the problem lies else where (kaffeine)

Hy Tyler! I have a quite similar old machine here with TW 64 KDE and a much newer Digital Devices Octopus DVB-S card, which recently after an update lost all TV channels (had to do a re-scan, since then everything is doing fine and channel lock is MUCH, MUCH faster than before). So definitely something changed.

Currently installed: Kaffeine 2.0.5-3.1-x86_64 from openSUSE TW-Oss (priority 99)

…and there is no alternative from packman (priority 66). No idea what I could do about Kaffeine…

With the second machine with the newer DVB-S card I could test that the disappearance of the card is not related to VNC, so back to square one…

What is this susepaste and how to use it? Whenever I go to my FF (lates on TW KDE) says:

Your connection is not secure

The owner of has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. uses an invalid security certificate. The certificate is not trusted because it was signed using a signature algorithm that was disabled because that algorithm is not secure. The certificate is only valid for Error code: SEC_ERROR_CERT_SIGNATURE_ALGORITHM_DISABLED

I have the same. I reported it up the line.

Using Konqueror, it reports the same, but it allows you to ignore the error.
OTOH, as long as this problem exists, posting there isn’t very helpful IMHO, because everybody who wants to see it gets the error :frowning:

I got back that the web master is informed about this and working on it.

…I picked the DVB etc. stuff from dmesg, I think I catched all lines:

   11.163012] snd_ctxfi 0000:05:05.0: chip 20K1 model Unknown (1102:1003) is found
   11.202968] Linux video capture interface: v2.00
   11.226014] tg3 0000:0e:00.0 enp14s0: renamed from eth0
   11.367668] saa7146: register extension 'av7110'
   11.483394] snd_ctxfi 0000:05:05.0: Use xfi-native timer
   11.508550] saa7146: found saa7146 @ mem ffff9918c0d15e00 (revision 1, irq 28) (0x13c2,0x000e)
   11.528015] raid6: sse2x1   gen()  3313 MB/s
   11.596017] raid6: sse2x1   xor()  5083 MB/s
   11.641949] DVB: registering new adapter (Technotrend/Hauppauge WinTV Nexus-S rev2.3)
   11.664098] raid6: sse2x2   gen()  8103 MB/s
   11.672034] Adding 2103292k swap on /dev/sda1.  Priority:-1 extents:1 across:2103292k FS
   11.688984] adapter has MAC addr = 00:d0:5c:xx:yy:zz
   11.732023] raid6: sse2x2   xor()  6187 MB/s
   11.800151] raid6: sse2x4   gen()  9195 MB/s
   11.868039] raid6: sse2x4   xor()  6039 MB/s
   11.868044] raid6: using algorithm sse2x4 gen() 9195 MB/s
   11.868045] raid6: .... xor() 6039 MB/s, rmw enabled
   11.868056] raid6: using ssse3x2 recovery algorithm
   11.950882] xor: measuring software checksum speed
   11.978531] dvb-ttpci: gpioirq unknown type=0 len=0
   11.988106]    prefetch64-sse: 11558.000 MB/sec
   12.012161] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80002622
   12.012164] dvb-ttpci: firmware @ card 0 supports CI link layer interface
   12.028089]    generic_sse: 10361.000 MB/sec
   12.028091] xor: using function: prefetch64-sse (11558.000 MB/sec)
   12.092215] dvb-ttpci: Crystal audio DAC @ card 0 detected
   12.093242] saa7146_vv: saa7146 (0): registered device video0 [v4l2]
   12.109705] Btrfs loaded, crc32c=crc32c-generic, assert=on
   12.110298] BTRFS: device fsid 58a133d2-a641-4fe1-9247-291c87ecea38 devid 1 transid 14853 /dev/sda2
   12.334421] LNBx2x attached on addr=8
   12.334430] av7110 0000:05:06.0: DVB: registering adapter 0 frontend 0 (ST STV0299 DVB-S)...
   12.334620] input: DVB on-card IR receiver as /devices/pci0000:00/0000:00:02.0/0000:01:00.3/0000:05:06.0/input/input9
   12.334904] dvb-ttpci: found av7110-0.
   13.792059] floppy0: no floppy controllers found

I see nothing strange, but the card is not in Kinfocentre (PCI, only the Philips SAA7146) and not in Kaffeine. :frowning:

Did you check whether your user is a member of the video group?

How to check? :slight_smile:



gives me


nothing more, nothing less. But on the second machine I get the same output (users), and that’s enough to register the DVB-S card in Kinfocentre and in Kaffeine.

So I don’t think this is the problem…

If you look at the permissions of the device entries, a user should be a member of the video group. Use YaST’s users and group module to add your user to the video group, reboot and see if Kaffeine sees the devices. Currently your user has absolutely no permissions re. the device.

Ooops, that worked!

But I still don’t understand why on the second machine I don’t need to be in the video group to manage the card in Kaffeine!

Anyway, thousand thanx, you made it work again! rotfl!

Nice. I don’t get the difference between the two systems either, that would need further investigation. Just drew conclusions from the output.

That is nice talking, but no evidence at all shown.

Again, show the permissions of the character special files:

ls -l /dev/dvb/adapter0

and prove that the user is not member of the group video by either



grep video /etc/group

In general we do not believe much of the talking. We believe in what the computer tells you and us.

That’s what the OP already showed in posts #4 en #14. And which led me to my conclusion. :smiley: