Recent Laptop Overheating (12.1, 64-bit)

Hi all,

Does anyone know how I can identify what might have started my laptop overheating.
I feel like it started within the last 2 weeks, but I can’t identify where the cause is.
I have auto online updates coming through daily, and there are no outstanding updates that need applying.
Theorectically, I have the latest of everything, although I know that isn’t always the best thing!

I’m (very) linux-friendly, but I can’t seem to identify the culprit of the overheating.
There was absolutely no overheating before.

I’m running :-
openSUSE 12.1 (64-bit)
linux kernel 3.1.9-1.4-default
kde 4.7.2 “release 5”
AMD E-450 APU + radeon graphics (with loads between 0.05 to 0.45, average’ing at 0.11)
8GB ram (swap space never used)
Bucket loads of disk space available
Internet always connected via WiFi (not cable)
95% of the time I run on the laptop screen, 5% on large 23" external monitor

Running on a Sony VAIO YB35AH, and was perfect from the point of installing 12.1 on a clean system.
Fan is working and kicking out loads of heat…
Fan is clean, air ducts are clean (have checked inside by removing the cover and keyboard)

Have tried multiple boot scenarios with nepomuck disabled, with skype disabled, with dropbox disabled, etc.
Still nothing seems to stop the overheating.

No new hardware has been added to the laptop at all, and nothing new has been plugged in/connected.
Everything is physically the same from the point of installing 12.1

$ sensors (read out)
Adapter: Virtual device
temp1: +64.0°C (crit = +97.0°C)
temp2: +41.0°C (crit = +90.0°C)

Adapter: PCI adapter
temp1: +65.0°C

Adapter: PCI adapter
temp1: +64.9°C (high = +70.0°C)
(crit = +115.0°C, hyst = +115.0°C)

All and any ideas of what to check and report on will be appreciated.
Looking forward to kicking ideas around to get it fixed.


Disabling Skype or Dropbox is not going to help. A couple of questions:

  • Has this been like this from the moment you installed?
  • Did you install the ATI proprietary driver for the video chip

Since installation, the system’s been fine, until recently.

I don’t remember which driver is running, does this tell you? (from Hardware Information) :-

13: PCI 01.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: vSkL.csnyiihLYL1
SysFS ID: /devices/pci0000:00/0000:00:01.0
SysFS BusID: 0000:00:01.0
Hardware Class: graphics card
Model: “ATI VGA compatible controller”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9806
SubVendor: pci 0x104d “Sony Corporation”
SubDevice: pci 0x9082
Driver: “radeon”
Driver Modules: “drm”
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0x3000-0x30ff (rw)
Memory Range: 0xf0200000-0xf023ffff (rw,non-prefetchable)
IRQ: 42 (243863 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009806sv0000104Dsd00009082bc03sc00i00”
Driver Info #0:
Driver Status: radeon is active
Driver Activation Cmd: “modprobe radeon”
Config Status: cfg=no, avail=yes, need=no, active=unknown


So, if I understand right, there’s no software change that could be the reason. One thing to do whenever a machine is overheating, is to check whether the outlets for air may have been obstructed by dust.

ATM the video chip uses the radeon driver. So, not ATI’s fglrx driver. You could give the latter a try to see if things improve. Also: did you enable any desktop effects? Try turning them all off, and report if the situation improves.

OK, thanks. I’ll give those 2 a try… nevery thought to try without desktop effects enabled. Good idea!