recent bios update results in keyboard hotkeys not working (KDE plasma)

I recently updated my system bios due to a bug mentioned here:

As a secondary side effect, I am no longer able to use several function keys. I cannot adjust screen brightness, nor can I disable the wifi card (there may be others, I haven’t tried them all). I can change the settings via plasma widgets. The keys are not recognized in the KDE shortcut mappings. Any advice would be helpful. Thanks.

Do you need to press the Fn key as well before, if yes then check the BIOS settings, if no the likely need to do this…

Yes, I need to press the Fn key beforehand. Fn key is enabled in the bios, and works in windows just fine.

Can you check the boot log for acpi errors/failed services;

journalctl -b --no-pager | egrep "acpi|error"

Here are the related errors and other random stuff:

acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]
Aug 22 09:02:10  kernel: acpi PNP0A08:00: _OSC: platform does not support [AER]
Aug 22 09:02:10  kernel: acpi PNP0A08:00: _OSC: OS now controls [PCIeHotplug SHPCHotplug PME PCIeCapability LTR DPC]
Aug 22 09:02:10  kernel: ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
Aug 22 09:02:10  kernel: ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
Aug 22 09:02:10  kernel: clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
Aug 22 09:02:10  kernel: acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)

The lines with “ACPI Error:” were repeated a bunch of times. I did not include all the duplicates here.

What about loaded modules are their wmi ones loaded? That last entry may be an issue, not sure.

checking dmesg for wmi yields:

Aug 22 09:02:10  kernel: wmi_bus wmi_bus-PNP0C14:03: WQBC data block query control method not found
Aug 22 15:02:13  kernel: input: Dell WMI hotkeys as /devices/platform/PNP0C14:03/wmi_bus/wmi_bus-PNP0C14:03/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input9
Aug 22 15:02:14  kernel: ath10k_pci 0000:6d:00.0: htt-ver 3.60 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1

Could this be caused by a grub configuration issue? My recent bios update was due to a problem with the new shim package, so I’m wondering if there is some other issue with the bootloader. Granted, my knowledge of bootloaders is limited.

Very unlikely, unless you changed the kernel parameters in Yast bootloader. The shim problem you were having is not related to this issue.

Ok, thanks. One more piece of information: Some of the function keys work, but not others. For example, I can toggle the keyboard backlight and change the volume, but the screen brightness and wifi toggle do not work.

If you boot to the previous kernel, do they work? If so, then it might be time for a bug report.

I cannot boot the previous kernel with the current shim. However, after the bios update some of the Fn keys stopped working on the old kernel before I ran the update. So, this kernel or the previous kernel, the result is the same.

Try running mkinitrd as root. This will force new detection of hardware. Yes I know just BIOS changr but that may look like new hardware. Also it should have run with new kernel but it never hurst to run it. Worth a try any way.

The previous kernel cannot be booted, unless secure-boot is first disabled.

Well, I guess this means a bios downgrade is in order, along with a downgrade of shim.

After thinking about this a bit longer, I think I’ll stay away from the bios downgrade. Is this something that needs to be corrected upstream in the kernel, or can I open a bug report for this? Thanks.

Yes, I think that’s wise.

There might be some setting that configures the function keys. I’m not sure where it is. So maybe open a bug report, and perhaps somebody will have a good answer.