Rebuilt TW installation and starting over with VM - problem with using iso download

Trying to start over with new VM and first objective is to install Windows 10 VM.
I have reached step 5 of 5 in creating new VM and having browsed to where I have the downloaded iso I get an error:-

Unable to complete install: 'Cannot access storage file '/home/alastair/Downloads/Computing_&_IT/Computing_Software/Win10_22H2_EnglishInternational_x64.iso': No such file or directory'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 72, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createvm.py", line 2088, in _do_async_install
    installer.start_install(guest, meter=meter)
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 737, in start_install
    domain = self._create_guest(
             ^^^^^^^^^^^^^^^^^^^
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 679, in _create_guest
    domain = self.conn.createXML(initial_xml or final_xml, 0)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib64/python3.11/site-packages/libvirt.py", line 4523, in createXML
    raise libvirtError('virDomainCreateXML() failed')
libvirt.libvirtError: Cannot access storage file '/home/alastair/Downloads/Computing_&_IT/Computing_Software/Win10_22H2_EnglishInternational_x64.iso': No such file or directory

But the file is there so where am I going wrong please?

Do you use a “&” char in the directory name? I would try first with a directory path without such chars…

That looks to me as an HTML construct. What has HTML to do with what you try to do?

And of course & is special to the shell. Thus you have to escape it when you want to use it in a bash command.

My mistake, I used ampersands in haste when sorting out files from lost cloud. Forgot where I was!!!

Not only that, but you did not even take the first action to be token after a “no such file or directory”. And that is checking if it exists.

`ls -l /home/alastair/Downloads/`

It is apparently easier to ask on the forums then to do the most basic checking.

Hi Henk,
I had been using Dolphin not cli and the directory appeared to be where I browsed so my checking, although less than through, appeared to be OK. I had not used cli because this has only been one issue trying to set up VM. I have been getting other strange problems and am not confident.

Fortunately I can at least be confident in getting your admonishments which are always appreciated.

You are welcome (and please take a nap).

Hi Henk,
Planning to start again with VM and at present working with only a single NIC connection but again using Yast2 with KVM server and KVM tools I have kept the installation simple, using a Windows 10 iso (now in the correct directory,) and accepted default network connection.

The installation appeared to run without any errors but the installation window closed and I have no indication of what has been done or where the VM might have been saved. A check of systemd journal indicates that the VM started and then failed. Here is my first stab at looking at the log for the last 100 lines:-

alastair@HP-Z640-1:~> sudo journalctl -rn 100
[sudo] password for root: 
Oct 05 15:30:31 HP-Z640-1 sudo[25536]: pam_kwallet5(sudo:session): pam_kwallet5: not a graphical session, skipping. Use force_run parameter to ignore this.
Oct 05 15:30:31 HP-Z640-1 sudo[25536]: pam_kwallet5(sudo:session): pam_kwallet5: pam_sm_open_session
Oct 05 15:30:31 HP-Z640-1 sudo[25536]: pam_unix(sudo:session): session opened for user root(uid=0) by alastair(uid=1000)
Oct 05 15:30:31 HP-Z640-1 sudo[25536]: pam_kwallet5(sudo:setcred): pam_kwallet5: pam_sm_setcred
Oct 05 15:30:31 HP-Z640-1 sudo[25536]: alastair : TTY=pts/7 ; PWD=/home/alastair ; USER=root ; COMMAND=/usr/bin/journalctl -rn 100
Oct 05 15:30:27 HP-Z640-1 sudo[25536]: pam_kwallet5(sudo:auth): pam_kwallet5: Refusing to do anything for the root user
Oct 05 15:30:27 HP-Z640-1 sudo[25536]: pam_kwallet5(sudo:auth): pam_kwallet5: pam_sm_authenticate
Oct 05 15:29:13 HP-Z640-1 plasmashell[7727]: Could not find the Plasmoid for Plasma::FrameSvgItem(0x56294be6ac00) QQmlContext(0x56294b308010) QUrl("file:///usr/>
Oct 05 15:29:13 HP-Z640-1 plasmashell[7727]: Could not find the Plasmoid for Plasma::FrameSvgItem(0x56294be6ac00) QQmlContext(0x56294b308010) QUrl("file:///usr/>
Oct 05 15:28:30 HP-Z640-1 pcloud[8000]: Update for linux-x64-prod-v1.14.0 is not available
Oct 05 15:25:58 HP-Z640-1 systemd[7528]: Started Konsole - Terminal.
Oct 05 15:24:19 HP-Z640-1 systemd[1]: snapperd.service: Consumed 2.259s CPU time.
Oct 05 15:24:19 HP-Z640-1 systemd[1]: snapperd.service: Deactivated successfully.
Oct 05 15:23:59 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 152 (BadDamage), sequence: 46613, resource id: 10576602, major code: 143 (DAMAGE), minor code: 3>
Oct 05 15:23:59 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 152 (BadDamage), sequence: 46609, resource id: 10576590, major code: 143 (DAMAGE), minor code: 3>
Oct 05 15:22:36 HP-Z640-1 systemd[1]: Started DBus interface for snapper.
Oct 05 15:22:36 HP-Z640-1 dbus-daemon[1232]: [system] Successfully activated service 'org.opensuse.Snapper'
Oct 05 15:22:36 HP-Z640-1 systemd[1]: Starting DBus interface for snapper...
Oct 05 15:22:36 HP-Z640-1 dbus-daemon[1232]: [system] Activating via systemd: service name='org.opensuse.Snapper' unit='snapperd.service' requested by ':1.1214'>
Oct 05 15:18:30 HP-Z640-1 pcloud[8000]: Update for linux-x64-prod-v1.14.0 is not available
Oct 05 15:17:50 HP-Z640-1 systemd[1]: virtnetworkd.service: Unit process 12171 (dnsmasq) remains running after unit stopped.
Oct 05 15:17:50 HP-Z640-1 systemd[1]: virtnetworkd.service: Unit process 12170 (dnsmasq) remains running after unit stopped.
Oct 05 15:17:50 HP-Z640-1 systemd[1]: virtnetworkd.service: Deactivated successfully.
Oct 05 15:17:50 HP-Z640-1 systemd[1]: virtstoraged.service: Deactivated successfully.
Oct 05 15:17:50 HP-Z640-1 systemd[1]: virtnodedevd.service: Deactivated successfully.
Oct 05 15:16:56 HP-Z640-1 systemd[1]: snapperd.service: Consumed 3.577s CPU time.
Oct 05 15:16:56 HP-Z640-1 systemd[1]: snapperd.service: Deactivated successfully.
Oct 05 15:16:06 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 152 (BadDamage), sequence: 19743, resource id: 10574225, major code: 143 (DAMAGE), minor code: 3>
Oct 05 15:16:06 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 152 (BadDamage), sequence: 19739, resource id: 10574213, major code: 143 (DAMAGE), minor code: 3>
Oct 05 15:15:50 HP-Z640-1 systemd[1]: systemd-hostnamed.service: Deactivated successfully.
Oct 05 15:15:49 HP-Z640-1 avahi-daemon[1231]: Registering new address record for fe80::fc54:ff:fe51:af01 on vnet3.*.
Oct 05 15:15:49 HP-Z640-1 avahi-daemon[1231]: New relevant interface vnet3.IPv6 for mDNS.
Oct 05 15:15:49 HP-Z640-1 avahi-daemon[1231]: Joining mDNS multicast group on interface vnet3.IPv6 with address fe80::fc54:ff:fe51:af01.
Oct 05 15:15:49 HP-Z640-1 kwin_x11[7678]: kwin_core: Failed to focus 0x2e00008 (error 8)
Oct 05 15:15:48 HP-Z640-1 NetworkManager[1389]: <info>  [1696515348.6629] device (vnet3): state change: unavailable -> disconnected (reason 'none', sys-iface-st>
Oct 05 15:15:48 HP-Z640-1 NetworkManager[1389]: <info>  [1696515348.6620] device (vnet3): state change: unmanaged -> unavailable (reason 'connection-assumed', s>
Oct 05 15:15:48 HP-Z640-1 systemd[1]: Started Virtual Machine qemu-4-win10-4.
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/resolv.conf` (14)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/nsswitch.conf` (7)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/group` (3)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/nsswitch.conf` (7)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/passwd` (1)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring directory `/etc` (2)
Oct 05 15:15:48 HP-Z640-1 nscd[1251]: 1251 monitoring file `/etc/nsswitch.conf` (7)
Oct 05 15:15:48 HP-Z640-1 systemd-machined[1258]: New machine qemu-4-win10-4.
Oct 05 15:15:48 HP-Z640-1 systemd-udevd[872]: Configuration file /etc/udev/rules.d/54-smfp_hp.rules is marked executable. Please remove executable permission bi>
Oct 05 15:15:48 HP-Z640-1 virtqemud[6571]: getaddrinfo failed for 'HP-Z640-1': Name or service not known
Oct 05 15:15:48 HP-Z640-1 NetworkManager[1389]: <info>  [1696515348.5696] manager: (vnet3): new Tun device (/org/freedesktop/NetworkManager/Devices/9)
Oct 05 15:15:48 HP-Z640-1 kernel: vnet3: entered promiscuous mode
Oct 05 15:15:48 HP-Z640-1 kernel: vnet3: entered allmulticast mode
Oct 05 15:15:48 HP-Z640-1 kernel: virbr0: port 2(vnet3) entered disabled state
Oct 05 15:15:48 HP-Z640-1 kernel: virbr0: port 2(vnet3) entered blocking state
Oct 05 15:15:25 HP-Z640-1 kwin_x11[7678]: kwin_core: Failed to focus 0x2e001a7 (error 8)
Oct 05 15:15:20 HP-Z640-1 systemd[1]: Started Hostname Service.
Oct 05 15:15:20 HP-Z640-1 dbus-daemon[1232]: [system] Successfully activated service 'org.freedesktop.hostname1'
Oct 05 15:15:20 HP-Z640-1 systemd[1]: Starting Hostname Service...
Oct 05 15:15:20 HP-Z640-1 dbus-daemon[1232]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.serv>
Oct 05 15:15:08 HP-Z640-1 systemd[1]: Started Virtualization nodedev daemon.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: Starting Virtualization nodedev daemon...
Oct 05 15:15:07 HP-Z640-1 dnsmasq-dhcp[12170]: read /var/lib/libvirt/dnsmasq/default.hostsfile
Oct 05 15:15:07 HP-Z640-1 dnsmasq[12170]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 names
Oct 05 15:15:07 HP-Z640-1 dnsmasq[12170]: read /etc/hosts - 10 names
Oct 05 15:15:07 HP-Z640-1 systemd[1]: Started Virtualization network daemon.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: Starting Virtualization network daemon...
Oct 05 15:15:07 HP-Z640-1 systemd[1]: virtnetworkd.service: This usually indicates unclean termination of a previous run, or service implementation deficiencies.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: virtnetworkd.service: Found left-over process 12171 (dnsmasq) in control group while starting unit. Ignoring.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: virtnetworkd.service: This usually indicates unclean termination of a previous run, or service implementation deficiencies.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: virtnetworkd.service: Found left-over process 12170 (dnsmasq) in control group while starting unit. Ignoring.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: Started Virtualization storage daemon.
Oct 05 15:15:07 HP-Z640-1 systemd[1]: Starting Virtualization storage daemon...
Oct 05 15:14:54 HP-Z640-1 systemd[1]: Started DBus interface for snapper.
Oct 05 15:14:54 HP-Z640-1 dbus-daemon[1232]: [system] Successfully activated service 'org.opensuse.Snapper'
Oct 05 15:14:54 HP-Z640-1 systemd[1]: Starting DBus interface for snapper...
Oct 05 15:14:54 HP-Z640-1 dbus-daemon[1232]: [system] Activating via systemd: service name='org.opensuse.Snapper' unit='snapperd.service' requested by ':1.1204'>
Oct 05 15:14:53 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 152 (BadDamage), sequence: 8091, resource id: 10571803, major code: 143 (DAMAGE), minor code: 3 >
Oct 05 15:14:46 HP-Z640-1 systemd[7528]: app-systemsettings-5060b8856abd49ffbda87624e3efef17.scope: Consumed 2.207s CPU time.
Oct 05 15:14:46 HP-Z640-1 kwin_x11[7678]: kwin_core: XCB error: 3 (BadWindow), sequence: 7251, resource id: 10573131, major code: 129 (SHAPE), minor code: 6 (In>
Oct 05 15:14:37 HP-Z640-1 plasmashell[7727]: kf.networkmanagerqt: void NetworkManager::ConnectionPrivate::onPropertiesChanged(const QVariantMap&) Unhandled prop>
Oct 05 15:14:37 HP-Z640-1 KeePassXC-2.7.6-x86_64.AppImage[7998]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 akonadi_maildispatcher_agent[8241]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 akonadi_sendlater_agent[8274]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 kded5[7677]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 akonadi_followupreminder_agent[8232]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 akonadi_notes_agent[8271]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 akonadi_mailmerge_agent[8260]: "Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/2”"
Oct 05 15:14:37 HP-Z640-1 systemsettings[20988]: kf.networkmanagerqt: void NetworkManager::ConnectionPrivate::onPropertiesChanged(const QVariantMap&) Unhandled >
Oct 05 15:14:37 HP-Z640-1 kded5[7677]: kf.networkmanagerqt: void NetworkManager::ConnectionPrivate::onPropertiesChanged(const QVariantMap&) Unhandled property ">
Oct 05 15:14:37 HP-Z640-1 ksystemstats[7827]: kf.networkmanagerqt: void NetworkManager::ConnectionPrivate::onPropertiesChanged(const QVariantMap&) Unhandled pro>
Oct 05 15:14:37 HP-Z640-1 NetworkManager[1389]: <info>  [1696515277.4090] audit: op="connection-update" uuid="1b316f6c-37c5-35f8-b5d1-7fc69d1d5066" name="eno1" >
Oct 05 15:14:37 HP-Z640-1 polkit-kde-authentication-agent-1[7797]: Finish obtain authorization: true
Oct 05 15:14:37 HP-Z640-1 polkitd[1242]: Operator of unix-session:24 successfully authenticated as unix-user:root to gain TEMPORARY authorization for action org>
Oct 05 15:14:37 HP-Z640-1 polkit-kde-authentication-agent-1[7797]: polkit_qt_listener_initiate_authentication_finish callback for  0x55a34fd7a680
Oct 05 15:14:37 HP-Z640-1 polkit-kde-authentication-agent-1[7797]: Listener adapter polkit_qt_listener_initiate_authentication_finish
Oct 05 15:14:37 HP-Z640-1 polkit-kde-authentication-agent-1[7797]: Finishing obtaining privileges
Oct 05 15:14:37 HP-Z640-1 polkit-kde-authentication-agent-1[7797]: Completed:  true
lines 46-100/100 (END)

It does seem there is a problem but now I am stuck and am tired already!

I have no idea why you address me for this. But when you want comment from me: when you are tired, then go to bed first.
Then look with fresh energy at your problem. And when you really have looked to it from all sides and tried to understand messages (e.g. by consulting man pages), the formulate off line a new topic for the forums. Do not tell any fairy-tales without proper evidence from computer commands with output. When you think you have formulated a good problem case (including: what did I do, what did I expect to happen, what happened instead) then go for something different and take e.g. lunch.

Back from lunch, look at your case again. Read it from top to bottom. Is it consistent, has it a logical flow, should any body with openSUSE knowledge, but without any knowledge how you have configured and use the system be able to understand this. Only after you are satisfied, then compose a good title, choose the best fitting category and start the new thread.

P.S. I have no idea about your technical question. In any case I think it should be in a new thread/topic.