Reboot/Log Off/Shutdown Error (13.1): fixing recursive fault but reboot is needed

I have several PCs running 32-bit versions of 12.3 (all identical hardware) and have recently attempted to upgrade (ie. upgrade, NOT new installations) two of them to 13.1.

Both exhibit the same error if I attempt to log out, shutdown or reboot. Screen displays text, freezing at the statement ‘Fixing recursive fault but reboot is needed’.

I guess I could attempt a fresh installation on one of them, but that’s a mission as I have to then re-install all additional software, LDAP, NFS etc etc and I would prefer avoiding this. And before I consider this option, anyone have any suggestions?

I am slightly more concerned because a search for this seems not to identify this as a common or recent problem, yet I have two PCs that have failed since upgrading last week.

64-bit upgrades have no such issues so far.

Did you do the updates? There are known problems with the 32 bit out of the box

Yes, decided to give it a couple of weeks and did full update on both yesterday, but same issues.

What video card and what drivers?

The PCs are the small paperback-book sized devices that attach to the rear of the monitor, nice for counter-top PoS terminals. I know their Intel graphics are not the most widely supported in Linux circles, but they have worked OK to date. They actually work now, after the 13.1 update, although they do seem a little more sluggish than when they were running 12.3. We can use them but as soon as the User logs off for the day, we then get the error message and a ‘press reset button’ restart is not good, at least not EVERY day.

VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09)
Subsystem: Foxconn International, Inc. Device 0d7d
Kernel driver in use: gma500
Kernel modules: gma500_gfx

When I say they are ‘sluggish’ I don’t necessarily mean through the GUI interface. I am remotely viewing one through a terminal (YaST) and it’s much slower than those still running 12.3. There are no obvious issues in ‘top’ that I can see.

Seems like there’s a know bug relating to my problem…

I have a similar experience and the same error message on Shutdown.
I had no trouble with 64 bit Opensuse 12.2.
I updated to 64 bit Opensuse 13.1 with a clean install. It boots and runs well but will not shut down. It hangs at that error message and I have to disconnect power to turn it off.
The hardware processor is Intel Atom D2700.

Would be grateful for any solution??

I believe it’s down to the Intel Atom and limited support from most, if not all varieties of Linux. Given that 13.1 was released some time ago I am guessing that fixing this issue isn’t a major priority and I suppose there is a risk it may never be fixed.

I have tried a system update and a fresh installation and I get the same issues.

I tried Ubuntu 13.1 and got the same result. My guess is that it is something to do with the kernel and not the distribution.
I hope the bug is fixed because I intend to use my intel atom machines for a few years yet.
I will see if it occurs if I load 64bit OpenSuse 12.3 on my Atom D2700 machine.