Reboot issue

My laptop doesn’t reboot . It shuts down (to some extent) but still the DELL and Leap logos are shown. I have to hold the power button to power off the laptop completely and then I can boot again.

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-57-default
OS Type: 64-bit
Processors: 8 × 11th Gen Intel® Core™ i7-1185G7 @ 3.00GHz
Memory: 15,4 GiB

How long did you wait? Most likely some service takes time to stop, press ESC, you will see more details. Or disable plymouth when booting (plymouth.enable=0 on kernel command line).

I pressed ESC just to be sure that everything was stopped (and indeed, that can take some time). Then it says “target reboot reached” or something like that, but it doesn’t reboot. I will try with disabling Plymouth.

Disabling Plymouth didn’t help.
I remember I had the same problem after an upgrade (many years ago) and then I solved it with setting some acpi parameter (if I remember well), but I don’t know which one.

It was not meant to fix anything. It was meant to provide more information by not hiding output on the screen. Boot with plymouth disabled and delete “quiet” kernel parameter and then post photo of screen when it stops.

OK. I did that, and now I see the same as when pressing ESC. It ends with

 OK ]  Reached target Shutdown.
 OK ]  Reached target Final Step.  
 OK ]  Finished Reboot.
 OK ]  Reached target Reboot.

But it doesn’t reboot…

Can I include the photo directly in a post, instead of via an UR (or where can I upload the photo)?

I too have had the same issues with newer kernels and Dell Laptops. I use MATE desktop and see the exact same issue - sometimes the Dell Logo appears and sometime it is just hung until I press the power button to turn it off. Doesn’t matter if I want to reboot or power off.

I created this script to solve the issue. Like init you call it with a 0 to power off or with a 6 to reboot.
It doesn’t do anything if you don’t call it with a 0 or 6

sleep 1
sync ; sync ; sync
if  $1 -eq 0 ]]
echo 1 > /proc/sys/kernel/sysrq; echo o > /proc/sysrq-trigger
if  $1 -eq 6 ]]
echo 1 > /proc/sys/kernel/sysrq; echo b > /proc/sysrq-trigger
sleep 15

I would expect more. Could you boot with “systemd.log_level=debug plymouth.enable=0” added to and “quiet” removed from kernel command line and post photo when it stops?

Can I include the photo directly in a post, instead of via an UR (or where can I upload the photo)?

Upload to

Here it is

(I tried it already yesterday with the susepaste command, but I received an error (with no explanation). I thought that I could only paste text and no images, but the reason of the error was that the image size was too large.)

I was about to look for acpi kernel parameters (as these solved the problem earlier), but finally I installed a new kernel from the Kernel:/stable repository, namely 5.12.6-1.gfe25271-default (also for solving other issues).

Shutdown and reboot work fine now.