Reboot freezes PC at BIOS screen

I have a problem where my PC will stop at the BIOS logo screen after a reboot. The keyboard and mouse don’t get power ie no lights.
I can power off / on and it will boot normally. The problem started after a fresh install and after installing the updates. ie before updates I could
reboot and it was ok.
I moved from Slackware and have Win7 and they don’t have this problem. Also Ubuntu and Arch rebooted normally when I tried them.
I have Opensuse 11.4 x64 on it’s own HDD (Samsung F3) The system board is an Asus P8P67 Deluxe (Sandy Bridge) and the HDD is on a SATA3 port.
Could it have something to do with the EFI BIOS? Would it be worth trying a newer kernel? it may better support my hardware.
I’m hesitant as I don’t want to break Lirc as it took awhile to get it working properly on the stock kernel.

Also where can I add ‘/etc/init.d/lirc restart’ so I don’t have to run it manually every time time I launch XBMC. I couldn’t find ‘rc.local’


I found the following solution to get a rc.local. You must be root to create the rc.local file and must be root in terminal to use chmod to make it executable and to add it in to the startup files.

The solution for your problem is very simple, do it yourself:

  • create your own /etc/init.d/rc.local as root (you know how, right?)
  • write whatever you need on it, but place a preamble at the very beginning:


Provides: rc.local

Required-Start: $network $syslog

Required-Stop: $network $syslog

Default-Start: 3 5

Default-Stop: 0 1 2 6

Description: whatever


  • then chmod 755 rc.local
  • and finally chkconfig --add rc.local

If your screen freezes with the BIOS boot message, but only when trying to load openSUSE, you would think that there is some sort of issue with the hard drive you loaded openSUSE on. Further, it is strange that in one startup method it works and with another it does not. How old is this hard drive and is it really SATA III or is it just SATA II plugged into a SATA III port? That chipset normally has four SATA II’s and two SATA III’s, though ASUS could add anything else it wants to the motherboard.

Thank You,

The equivalent of rc.local under openSUSE is /etc/init.d/after.local. This file already exists on 11.4 (had to be created on 11.3). Put here the commands you want to be executed at the end of the init process and in /etc/init.d/boot.local the ones that should be run at the end of the boot process, before entering the runlevels - although it’s unlikely that you’ll need to run anything before init.

Thanks for the reply. I’ll try the ‘/etc/init.d/after.local’ and see how it goes.
From a cold boot it starts opensuse normally. I can’t work out why it stops at the BIOS screen after I reboot. It looks like the keyboard and mouse don’t recover from the reboot ie no power, I can see the fans spinning.
The drive is 6months old and is on the 2nd sata3 port. I have Win7 on the 1st sata3 port (G.skill 120GB SSD) and 2x 2TB Samsung F4’s on 2 of the Intel sata2 ports. I have my DVD writer on one of the Marvel sata3 ports. All my HDD’s are sata2 and use sata2 cables.
After installing opensuse I rebooted and then ran the update. I rebooted again and then I got the problem. I did another install and it did the same thing again. I’ve checked my copy of opensuse and it checks out ok.

Hi, cheers. I’ll give that a try.

Just tried the following
I installed a new kernel (3.0.4) and the problem persists.
I tried both the gnome and kde live cd’s, if I reboot without installing I get the same problem - stops at BIOS screen. I tried another ‘linux’ live cd and it works.
Is there a log I can look at that records the last actions before a power off and/or a reboot.
And using ‘after.local’ works perfectly - cheers.

On 09/02/2011 01:36 AM, boost3d wrote:

might be the problem, might not…

i’d never heard of EFI BIOS so i read a little and i think you may need
to chat with the devs…its kinda sounding like a corner case bug to me…

devs almost never come here (this is a forum of users helping users,
there is a wide range of expertise, but few here that i know are EFI

i suggest you keep checking back for useful info here, but also reach
out to the generally higher technical level folks you find on IRC or
mail list, entryways to both are here:

i’d say or IRC should do the trick…but you
might begin by search the bugzilla for it, here: [they moan a lot if you ask about a known bug]

url= Dilbert

Cheers DD, I’ll give that a go after I’ve checked the BIOS. It’s not a major problem, I don’t need to reboot often - only to use one last app I’m trying to find a replacement for in linux (myphoneexplorer) may try it with wine.
Once I’ve sorted this I can move opensuse to my SSD, been reading the opensuse doco on SSD’s.

I have an on-board LED to display system status (forgot about it) I’ll compare the code for a cold boot and a reboot.
Also I have the ‘EPU’ switch enabled - Quote from manual ‘Turning this switch to Enable will automatically detect the current PC loadings and intelligently moderate the power consumption’
I enabled it when I built the PC so I didn’t have to worry about the OS controlling the fans etc. It allowed me to have the BIOS controlling the FANS, I set the min and max fan speed and min and max temp.
With this I also didn’t need to install the Asus management software. I’ll try a reboot with this option disabled.