Reboot and shutdown in Kde Plasma don't work anymore

Since a few days after one of the latest updates in Tumbleweed shutdown and reboot in Plasma stopped working. I usually used the key combination to shutdown without questions, and this was the fastest way to shut down. But since a few days the system doesn’t shutdown but goes back to the log in screen. If I then click on the shutdown of reboot button it works as expected. This is quite annoying and I hope someone has found a solution, that is, if more people experienced the problem. This happens with any way of shutting down or rebooting in Plasma (xorg version) Has anyone been having the same problem? Any solution?

I have two systems with Tumbleweed and both have the same problem. I already filed a bug report but haven’t heard anything since.

Thanks in advance

I never do it like this and maybe there are many people are like me. Thus they do not know what key combination that is. Nevertheless people are willing to try to help you by e.g. testing this on their own system to reproduce your problem. But not knowing what to do makes this difficult.

In other words, never assume that all people are doing things like you do them (after all, Linux is about choice),nor that people that are doing things diferent then you will not able to help. Always describe exact what you do (our crystal globes are down due to a virus ;)).

This seems to be affecting a few “edge cases” and has been acknowledged by David Edmundson (KDE Developer)

Currently the exact reason is unknown, but it is thought kmserver is crashing.

See this bug report : https://bugs.kde.org/show_bug.cgi?id=422870

Fixed: https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/101

Should make it’s way to TW in a while.

Henk,

In the Plasma shortcuts list, there is an option called “shutdown/reboot without confirmation” which are by default Ctrl + Alt + Shift + Page Down/Up (or Ctrl + Alt + Page Down/Up) in KDE.

I’m pretty sure thsi is what the OP is talking about. I never use this myself personally, I personally go through all of my installation to in fact disable it because I curse frequently whenever I press the key combination by accident.

Thats is all nice when you have found it, but what I want to tell to the OP is that he should make clear what he does in his problem description and not expect that others go and explore the whole of KDE to see if they can find what the OP has chosen to do amongst the myriad of possibilities. I assume that one should try to make it potential helpers as easy as possible to understand what is done, despite the fact that I have seen those helpers spend considarable amounts of time to find out what is going on where an OP could have explained that in one sentence.

Irrespective of which key combination the OP was referring to, if you were unlucky enough to be hit by bug 422870 – Reboot and shutdown result in logout the system would fail to shutdown/reboot, one would be logged out and returned to the SDDM (or whatever) login screen. A typo in the source code resulted in a potential race condition, some systems were unaffected, others consistently, and some randomly.

People may want to remember the following commands which can be run from any elevated console

systemctl poweroff
systemctl reboot

Reasons to use the above instead of more usual GUI menu options

  • If the Desktop has a bug like what is described in this thread
  • If you support numerous OS and Desktops, and want a universal way to execute a shutdown or reboot no matter the system
  • You want a quick shutdown or reboot. It’s common for Desktops to insert a “wait” to allow services to stop to avoid losing data. I’m pretty sure (haven’t followed up on what I researched years ago) that these commands won’t finalize until other running systemd services have stopped. If you’re running a database app you should be shutting down that app manually anyway. The “wait” command a Desktop might do is not a good substitute and can still lose data

There are also older, legacy commands that should still work, but as long as we are running systemd, I’d recommend the commands in our current OS.

TSU

I notice the following in /sbin (on my 15.1 system):


poweroff -> /usr/bin/systemctl
...
reboot -> /usr/bin/systemctl

So a simple poweroff or reboot (in an elevated console) is enough, correct? (shutdown -> /usr/bin/systemctl is in there, too, among others.)

Yes, that is the compatibility systemd has build in to make conversion easy.

When you run a command:

command argument1 arg2

the command itself receives a copy of the command line (parsed into components). So it sees the command name by which it was called.

When you use the “reboot” command, that calls “systemctl”. But the “systemctl” command notices that it was called using the command name “reboot”. And, because of that, it reboots the system.

According to the journal dracut-shutdown.service runs, see: man dracut-shutdown.service.

I was only trying to explain the part about “reboot” being a link to “systemctl”. That can be confusing to people not familiar with unix/linux ways of doing things.

Have the same issue. After plasma update few days ago…

I have seen this with some updates to NVIDIA driver. Here it is temporary and a reboot fixes it. Pressing CTRL-ALT-BACKSPACE twice will shut down KDE back to log in and either a reboot or re login will fix it.