Realtek wifi card randomly disconnects on tumbleweed and requires a reboot to work again

I have a lenovo ideapad laptop with the following realtek wifi card:

sudo lspci -nnk | grep -iA3 net
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b852]
        Subsystem: Lenovo Device [17aa:4853]
        Kernel driver in use: rtw89_8852be
        Kernel modules: rtw89_8852be

The problem I’m having is that on tumbleweed the card randomly disconnects from wifi and I cannot get the network to work without a reboot (turning the card off and on in the kde gui doesn’t help).

I found the rfkill command and I could see if the card is soft locked with it and try to unlock it if the card disconnects again, but it works now so I can’t check.

Here’s the journalctl output after starting firefox (it disconnected like a minute after starting the browser but the issue doesn’t seem like it has something to do with firefox): openSUSE Paste

Somewhere around the end of the log file I turned wifi on and off several times with the kde gui to get some more information if that helps.

Thanks for help

Maybe this is helping:


Thanks for replying. I will try the modprobe fix tomorrow but the card disconnects randomly so I don’t know when it will break next time (after last reboot it worked for a session of over 3 hours with no problems). The arch forum link mentions something about a fix in a future kernel release, does that mean that the developers are already working on a solution (sorry if it’s a dumb question, but I’m still pretty new to linux)? I don’t need the laptop right now as I use a desktop daily, so I could wait to see if newer kernel itself fixes the issue.

I do not know, if/when a patch will be there.

you can use rtw89 from the Hardware Repo, but if you have enabled secure boot, you have to download the key by yourselve and add them to to mok Database.

Or you use the rtw89 from my Hardware Repo (its the same as in the openSUSE Hardware Repo, sources from Larry Finger), I offer a uefi key as rpm and you can add the key easy by rebooting.

How to add a key to mok Database:
(I think there will be a new certificate in a few hours)