realtek SD card reader not recognized

The SD card reader is not recognized on my laptop. The vendor is realtek. Does anyone know if there is a driver that can be downloaded or some other work around to get the SD card reader working?

lspci output:

6c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5260 (rev 01)


Thanks.

I guess I’ll take this to mean there is no linux driver for this card reader.

Hi
I’m guess this is a fairly new system? Can you posu the full output of lspci;


/sbin/lspci -nnk | grep -A3 5260

I would take a guess it’s the rtsx_pci, but doesn’t have your ID in the kernel (yet).

A bug report might be the way to go?
openSUSE:Submitting bug reports - openSUSE

Yes, it’s fairly new. It’s a Dell precision 7530.
Output of lspci:

6c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5260] (rev 01)
        Subsystem: Dell Device [1028:0831]
6d:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
        Subsystem: Dell Device [1028:0310]

I’ll fill out a bug report.

Hi
So I see it’s in the later kernel, hopefully they will backport…


/sbin/modinfo rtsx_pci |grep 5260

alias:          pci:v000010ECd00005260sv*sd*bcFFsc*i*

uname -a
Linux grover 4.20.6-1-default #1 SMP PREEMPT Thu Jan 31 07:37:50 UTC 2019 (463cfd2) x86_64 x86_64 x86_64 GNU/Linux

Thanks for the info. I have a few other unknown devices in my hwinfo output. I was going to install the newest kernel to test what else is now recognized but I’m not sure how to go about that. Doing a distribution upgrade to the kernel-stable repo wants to uninstall my existing kernel, which I’d like to avoid, but just installing the standalone kernel does not update grub so the kernel won’t load. How do I add the new kernel to grub?

Thanks.

Hi
No zypper dup required, you should be able to just;


 zypper in kernel-default --from <the repo number>

It will pull in the required files…

Yes, but that results in a boot error stating something to the effect of “must load kernel first.” I tried it, I can’t boot the new kernel unless I do zypper dup, which uninstalls the old one.

Hi
OK, so I added the kernel:stable repository (I’m assuming you added the same one as me?);


zypper ar -f -g -n "Kernel:Stable" https://download.opensuse.org/repositories/Kernel:/stable/standard/ repo-kernel-stable
zypper ref <accept key always>

zypper up kernel-default
...There is an update candidate for 'kernel-default', but it is from a different vendor. Use 'zypper install kernel-default-4.20.6-3.1.g463cfd2.x86_64' to install this candidate...

zypper -vvv install kernel-default-4.20.6-3.1.g463cfd2.x86_64

'kernel-default-4.20.6-3.1.g463cfd2.x86_64' not found in package names. Trying 'kernel-default.x86_64 = 4.20.6-3.1.g463cfd2'.
Selecting 'kernel-default-4.20.6-3.1.g463cfd2.x86_64' from repository 'Kernel:Stable' for installation.
Resolving package dependencies...
Force resolution: No

The following 2 package updates will NOT be installed:
  kernel-firmware  20190118-35.1  noarch  Kernel:Stable  obs://build.opensuse.org/Kernel
  ucode-amd        20190118-35.1  noarch  Kernel:Stable  obs://build.opensuse.org/Kernel

<exit install>

zypper -vvv install kernel-default-4.20.6-3.1.g463cfd2.x86_64 kernel-firmware-20190118-35.1.noarch ucode-amd-20190118-35.1.noarch
...

Kernel installs along with rebuilding initrd and grub, reboot, enroll key, reboot, select advanced options… I see;

IMG_0341.JPG

I added the same repo as you. I also get the same boot menu as well. The new kernel is listed in the boot menu, however when I select the kernel to boot, then I get:

error: you must load the kernel first

and I am unable to boot.

Hi
So did you see mkinitrd run when installing the kernel?

Can you force the re-install;


zypper -vvv install -f kernel-default-4.20.6-3.1.g463cfd2.x86_64 kernel-firmware-20190118-35.1.noarch

Yes, mkinitrd runs. Output here.

I’m no expert on this output, but it doesn’t seem like anything is amiss here.

Apparently kernels from OBS do not support secure boot, so that was the problem. It’s now working properly.

On Fri 08 Feb 2019 08:16:03 AM CST, z2 wrote:

Apparently kernels from OBS do not support secure boot, so that was the
problem. It’s now working properly.

Hi
I think it’s an issue for some systems, the key imported fine here and
secure boot working with the kernel key… but is easier to disable :wink:


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!