Realtek RTL8723BE woes

I have been installing Leap 42.3 on an HP desktop with the Realtek RTL8723BE wi-fi chip and hit a number of problems. Initially it was disconnecting after a while and I used a tip from Google about adding

options rtl8723be fwlps=0

to /etc/modprobe.d/rtl8723be.conf.

This solved the problem of the connection going down but a new problem arose: a periodically slow connection.

iwconfig produced

wlan0     IEEE 802.11bgn  ESSID:"BTHub5-265F"          Mode:Managed  Frequency:2.462 GHz  Access Point: D4:63:FE:07:25:69
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=36/70  Signal level=-74 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:8   Missed beacon:0

Comparison with other devices on the network showed that their Bit Rate was 1 Mb/s [but when I got home I found that my laptop, with an an Atheros chip using the ath9k driver, showed 72.2Mb/s at home as opposed to 1 Mb/s at my friend’s house].

So I tried to reduce the Bit Rate with

iwconfig wlan0 rate 40M auto

This appeared to work for one session but has not worked since.

I did wonder about trying

iwconfig wlan0 rate 1M auto

as that was the rate that other devices were showing at my friend’s house but did not as the iwconfig did not appear to have any effect anyhow.

demesg showed

   13.692842] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
   13.693674] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
   13.694439] rtlwifi: rtlwifi: wireless switch is on

but I can only find questions and no answers to how to change the rate control algorithm, if that is the way forward.

Further enquiries led to ifcfg-wlan0 which is created by wpa_supplicant and contained the line


However I could find no documentation for it suggesting whether this was a way forward for managing the occasional slowdowns.

NB during the installation wicked was used to manage the network; as it was also recommended in one post as better for dealing with the first problem, I have not tried NetworkManager.

Any advice/assistance gratefully received.

Hi John. This caught my attention with respect to this wireless chipset, HP, and disconnections! I note that the signal level reported by iwconfig was reasonably weak

Link Quality=36/70  Signal level=-74 dBm

It is known that some HP laptops only implemented this hardware with one physical antenna, even though there may be more than one antenna port available. If the driver gets it wrong, the received signal level will be much weaker than it should be for a given wifi environment, leading to connectivity issues such as you describe. Here’s a thread I helped with where the underlying cause of connectivity issues was found to be due to weak signal dues to the driver using the wrong antenna port. Post #18 and post #23 onwards will show you how to check if this the issue and correct it by explicitly configuring the appropriate antenna port to be used for your hardware. Hope this helps.

Maybe the last rtlwifi from lwfinger helps.
I have build it yesterday:

This is the new Package:

Thanks. It will be a few days before I get a chance to visit my friend again but I will report back. Any other suggestions gratefully received.

Thanks again. However, my friend has returned the computer because of an unrelated hardware fault - so I cannot test any of your helpful suggestions.