Realtek RTL8191SE and no wifi access!

Hello, please, could anybody help me with my wifi on my notebook ? ( Toshiba Satellite ) So I have used google and read a few topics here at this forum. ( especially this Getting Your Wireless to Work was very interesting for me ) But it is useless for me, because I am newborn in GNU/Linux. I use openSUSE 11.3 with KDE. I have read, that you need some informations about my hw. I hope these are

uname -r
2.6.34-12-desktop

lspci

0e:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

hwinfo --pci

31: PCI e00.0: 0280 Network controller
[Created at pci.318]
Unique ID: KJVu.pWUwfchqQtC
Parent ID: H0_h.rQDwMa03u53
SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:0e:00.0
SysFS BusID: 0000:0e:00.0
Hardware Class: network
Model: “Realtek Network controller”
Vendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
Device: pci 0x8172
SubVendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
SubDevice: pci 0x8181
Revision: 0x10
I/O Ports: 0xa000-0xafff (rw)
Memory Range: 0xf0200000-0xf0203fff (rw,non-prefetchable)
IRQ: 11 (no events)
Module Alias: “pci:v000010ECd00008172sv000010ECsd00008181bc02sc80i00”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #11 (PCI bridge)

on website of realtek Realtek

but I don´t konw what should I have to download

dmesg | grep firmware

2.801713] platform radeon_cp.0: firmware: requesting radeon/RV710_pfp.bin
2.803156] platform radeon_cp.0: firmware: requesting radeon/RV710_me.bin
2.804667] platform radeon_cp.0: firmware: requesting radeon/R700_rlc.bin

You should also inspect the boot log for other information regarding your device. In particular look for messages that your radio kill switch has been activated. A number of people have felt rather silly when they posted that their wireless didn’t work, only to be told to “turn it on”.
I don’t uderstand…

what should I look for at this log?

Thank very much for your advice and for your time for me.

Did you already read this:
openSUSE 11.3 and Toshiba Satellite with i7

The driver for the USB device with ID 10ec:8172 that is in kernel 2.6.34
(openSUSE 11.3) is broken for most devices. I have a newer driver that I got
privately from Realtek that works reliably and it will be pushed to the kernel
soon (I hope). The holdup is that Realtek’s lawyers have not signed off on the
copyright in my new version. Until they do, there is little I can do.

2 vnicolau: no, I didn’t read this topic, it seems very simply, but I have never compile anything so I have use google “how to”. I am very skeptic about my ability to do this procedure. :frowning:

2 lwfinger:

What does it mean for me ( and other users with this realtek )?

When the lawyers sign it, it can be install by Yast2? How can I know, that it already is in kernel?

And now…? Should I download RTL8191SE**-VA2** and try to use it? But I have RTL8191SEvB?

2 lwfinger: I have found your post here New IMB Lenovo L512 >I downloaded the drivers and Need to install them. … so I suppose it is your next advice?

The 10ec:8172 device is not
supported by any drivers in even the latest kernel, thus you will need to build
the driver. To do this, you need to have the kernel headers installed. To get
these, issue the command

Code:

sudo zypper install kernel-headers

With these available, you should be able to change directory to the one that
contains the Reaktek source, and enter “make”. There is good news - I downloaded
the driver from the Realtek site and compiled it with no changes. There were two
warnings that can be ignored. Once the build finishes, you should copy the
firmware as described in the instructions you posted, and load the new driver
with the command

Code:

sudo /sbin/insmod HAL/rtl8192/r8192se_pci.ko

You should now be able to bring the wireless device up with NetworkManager. If
it works this way, then you can “permanently” install it with

Code:

sudo make install

The installation is not really permanent as the driver must be rebuilt and
reinstalled each time there is a kernel update. The firmware will remain. You
only need to do that step with a new installation.

As you see, these instructions are a lot simpler than the list you posted
earlier. Ignore those except for the step that says to copy the firmware.

:question:It may be better to wait for “your built in kernel”. Until :\ NDISWrapper or to buy an external usb wifi adapter

because

and my skills are null and I am afraid of my safety! ( kernel hacking… it sounds dangerous )

On 08/28/2010 03:06 PM, vaon wrote:
>
> and my skills are null and I am afraid of my safety! ( kernel
> hacking… it sounds dangerous )

When my new driver is ready, it will be submitted to the mainline kernel tree
for inclusion in the staging directory. If all goes well, it might be in kernel
2.6.37, which might be used in openSUSE 11.4, but I expect the driver in 12.0.
The only way to get it into 11.3 would be to use the kernel-of-the-day.

Kernel hacking is not dangerous. If you get the code wrong, it might not build.
If it builds, it might fail on boot. In any case, I always keep a known good
kernel in order to recover. My GRUB menu might have anywhere between 5 and 12
kernels listed, and only one will be “failsafe”. At the moment, I have 5 and
every entry is for openSUSE 11.3.

Have you tried entering “acpi = noirq” in your “boot options” section at boot time. That’s what worked for me.

No, I didnť try it. I am only normal user of pc, so I have used google what acpi is! I have read many posts at different forums ( not only for opensuse ), where are many advices how to with realtek… but to my mind is the most important this

I used

sudo zypper install kernel-headers
make
sudo cp -rf firmware/RTL8192SE /lib/firmware/2.6.34-12-desktop
sudo /sbin/insmod HAL/rtl8192/r8192se_pci.ko
sudo make install

wifi worked, but until next reboot of my pc :’(

ndiswrapper with kndiswrapper doesnť work for me… at the last step by using GUI ( configuration wifi access ) there is suddenly no window…:’(

I believe, that linux power advanced user ( like lwfinger ) is able to resolve this hw problem. But not me, because my ability with pc are very low ( not only with linux,windows too ). This is laptop of my all family and we want to use it for our work and entertainment… not for father’s googling and trying to do something. I have no time for resolving this issue with uncertain result. I will not change my distro, because the kernel is the same at all GNU/Linux distros and it si common mistake of beginners to change one if there exists problem. I will use GNU/Linux, I will use openSUSE, because I like it and is better for safety of my family. So I will use some external usb device for accessing internet ( no realtek driver lol! ) and I will looking forward openSUSE 11.4 with lwfinger’s modul in kernel for my realtek.

thank you very much for everybody for your advices

On 08/31/2010 03:36 PM, vaon wrote:
>
> No, I didnť try it. I am only normal user of pc, so I have used
> google what acpi is! I have read many posts at different forums ( not
> only for opensuse ), where are many advices how to with realtek… but
> to my mind is the most important this
> “lwfinger” Wrote:
>> The driver for the USB device with ID 10ec:8172 that is in kernel
>> 2.6.34
>> (openSUSE 11.3) is broken for most devices.
>
> I used
>
> Code:
> --------------------
> sudo zypper install kernel-headers
> make
> sudo /sbin/insmod HAL/rtl8192/r8192se_pci.ko
> sudo make install
>
> --------------------
>
> wifi worked, but until next reboot of my pc :’(

If it worked after the insmod, but failed after the next reboot, then the “sudo
make install” did not work. The only thing I see is that a “sudo /sbin/depmod
-a” should have followed the install step.

After you reboot, check the output of dmesg for any messages regarding the 8192.

dmesg | grep firmware

23.842442] rtl819xSE 0000:0e:00.0: firmware: requesting RTL8192SE/rtl8192sfw.bin

I have reinstalled my opensuse completely. Twice new instalation and both method

zypper install kernel-headers

nothing, therefor in Yast2 install kernel-source and kernel-syms, then


make
sudo cp -rf firmware/RTL8192SE /lib/firmware/2.6.34-12-desktop
sudo /sbin/insmod HAL/rtl8192/r8192se_pci.ko
sudo make install

sometimes yes connection sometimes no connection, therefor 2nd new instalation and

make
sudo make install
reboot

Non stabil wifi access again…

  • problems with kwalletmanager at both… it wants always enter pswd even if I have set allow always for Networkmanager…if I turn off kwalletmanager I must always enter pswd for my WPA/WPA2

many thanks … but I am afraid it is impossible to have no problem wifi work at my Toshiba with realtek on openSUSE 11.3

I have more stabil conection to internet now ( better say acceptable conection ) rotfl! rotfl!.. persists only problem with kwallet… It’s very uncomfortable. I’ll try delete /.kde/share/apps/kwallet/ Maybe it helps me.

I have another question…

What does it mean rebuilt? How can I to do after each kernel update? Like a new instalation from the beginning step by step :\

to lwfinger: tomorrow openSUSE 11.4 - kernell 2.6.37 … How about your driver? Is it in kernel?

On 03/09/2011 03:36 PM, vaon wrote:
>
> lwfinger;2213452 Wrote:
>> The driver for the USB device with ID 10ec:8172 that is in kernel
>> 2.6.34
>> (openSUSE 11.3) is broken for most devices. I have a newer driver that
>> I got
>> privately from Realtek that works reliably and it will be pushed to the
>> kernel
>> soon (I hope). The holdup is that Realtek’s lawyers have not signed off
>> on the
>> copyright in my new version. Until they do, there is little I can do.
>
> to lwfinger: tomorrow openSUSE 11.4 - kernell 2.6.37 … How about your
> driver? Is it in kernel?

Yes, the USB driver for the device with ID 0bda:8172 is in the 2.6.37 kernel.
That is the RTL8191SU.

I got the lead part of the ID above wrong. That ID is for the RTL8191SE, which
has a PCIe interface. That driver will not be in the kernel until 2.6.40 as it
is giving me some trouble, and keeps crashing the system.

:’( for me… but the last version of driver produced by Realtek is OK… wifi now works correctly after compilation :slight_smile: