Realtek RTL8188CUS very slow download speed

Hello,

I use openSUSE (Xfce) on my Desktop PC.

openSUSE Tumbleweed (July 28, 2020)
http://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-DVD-x86_64-Snapshot20200728-Media.iso?mirrorlist

I have installed openSUSE on an internal hard disk and have not set anything after installation. I only use the default setting.

After installation I connected to my Wi-Fi network immediately (my internet data plan is 21.6 Mbits maximum), but the download speed is extremely low compared to Windows 8.1.

openSUSE achieves only these results in the speedtest:
0.88 Mbits/s (Download)

4.07 Mbps (Upload)

Windows 8.1
10.18 Mbps (Download)

4.63 Mbit/s (Upload)

On Windows 8.1, the Wi-Fi adapter there is called RTL8188CU. On openSUSE, it is called RTL8188CUS. I don’t know why, it’s different on openSUSE. I only use the default setting and have nothing installed.

On Windows 8.1 I only use the default driver on Windows 8.1, I have nothing installed except all Windows updates (July 2020) and Firefox 78.0.2.

I looked at YaST Hardware Information and it says that it uses the rtl8192cu driver. What to do?

Can the developers fix the bug here? I think the standard driver for RTL8188CU on openSUSE needs to be improved. How can I solve this problem? I am a beginner. Thanks for the help.

Is this an USB Stick?
Post

lsusb

Use Code-Tags:
https://forums.opensuse.org/showthread.php/536143-Using-Code-Tags-Around-Your-Paste

I don’t know. It’s a purchased desktop computer.

I’ve never seen the Wi-Fi adapter or a USB stick before. It’s in the PC and a friend of mine removed a blue cable (USB) from the motherboard and then the Wi-Fi adapter was not visible in Windows 8.1.

Is this a USB stick for you?

lsusb

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 046d:c08b Logitech, Inc. 
Bus 001 Device 005: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 004: ID 195d:2074 Itron Technology iONE 
Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

Here on Kernel 5.7:

modprobe -c | grep -i "0bda.*8176"
alias usb:v0BDAp8176d*dc*dsc*dp*ic*isc*ip*in* rtl8192cu
alias usb:v0BDAp8176d*dc*dsc*dp*icFFiscFFipFFin* rtl8xxxu

So 2 modules are maybe using for this USB-Stick.

So post:

modprobe -c | grep -i "0bda.*8176"

So post:

modprobe -c | grep -i "0bda.*8176"
modprobe: command not found

I then got the tip from the friend to enter that and it showed a result in Terminal.


sudo modprobe -c | grep -i "0bda.*8176"
[sudo] password for root: --- enter my password ---

Result:


alias usb:v0BDAp8176d*dc*dsc*dp*ic*isc*ip*in* rtl8192cu
alias usb:v0BDAp8176d*dc*dsc*dp*icFFiscFFipFFin* rtl8xxxu

As root:

lsmod | grep -i rtl

Please ever the whole commandline and output:

linux64:~ # lsmod | grep -i rtl

btrtl                  24576  1 btusb
bluetooth             700416  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm

rtl8xxxu              151552  0
rtl8192cu             102400  0
rtl_usb                24576  1 rtl8192cu
rtl8192c_common        73728  1 rtl8192cu
rtlwifi               135168  3 rtl8192c_common,rtl_usb,rtl8192cu
mac80211             1044480  4 rtl_usb,rtl8192cu,rtlwifi,rtl8xxxu
cfg80211              888832  3 rtlwifi,mac80211,rtl8xxxu
usbcore               335872  11 xhci_hcd,ehci_pci,usbhid,rtl_usb,rtl8192cu,usb_storage,ehci_hcd,xhci_pci,rtl8xxxu,uas,ums_realtek

As root:

modprobe -r rtl8xxxu

Restart your network.

Better?

It’s working now.

Then I also restart my Desktop PC and connect it to the Wi-Fi network. That works too.

The download speed is now fast, like on Windows 8.1. I hope it remains so permanent.

Thank you very much. :slight_smile:

It’s working now.

After removing rtl8xxxu?

Then blacklist it:

echo 'blacklist rtl8xxxu' > /etc/modprobe.d/disable-rtl8xxxu.conf

What do you mean, exactly?

I entered it (what you wrote) while using my Desktop PC (speedtest.net). It worked right away.

Then I rebooted the Desktop PC to see if it was still working. Even after rebooting, it still worked.

Should I do it, because currently it works. I will continue to test over the next few days to see if it stays that constant. So far everything is good. :slight_smile: