Realtek RTL 8187 will not connect

I have never had to use wireless on my Leap 42.1 machine before now. With this simple adapter it seems that it should be straight forward but I am missing something. I have been using the Network settings in YaST to attempt to configure the adapter. The adapter is seen and it goes through the configure process, but always comes back as non-connected. Right now I have a Ethernet connection also but that will soon be going away so I must get this working before that happens.

** #** sudo /usr/sbin/iwlist scan
eth0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: C8:D7:19:85:C6:B4
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=70/70 Signal level=-29 dBm
Encryption key:on
ESSID:“FancySycamore”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000001795798ee
Extra: Last beacon: 192ms ago
IE: Unknown: 000D46616E6379537963616D6F7265
IE: Unknown: 010882848B962430486C
IE: Unknown: 03010B
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D160B080400000000000000000000000000000000000000
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD7F0050F204104A00011010440001021041000100103B00010310470010D2
172FFF5651869C1CAA85F05CBFB7B510210005436973636F1023000D4C696E6B7379732045323530301024000776312
E302E30331042000234321054000800060050F20400011011000D4C696E6B737973204532353030100800020084103C
000103
IE: Unknown: DD090010180201F0040000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
Cell 02 - Address: C8:D7:19:85:C6:B6
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=70/70 Signal level=-30 dBm
Encryption key:off
ESSID:“FancySycamore-guest”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000017957a6b0
Extra: Last beacon: 192ms ago
IE: Unknown: 001346616E6379537963616D6F72652D6775657374
IE: Unknown: 010882848B962430486C
IE: Unknown: 03010B
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: Unknown: 32040C121860
IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D160B080400000000000000000000000000000000000000
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD090010180201F0040000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
Cell 03 - Address: 6A:A1:95:6F:84:8C
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=68/70 Signal level=-42 dBm
Encryption key:on
ESSID:“iPhone”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000000720cb1e
Extra: Last beacon: 1352ms ago
IE: Unknown: 00066950686F6E65
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 200100
IE: Unknown: 23020E00
IE: Unknown: 2A0100
IE: Unknown: 32040C121860
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 2D1A2D0017FFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1601080000000000000000000000000000000000000000
IE: Unknown: 7F080400000000000040
IE: Unknown: DD0A0017F206010103010000
IE: Unknown: DD0D0017F20602010648A1956F848D
IE: Unknown: DD090010180200001C0000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

lo Interface doesn’t support scanning.

I need to connect to iphone. Fancy Sycamore is the wifi that is broadcasting off of my ethernet connection.

Can anyone here help me through this? It will be much appreciated. Thanks.

I disabled my ethernet connection and now I have lost that connection also. I can’t seem to get it back. Not that it matters that much because it will soon go away anyway. But it will make it hard to post code. Can you experts overlook the fact that I screwed up in posting this output and give me a hint on how to proceed to get a wireless connection? Thank you

I need to associate but am unclear how to go about it.


wlan0     IEEE 802.11  ESSID:off/any   
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm    
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


I see no NetworkManager Aplet

You can choose to use NetworkManager or wicked via YaST > System > Network Settings > Global Options. If changing network environments frequently, then NetworkManager is easier to use. If you want to use NM, then there are two graphical front-ends available - KDE has it’s own and the other is Gnome orientated. If you need further help with this then tell us which desktop environment you’re using. NM includes a connection-editor used to create the required network config.

For wicked the connection needs to be configured using YaST > System > Network Settings > Overview, select the relevant network device then ‘Edit’ and follow the prompts given. It may be necessary to restart the network for the setting to take effect.

sudo systemctl restart wicked

Thank you Ferrari man,
Before I went to sleep last night, I installed the network widget in the system KDE system tray. I woke this morning to a working wifi. It must take these systems a while to sort through these network changes? Anyway I have accomplished my goal. I am happy this forum is here. Thanks all.

Perhaps a reboot helped with restarting the necessary service. Anyway good to read that it is now working as expected. :slight_smile:

No, I actually went through the rebooting process with that in mind. I had wifi the whole time. I should have specified the KDE environment as apparently you need the widget in the system tray to gain a point of access with KDE.

I am returning to this thread to try to get a resolution to my problem. If I cannot solve this problem, I will either go back to Windows for my desktop environment or maybe try a different Linux distribution. It seems to me that wireless might be the weak point of Opensuse? I now am not sure that I ever had a Wicked connection with this RTL8187 usb. I think when I installed the NetworkManager widget, Networkmanger configured the card and I achieved a connection under Networkmanager. The code outputs in this thread are current with the attempted Wicked configuration. The last one is the output of usr/sbin/iwconfig. Is there anybody out there that can look at the code output in this thread and give me a clue as to where to turn? I have tried to configure the network using the YAST tool but to no avail. I have also tried resetting the system by rebooting, deleting the card, reconfiguring and restarting the system at the command line…‘sudo systemctl restart wicked’ . (Is there anybody who can give me an answer to this question . . . Would buying a more up to date USB wireless card possibly solve my problem?) Thanks to anyone who can help me.

I have upgraded to Leap 42.2 since I first posted this thread. Same problem though.

I no longer have my ethernet connection.