Realtek HD audiio to work in Opensuse 11.1

I have a hp dv9640 dual booted with vista. I am a total noob on linux and have downloaded the HD Linux driver from realtek but have no idea how to install. Have searched but cant find a step by step guide. right now it plays PCM and staticee. Can anyone help. thank you

If you can avoid using the realtek driver, I would recommend avoiding it. The reason I give this recommendation is you are unlikely to get much support using that driver. Instead if you use the alsa driver that comes with openSUSE , a number of us will attempt to help you on this forum. Plus if you write a bug report on openSUSE (to attempt to get a bug fixed in the audio) you are more likely to get the bug addressed if you are using the alsa driver, than you are if you are using the realtek driver.

Now you state you are very new to openSUSE Linux. It might help first if you read some openSUSE concepts: Concepts - openSUSE

Then after reading that, try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? If using openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Im going to read this thoroughly now and will get and work with the alsa driver. I know a good bit about windows and building windows machine and knew the conversion to linux would be a little tricky. Im running kde how do I find the console to type in the stuff you said?

If running KDE, just press <ALT><F2> and type: konsole

found konsole and am reading will post results when done thank you

This also suggests to me you do not know how to get root permissions.

Note, you should ALWAYS ALWAYS ALWAYS log in to your desktop as a regular user. I am very insistent on this, to the point that I will not help users who log in to their desktop with root (administrator permissions). So please do NOT do that during your efforts to get sound working.

If as a regular user, you open a konsole and type the command “su user-a” (no quotes) it will ask you for the password of “user-a” and hence there after everything you do in that konsole will be with the permissions of “user-a”. … assuming user-a exists , of course ]

If you type just “su” (no quote) it will ask for the password of the administrator (user root). ie it assumes if you type no user-name that you want the root permissions. So if you are going to run a bunch of commands in a konsole where root permissions are needed, one can type “su” (no quotes and enter root password) and there after all commands in that open konsole (and only that konsole) will have root permissions. Once you close the konsole, that ends that konsole session. Or one can type “exit” to get rid of the root permissions.

Note the change in prompt from a regular user, and from user root.

Note if you type “su -c some-command” (no quotes) where ‘some-command’ is a command, then the ’ -c ’ means that you are asking for root permissions for only that one command and not subsequent commands.

Ubuntu users like to use something called “sudo” . I don’t use it. I don’t like it. Sorry, no explanations offered nor given. So you will need to learn about that from someone OTHER than me. :slight_smile:

Here is what I found. The test had a female voice and it was clear but when playing any songs or sounds in Audioplayer it is fuzzy sounding and splotchy.

Your ALSA information is located at

Please inform the person helping you.

linux-vgf4:/home/HackBox/Documents # rpm -qa | grep alsa
linux-vgf4:/home/HackBox/Documents # rpm -qa | grep pulse
linux-vgf4:/home/HackBox/Documents # rpm -q libasound2
linux-vgf4:/home/HackBox/Documents # uname -a
Linux linux-vgf4 #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux
linux-vgf4:/home/HackBox/Documents # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.l7q1YApzaEE:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
linux-vgf4:/home/HackBox/Documents #

OK, great. Then your basic sound works !! That makes this easy.

What IMHO you should do next is setup your Software Package Manager so you can install 3rd party software to address this (as openSUSE comes crippled for multimedia) . You can do this by adding 4 software repositories. Just 4. The concepts page I linked above will explain what a repository is, but in essence it is a file server on the internet with a collection of openSUSE Linux applications, codecs, drivers … etc … I recommend 4 repositories and ONLY 4 repositories. No others. Adding others as a new user can land you in a whole bunch of trouble. It typically takes above-average to expert users to sort some of the problems that can happen. The 4 that I recommend are OSS, Non-OSS, Update, and Packman. Chanced are the first 3 (OSS, Non-OSS, Update) are already setup, and you just need to add Packman.

There is guidance here for how to add the repositories on openSUSE-11.1: Repositories/11.1 - openSUSE-Community

Once those 4 are added then with your PC connected to the internet, lets add some 3rd party packaged multimedia applications and codecs from packman to give you some minimal multimedia capabilities.

Go to YaST > Software > Software Management and change “filter” to “search” and search for and install the Packman version (and NOT the Novell/SuSE-GmbH version) of amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, mplayerplug-in, vlc, libffmpeg0, w32codec-all, libquicktime0, xvidcore, libxvidcore4. The last 5 should pick up a bunch of codecs. …

In amarok change the sound engine to the xine sound engine.

If you get real curious as to how audio is setup in Linux, you can read this guide: Sound-concepts - openSUSE

If you find your volume level is low, and you have to move it up to improve the volume, but then you get distortion, what you can do is:

1st - go to YaST > Hardware > Sound > Other > Volume and move the PCM and master volume there up high. Say up to 95%. Then close YaST after applying that.

2nd - go to your mixer (in KDE that is kmix) and move down the levels of Master and PCM to reduce the distortion, but still give you reasonable volume. Note that every time you start a multimedia application you may be forced to go and adjust the mixer PCM levels.

Just a note … EVERYONE of those commands works as a regular user. So you did not need root permissions for those.

The only reason I asked you to use root permissions to run the script, is because that script is saved under /usr/sbin, and to save changes to /usr/sbin, one needs root permissions. The first time you run the script it will ask if you wish to update. If you run the script as a regular user, the update will fail because the script can not write to /usr/sbin. But once the script is updated, you can run it as a regular user. (however no need to run it now as it appears your audio works ok).

I forgot to mention … you can tell the packman packaged versions by the “pm” in their version number.

Good luck. I’m off to bed. Making mistakes as I am tired.