[realtek driver r8169] impossible to obtain dchp lease...

Greetings !!

I did the error to upgrade to 42.2 and now…

  • I can’t connect using ethernet cable (working on another leap 42.2 computer) with a realtek integrated card using r8169 driver.

dhclient -v eth0 gives: DHCPNAK

I’m pretty sure that driver is in the current kernels (and as far as I know in previous ones as well) so maybe you should update to 42.3. My ethernet runs on that and I’ve never had to compile or set up anything it just works. Check if the module is loaded with

 sudo lsmod | grep 8169


If it is loaded then check in Yast2>System>Network Settings and see if youe ethernet connection shows up there.

Have you installed the r8168 driver?

zypper se -si r8168
grep -i 'blacklist r8169' /etc/modprobe.d/*

How did you perform the upgrade ?
Any ‘home:/’ or ‘devel’ repos involved ?

I upgraded using the usb image iso from the LEAP 42.2 DVD… nothing went wrong during the upgrade.
The updates were done straight after using the wifi interface (sloooooow ^^).

I installed the 0010-r8168-8.045.08 driver from realtek… I still receive some DHCPNAK messages in return of DHCPREQUESTs

r8169 has been set out and replaced by r8168… but still no dhcp working.
all the three other computers (two in 42.2 and the last in 13.2 could connect using ethernet interface) dhcp server can handle computers from to range with IP reservations for four computers including this one having a buggy ethernet interface.

Something strange my ANTARES server, running on 42.2 is using the r8169 driver on one of the two realtek cards I have in ^^
I’m looking to see which card is set to eth0 that could receive an ip address using DHCP with the r8169 driver…
As I set ANTARES in runlevel 3… I can not remember where I could see which interface is linked with eth0…

lsmod | grep r8169 

returns nothing as the ./autorun.sh script did the necessary to replace r8169 by r8168…

zypper lr

lists repos related to 42.2 and packman is linked with

do you suggest I kill the old root folder by renaming it and see if all these stuff is working better ?

Why not installing an r8168.rpm???
Than you can revert it also…


lsmod | grep r 816

also post as I wrote:

grep -i 'blacklist r8169' /etc/modprobe.d/*

And do not write something, only post it.

Use Code-Tags.

http://paste.opensuse.org/52694205 ← antares server 42.2 working

http://paste.opensuse.org/96883450 ← rasalgethi server 42.2 not working

http://paste.opensuse.org/8197858 ← antares 42.2 working
http://paste.opensuse.org/58970514 ← rasalgethi 42.2 not working

Hey, my Ethernet is working with the r8169 Module.
I will not help you when you are doing what you think.

So no paste on susepaste, do it here in the Forum using Code-Tags, the # on Top.
And answer the questions, nothing else.

I already answered: I installed the r8168 and it does not fix the issue.
The r8169 hasn’t worked but I realized that it worked on another 42.2 computer named antares with the same network card.

r8169 has been set out the kernel, lsmod lists nothing when asking for r8169 but r8168.

rasalgethi:/home/hurukan # lsmod | grep r8169
rasalgethi:/home/hurukan # lsmod | grep r8168
r8168                 536576  0 
rasalgethi:/home/hurukan # 

I have not asked for any special r816x, I have asked:

lsmod | grep r816

Once more:
Answer the questions, not what you are thinking.


grep -i 'blacklist r8169' /etc/modprobe.d/*

Also as root:
delete the r8168:

modprobe -r r8168

insert the r8169

modprobe r8169

restart your network:

systemctl restart network.service

Thank you.

I can’t understand what is going on.

I have a technicolor modem/router given by my ISP… it could be configurer as IPv4 only router, ipv6 only router and IPv4/ipv6 router.
As I did not use ipv6 I set the router in ipv4.
I got 4 computer in my local network.

Two of them are equipped with realtek ethernet cards, and (now) both are running r8169 driver.
When I set ipv4 only on the router, I have one computer (antares) that could obtain dhcp lease but the other (rasalgethi) don’t.
When I set ipv4/ipv6 on the router, I have **antares **that can’t obtain dhcp lease and **rasalgethi **that can obtain dhcp lease ^^

I know on antaresI cut the ipv6 traffic using ip6tables

# plus rien ne passe au niveau ipv6

ip6tables -F

ip6tables -P INPUT DROP
ip6tables -P OUTPUT DROP
ip6tables -P FORWARD DROP

ip6tables -t nat -P PREROUTING   DROP
ip6tables -t nat -P POSTROUTING   DROP
ip6tables -t nat -P INPUT  DROP
ip6tables -t nat -P OUTPUT  DROP

ip6tables -A INPUT -i eth0 -j DROP
ip6tables -A OUTPUT -o eth0 -j DROP

# règles avancées...

echo 0 > /proc/sys/net/ipv6/conf/eth0/accept_ra
echo 10000000 > /proc/sys/net/ipv6/conf/eth0/router_solicitation_delay
echo 10000000 > /proc/sys/net/ipv6/conf/eth0/router_solicitation_interval
echo 0 > /proc/sys/net/ipv6/conf/eth0/router_solicitations

I disabled this service, ran the router in ipv4/ipv6 mode.
Have to go back later to give report.

I’m getting mad… I confirm the router is set to IPv4 only and the other computer (rasalgethi) running r8169 got its dhcp lease (???)
This morning I had to set the router to ipv4/ipv6 to obtain a lease…

I have no particular skills using IPv6 addresses so that is the reason why I stay with IPv4 addresses (and set the router to ipv4 only).