Realtek audio problem

I’m total newbie to Linux world, and my first day with Linux was a week ago. I got a new hard drive, partitioned it, installed Windows 7 first and then installed Opensuse 13.1 with KDE. I could not make the sound work on Opensuse. I’ve been searching for a week online, and tried everything I could with no success. I learned couple commands though, and my sound card model, codec, etc … … I ran and got the below information.

It doesn’t mean too much to me but somebody with some knowledge might be able to help please by taking a quick look at.
on Windows 7: The sound did not work first when I started using it out of box, but I then installed Realtek driver and everything worked fine.
on Opensuse: I tried updating ALSA to the latest version, alsamixer, Audio Setup, Select Master Channel, Assign permission to user, Test sound, … … … … but still no success. I thought of downloading Realtek driver as I did in Windows, but I got stuck at the last step when I followed the Realtek instruction at “make install” command

zino@linux-l7ok> sudo make install
root’s password:
if -L /include/sound ]; then
rm -f /include/sound;
ln -sf /home/zino/Downloads/AA/alsa-driver-RTv5.18/alsa/include/sound /include/sound;
rm -rf /include/sound;
install -d -m 755 -g root -o root /include/sound;
for f in include/sound/.h; do
install -m 644 -g root -o root $f /include/sound;
install: cannot stat ‘include/sound/
.h’: No such file or directory
make: *** [install-headers] Error 1

Thanks for help

You should not need a separate drive I think.

but in any case you should not make as root only do the install step as root

First did you go to Yast and see if you can set up the sound card? Try turning off pulse and see if that helps. Try the test sounds? Also try testing in the KDE sound section in the configure desktop.

Also see if your user is a member of the audio group.

If none of that works then maybe try the drive

Looking closer it seem that you may have two sound devices a realtek and Intel

Be sure the right one is first in the sound configuration in Yast

Show us lspci to confirm there are two

Edit never mind maybe only the one