Realtek ALC269 no sounds from headphone in 11.3

Hi there,
i just installed the latest opensuse version on my asus eee pc 1001px which has realtek alc269 sound card. The problem is that there is no sound coming from headphones when plugged in… I had the same problem in ubuntu 10.04 and i solved it editing the alsa.conf and adding a line… i didn’t manage to find any solution for opensuse though. :frowning:

What line did you add in Ubuntu-10.04 ?? The place to add lines in openSUSE-11.3 is often the /etc/modprobe.d/50-sound.conf file.

If your ‘line’ solution (what ever it might be) does not work, can you please provide more information, as noted in your multimedia stickie: Welcome to multimedia sub-area (please read the stickies for every forum area you visit).

I’ll quote the relevant parts for you:

please post in this “multimedia” sub-forum, providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](

followed by this (where in RED is the URL).](

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on []( and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer
    , in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

I solved this one : I had to edit my audio card settings in yast. I added “lifebook” to model value =)

Glad to read you suceeded. Thankyou for sharing your solution.

Likely YaST added the model “lifebook” to the /etc/modprobe.d/50-sound.conf file. If you type:

cat /etc/modprobe.d/50-sound.conf

you should be able to observe YaST’s edit.

here’s the output :slight_smile:

punkysxe@linux-znb7:~> cat /etc/modprobe.d/50-sound.conf

options snd-hda-intel model=lifebook
options snd slots=snd-hda-intel
# u1Nb.OPCaYZocXF7:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

Thanks! It appears YaST added this line:

options snd-hda-intel model=lifebook

and then restarted your alsa sound driver by reloading the associated kernel module.