Realtek AC 97 Audio; no sound

Sound doesn’t work. I followed SDB: Audio Troubleshooting SDB:AudioTroubleshooting - openSUSE and followed the Realtek Audio 97 forum Realtek Ac97 Audio - openSUSE Forums but had some errors. I run Opensuse 11 on my Gateway MX3215 laptop, Gnome desktop.

Here is some info:

tsalsa.txt - nopaste.com (beta)

I ran, excluding the quotes.
“rpm -qa | grep alsa”
alsa-driver-unstable-kmp-pae-1.0.17.20081025_2.6.25.16_0.1-1.1
alsa-tools-gui-1.0.16-47.1
alsa-tools-1.0.17.git20080715-1.11
alsa-plugins-1.0.16-57.1
alsa-oss-1.0.15-48.1
alsa-devel-1.0.17.git20081024-1.1
alsa-firmware-1.0.17.git20080617-2.1
alsa-driver-kmp-default-1.0.17.20081025_2.6.25.16_0.1-1.1
java-1_5_0-sun-alsa-1.5.0_update16-1.1
alsa-1.0.17.git20081024-1.1
alsa-driver-unstable-kmp-default-1.0.17.20081025_2.6.25.16_0.1-1.1
alsa-plugins-pulse-1.0.16-57.1
alsa-utils-1.0.17.git20080820-1.1
alsa-driver-kmp-pae-1.0.17.20081025_2.6.25.16_0.1-1.1
bethdave@dslrouter:~> rpm -qa | grep pulse
libpulsecore4-0.9.10-26.5
libpulse-mainloop-glib0-0.9.10-26.5
pulseaudio-module-gconf-0.9.10-26.5
pulseaudio-module-x11-0.9.10-26.5
pulseaudio-module-zeroconf-0.9.10-26.5
gstreamer-0_10-pulse-0.9.5-54.1
libpulse-browse0-0.9.10-26.5
libpulse0-0.9.10-26.5
pulseaudio-utils-0.9.10-26.5
pulseaudio-0.9.10-26.5
pulseaudio-esound-compat-0.9.10-26.5
alsa-plugins-pulse-1.0.16-57.1
pulseaudio-module-lirc-0.9.10-26.5
pulseaudio-module-bluetooth-0.9.10-26.5

“rpm -q libasound2”
libasound2-1.0.17.git20081024-1.1

“uname -a”
Linux dslrouter 2.6.25.18-0.2-default #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux

“cat /etc/modprobe.d/sound”

options snd slots=snd-via82xx

Ssy1.4IVJSDDDGu8:VT8233/A/8235/8237 AC97 Audio Controller

alias snd-card-0 snd-via82xx

Sorry, if I missed anything.

OK, one thing at a time. :slight_smile: … your kernel is 2.6.25.18-0.2-default. Which means the driver you should be using is alsa-driver-kmp-default. Not the others.

Good luck!

Thanks, oldcpu. I removed the extra drivers, now

rpm -qa | grep alsa
alsa-tools-1.0.17.git20080715-1.11
alsa-driver-kmp-default-1.0.17.20081029_2.6.25.18_0.2-1.1
alsa-firmware-1.0.17.git20080617-2.1
alsa-1.0.17.git20081024-1.1
alsa-utils-1.0.17.git20080820-1.1

Still no sound happened, but for the first time in alsamixer I was able to view external amplifier, but couldn’t turn it off.

I ran in terminal
amixer
to see if external amplifier was still on

Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 63
Mono:
Front Left: Playback 51 [81%] -18.00dB] [on]
Front Right: Playback 51 [81%] -18.00dB] [on]
Simple mixer control ‘Master Mono’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 0 [0%] -46.50dB] [off]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 63
Mono:
Front Left: Playback 63 [100%] [0.00dB] [on]
Front Right: Playback 63 [100%] [0.00dB] [on]
Simple mixer control ‘3D Control - Switch’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘PCM’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [12.00dB] [on]
Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control ‘PCM Out Path & Mute’,0
Capabilities: enum
Items: ‘pre 3D’ ‘post 3D’
Item0: ‘pre 3D’
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 0 [0%] -34.50dB] [on] Capture [off]
Front Right: Playback 0 [0%] -34.50dB] [on] Capture [off]
Simple mixer control ‘CD’,0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 0 [0%] -34.50dB] [on] Capture [off]
Front Right: Playback 0 [0%] -34.50dB] [on] Capture [off]
Simple mixer control ‘Mic’,0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 16 [52%] -10.50dB] [on] Capture [on]
Front Right: Playback 0 [0%] -34.50dB] [on] Capture [on]
Simple mixer control ‘Mic Boost (+20dB)’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘Mic Select’,0
Capabilities: enum
Items: ‘Mic1’ ‘Mic2’
Item0: ‘Mic1’
Simple mixer control ‘Video’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Phone’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 0 [0%] -34.50dB] [off]
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958 Output’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘IEC958 Playback AC97-SPSA’,0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 3
Mono: 3 [100%]
Simple mixer control ‘PC Speaker’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 15
Mono: Playback 15 [100%] [0.00dB] [on]
Simple mixer control ‘Aux’,0
Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 0 [0%] -34.50dB] [off] Capture [off]
Front Right: Playback 0 [0%] -34.50dB] [off] Capture [off]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 0 [0%] [0.00dB] [on]
Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control ‘Mix’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Mix Mono’,0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘External Amplifier’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘Input Source Select’,0
Capabilities: enum
Items: ‘Input1’ ‘Input2’
Item0: ‘Input1’
Simple mixer control ‘Input Source Select’,1
Capabilities: enum
Items: ‘Input1’ ‘Input2’
Item0: ‘Input1’
Simple mixer control ‘VIA DXS’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] -48.00dB]
Front Right: Playback 31 [100%] -48.00dB]
Simple mixer control ‘VIA DXS’,1
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] -48.00dB]
Front Right: Playback 31 [100%] -48.00dB]
Simple mixer control ‘VIA DXS’,2
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] -48.00dB]
Front Right: Playback 31 [100%] -48.00dB]
Simple mixer control ‘VIA DXS’,3
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] -48.00dB]
Front Right: Playback 31 [100%] -48.00dB]

Here I found external amplifier and seen it was still on. I understood I had to turn it off, but couldn’t in alsamixer. So in Gnome desktop I went to
Multimedia/Volume Control/Volume Control

I could adjust the sound like in alsamixer but here I was able to go to
Edit/Preferences
then I scrolled down until I found external amplifier and checked the box.

Now a new box appears called switches. Here uncheck the external amplifier, and for me the sound worked.

Unfortunately, I can’t get the settings to save. I haven’t checked the bios yet, but I have tried
alsactl store
but it didn’t save. Not the biggest deal, I’m just happy to have sound.

Two links that helped me.

Sound Card And Opensuse 10.3 - openSUSE Forums

Gateway Laptop No - Audio Problem - Please Help. - openSUSE Forums

Congratulations on getting sound !! Did you run “alsactl store” with root permissions? ie setup your mixer such that your sound works, and then type: su -c 'alsactl store’and enter root password when prompted for a password.

Once again, WELL done in sorting this, and WELL done wrt your research.