Realtek 8723DE - secrets not deliverd

hi,

got a laptop with Leap 15 and with the help of Sauerland https://forums.opensuse.org/showthread.php/533131-wifi-0bda-b009-realtek-semiconductor-corp I got the Realtek 8723DE working fine for the last 20 days.

However since sunday Network Manager just throws a (from dutch) “Secrets not deliverd” message.
I removed the Wifi from Networkmanager and did a reconnect, enter the password a few times, but no connection.

journalctl -u NetworkManager:

[Oct 08 17:55:46 linux-mq72 NetworkManager[1354]: <info>  [1539014146.5073] device (wlan0): Activation: starting connection 'Malazan_Empire' (d440d12c-3742-4bec-86f8-3aa884463225)
Oct 08 17:55:46 linux-mq72 NetworkManager[1354]: <info>  [1539014146.5075] audit: op="connection-activate" uuid="d440d12c-3742-4bec-86f8-3aa884463225" name="Malazan_Empire" pid=1917 uid=1000 result>
Oct 08 17:55:46 linux-mq72 NetworkManager[1354]: <info>  [1539014146.5077] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Oct 08 17:55:46 linux-mq72 NetworkManager[1354]: <info>  [1539014146.5079] manager: NetworkManager state is now CONNECTING
Oct 08 17:55:46 linux-mq72 NetworkManager[1354]: <info>  [1539014146.9503] device (wlan0): set-hw-addr: reset MAC address to FC:01:7C:46:89:F3 (preserve)
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4354] device (wlan0): supplicant interface state: inactive -> disabled
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4457] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4469] device (wlan0): Activation: (wifi) access point 'Malazan_Empire' has security, but secrets are required.
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4473] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4847] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4858] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4865] device (wlan0): Activation: (wifi) connection 'Malazan_Empire' has security, and secrets exist.  No new secrets needed.
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4868] Config: added 'ssid' value 'Malazan_Empire'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4870] Config: added 'scan_ssid' value '1'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4872] Config: added 'bgscan' value 'simple:30:-80:86400'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4874] Config: added 'key_mgmt' value 'WPA-PSK'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4876] Config: added 'auth_alg' value 'OPEN'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.4878] Config: added 'psk' value '<hidden>'
Oct 08 17:55:47 linux-mq72 NetworkManager[1354]: <info>  [1539014147.8136] device (wlan0): supplicant interface state: disabled -> inactive
Oct 08 17:55:48 linux-mq72 NetworkManager[1354]: <info>  [1539014148.2669] device (wlan0): supplicant interface state: inactive -> scanning
Oct 08 17:55:49 linux-mq72 NetworkManager[1354]: <info>  [1539014149.2677] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:55:49 linux-mq72 NetworkManager[1354]: <info>  [1539014149.2819] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:55:49 linux-mq72 NetworkManager[1354]: <info>  [1539014149.5637] device (wlan0): supplicant interface state: associating -> associated
Oct 08 17:55:50 linux-mq72 NetworkManager[1354]: <info>  [1539014150.3808] device (wlan0): supplicant interface state: associated -> 4-way handshake
Oct 08 17:55:50 linux-mq72 NetworkManager[1354]: <info>  [1539014150.4073] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:55:50 linux-mq72 NetworkManager[1354]: <warn>  [1539014150.4074] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:55:50 linux-mq72 NetworkManager[1354]: <info>  [1539014150.4123] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:55:50 linux-mq72 NetworkManager[1354]: <info>  [1539014150.5127] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:56:01 linux-mq72 NetworkManager[1354]: <info>  [1539014161.9375] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:56:01 linux-mq72 NetworkManager[1354]: <info>  [1539014161.9603] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <info>  [1539014162.2379] device (wlan0): supplicant interface state: associating -> associated
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <info>  [1539014162.3922] device (wlan0): supplicant interface state: associated -> 4-way handshake
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <info>  [1539014162.4072] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <warn>  [1539014162.4073] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <info>  [1539014162.4143] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:56:02 linux-mq72 NetworkManager[1354]: <info>  [1539014162.5127] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:56:12 linux-mq72 NetworkManager[1354]: <warn>  [1539014172.6376] device (wlan0): Activation: (wifi) association took too long
Oct 08 17:56:12 linux-mq72 NetworkManager[1354]: <info>  [1539014172.6377] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:12 linux-mq72 NetworkManager[1354]: <warn>  [1539014172.6404] device (wlan0): Activation: (wifi) asking for new secrets
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8842] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8849] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8851] device (wlan0): Activation: (wifi) connection 'Malazan_Empire' has security, and secrets exist.  No new secrets needed.
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8851] Config: added 'ssid' value 'Malazan_Empire'
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8851] Config: added 'scan_ssid' value '1'
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8852] Config: added 'bgscan' value 'simple:30:-80:86400'
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8852] Config: added 'key_mgmt' value 'WPA-PSK'
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8852] Config: added 'auth_alg' value 'OPEN'
Oct 08 17:56:18 linux-mq72 NetworkManager[1354]: <info>  [1539014178.8852] Config: added 'psk' value '<hidden>'
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.3364] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.3574] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.6323] device (wlan0): supplicant interface state: associating -> 4-way handshake
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.6598] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <warn>  [1539014180.6599] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.6655] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:56:20 linux-mq72 NetworkManager[1354]: <info>  [1539014180.7667] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.1945] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.2128] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.4963] device (wlan0): supplicant interface state: associating -> associated
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.5059] device (wlan0): supplicant interface state: associated -> 4-way handshake
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.5553] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <warn>  [1539014192.5554] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.5649] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:56:32 linux-mq72 NetworkManager[1354]: <info>  [1539014192.6627] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:56:43 linux-mq72 NetworkManager[1354]: <warn>  [1539014203.6386] device (wlan0): Activation: (wifi) association took too long
Oct 08 17:56:43 linux-mq72 NetworkManager[1354]: <info>  [1539014203.6387] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:43 linux-mq72 NetworkManager[1354]: <warn>  [1539014203.6410] device (wlan0): Activation: (wifi) asking for new secrets
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8818] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8826] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8883] device (wlan0): Activation: (wifi) connection 'Malazan_Empire' has security, and secrets exist.  No new secrets needed.
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8890] Config: added 'ssid' value 'Malazan_Empire'
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8897] Config: added 'scan_ssid' value '1'
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8897] Config: added 'bgscan' value 'simple:30:-80:86400'
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8898] Config: added 'key_mgmt' value 'WPA-PSK'
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8898] Config: added 'auth_alg' value 'OPEN'
Oct 08 17:56:48 linux-mq72 NetworkManager[1354]: <info>  [1539014208.8898] Config: added 'psk' value '<hidden>'
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.3550] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.3727] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.6412] device (wlan0): supplicant interface state: associating -> associated
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.6476] device (wlan0): supplicant interface state: associated -> 4-way handshake
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.6759] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <warn>  [1539014210.6760] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.6812] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:56:50 linux-mq72 NetworkManager[1354]: <info>  [1539014210.7815] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:57:02 linux-mq72 NetworkManager[1354]: <info>  [1539014222.2072] device (wlan0): supplicant interface state: scanning -> authenticating
Oct 08 17:57:02 linux-mq72 NetworkManager[1354]: <info>  [1539014222.2328] device (wlan0): supplicant interface state: authenticating -> associating
Oct 08 17:57:02 linux-mq72 NetworkManager[1354]: <info>  [1539014222.5030] device (wlan0): supplicant interface state: associating -> associated
Oct 08 17:57:05 linux-mq72 NetworkManager[1354]: <info>  [1539014225.4238] device (wlan0): supplicant interface state: associated -> 4-way handshake
Oct 08 17:57:05 linux-mq72 NetworkManager[1354]: <info>  [1539014225.4539] device (wlan0): supplicant interface state: 4-way handshake -> group handshake
Oct 08 17:57:05 linux-mq72 NetworkManager[1354]: <warn>  [1539014225.4539] sup-iface[0x56338086d800,wlan0]: connection disconnected (reason -1)
Oct 08 17:57:05 linux-mq72 NetworkManager[1354]: <info>  [1539014225.4599] device (wlan0): supplicant interface state: group handshake -> disconnected
Oct 08 17:57:06 linux-mq72 NetworkManager[1354]: <info>  [1539014226.0044] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 08 17:57:14 linux-mq72 NetworkManager[1354]: <warn>  [1539014234.6386] device (wlan0): Activation: (wifi) association took too long
Oct 08 17:57:14 linux-mq72 NetworkManager[1354]: <info>  [1539014234.6386] device (wlan0): state change: config -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Oct 08 17:57:14 linux-mq72 NetworkManager[1354]: <info>  [1539014234.6390] manager: NetworkManager state is now DISCONNECTED
Oct 08 17:57:14 linux-mq72 NetworkManager[1354]: <warn>  [1539014234.6402] device (wlan0): Activation: failed for connection 'Malazan_Empire'
Oct 08 17:57:14 linux-mq72 NetworkManager[1354]: <info>  [1539014234.6416] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Oct 08 17:57:15 linux-mq72 NetworkManager[1354]: <info>  [1539014235.0936] device (wlan0): set-hw-addr: set MAC address to EA:2E:F2:DA:80:D9 (scanning)
Oct 08 17:57:15 linux-mq72 NetworkManager[1354]: <info>  [1539014235.6270] device (wlan0): supplicant interface state: scanning -> disabled
Oct 08 17:57:15 linux-mq72 NetworkManager[1354]: <info>  [1539014235.9539] device (wlan0): supplicant interface state: disabled -> inactive

system is fully updated, other devices have no issue connecting

Hi
I have controlled the kmp and have not seen any error in the build process.

So please post:

zypper se -si kernel-default rtlwifi networkman rtl8723
zypper lr -d

Also you can grep the zypper.log for the time, when the problem began:

grep -i '2018-10-08' /var/log/zypp/history

That will show all for Oct 8th, 2018.

What’s the meaning of the “from dutch” addition? I’m dutch, but don’t see any dutch in the output. Sure the translation ( if there is ) is correct?

KDE is in dtuch and under “Meldingen” it said somethink like “Secrects niet geleverd” :slight_smile:

hello again Sauerland :slight_smile:
here is the requested info

As far as I can tell the user updated on Saturday (06-10) but after the update turned laptop off so only noticed Sunday that the wifi stopped working.
On Monday (08-10) I did a new update run and forced the rtl files from your repo to be reinstalled just in case.

linux-mq72:~ # zypper se -si kernel-default rtlwifi networkman rtl8723
Loading repository data...
Reading installed packages...

S  | Name                             | Type    | Version                                  | Arch   | Repository               
---+----------------------------------+---------+------------------------------------------+--------+--------------------------
i+ | NetworkManager                   | package | 1.10.6-lp150.3.1                         | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-branding-openSUSE | package | 42.1-lp150.2.2                           | noarch | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-lang              | package | 1.10.6-lp150.3.1                         | noarch | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-openconnect       | package | 1.2.4-lp150.1.11                         | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-openconnect-lang  | package | 1.2.4-lp150.1.11                         | noarch | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-openvpn           | package | 1.8.2-lp150.2.1                          | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-openvpn-lang      | package | 1.8.2-lp150.2.1                          | noarch | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-pptp              | package | 1.2.4-lp150.1.7                          | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | NetworkManager-pptp-lang         | package | 1.2.4-lp150.1.7                          | noarch | openSUSE-Leap-15.0-Oss   
i+ | kernel-default                   | package | 4.12.14-lp150.12.19.2                    | x86_64 | openSUSE-Leap-15.0-Update
i+ | kernel-default                   | package | 4.12.14-lp150.12.16.1                    | x86_64 | openSUSE-Leap-15.0-Update
i+ | kernel-default-devel             | package | 4.12.14-lp150.12.19.2                    | x86_64 | openSUSE-Leap-15.0-Update
i+ | kernel-default-devel             | package | 4.12.14-lp150.12.16.1                    | x86_64 | openSUSE-Leap-15.0-Update
i+ | libKF5NetworkManagerQt6          | package | 5.45.0-lp150.1.1                         | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | libproxy1-networkmanager         | package | 0.4.15-lp150.2.2                         | x86_64 | openSUSE-Leap-15.0-Oss   
i+ | rtl8723de-firmware               | package | 0.7.git20180301-lp150.5.1                | noarch | xx-wifi                  
i+ | rtlwifi_new-extended-kmp-default | package | 20180224_k4.12.14_lp150.12.19-lp150.13.3 | x86_64 | xx-wifi                  
i+ | rtlwifi_new-firmware-license     | package | 0.7.git20180301-lp150.5.1                | noarch | xx-wifi           

linux-mq72:~ # zypper lr -d                                                                                                                                                                           
Repository priorities are without effect. All enabled repositories share the same priority.                                                                                                           
                                                                                                                                                                                                      
#  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                   | Service                                                                                                                                                                              
---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------+--------                                                                                                                                                                              
 1 | openSUSE_Leap_15.0        | xx-Games                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Leap_15.0/                   |        
 2 | packman.inode.at-suse     | xx-Packman Repository                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                                      |        
 3 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/                   |        
 4 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/               |        
 5 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/oss/                              |        
 6 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/non-oss/                          |        
 7 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                     |        
 8 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                         |        
 9 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/                  |        
10 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/              |        
11 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                                    |        
12 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                                |        
13 | xx-wifi                   | xx-wifi                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.0_Update/ |    

zypper logs: zypp log - Pastebin.com

Saturday was a big update it seems which included rtl, monday was kernel and foced rtl again which also added the 2 blacklist rpm’s

okay, I solved it but don’t ask me why, can only tell you how :slight_smile:

  1. I thought maybe something got corrupted with the install on the 7th so I did a full reinstall using
zypper in -f $(rpm -q -a --qf '%{NAME} ')

This made no difference.

  1. I started looking through the latest kernel change log (4.12.14-lp150.12.19) and I did notice this line:
  • Bluetooth: Add a new Realtek 8723DE ID 0bda:b009 (bsc#1051510).

which I found a bit odd since the bluetooth does not show up at all, but it is the same device as the wifi so I figured lets reinstall the oldest kernel I could find in yast which was 4.12.14-lp150.12.4 and hopefully does not have this change.
Booted up using that but no difference.

  1. So removed that kernel again and also removed everything from the xx-wifi repo, you know with a little hope tgat maybe they did add the wifi in the new kernel.
    So removed the rtl8723de-firmware, rtlwifi_new-extended-kmp-default, rtlwifi_new-firmware-license but also the 2 broadcom packages that got auto installed and the blacklist packages.

reboot but sadly no wifi.

  1. Then only added the rtlwifi_new-extended-kmp-default, nothing else, no firmware or anything.

reboot -> working wifi

I got the laptop for few more days till I return it to the user in case you want to test anything, but several reboots/shutdowns etc. etc. and wifi works perfectly

ps: did a dmesg | grep firmware and I see: rtl8723de: Using firmware rtlwifi/rtl8723defw.bim which after looking in yast is provided by kernel-firmware… could this have been conflicting with the one from xx-wifi ?

ps: did a dmesg | grep firmware and I see: rtl8723de: Using firmware rtlwifi/rtl8723defw.bim which after looking in yast is provided by kernel-firmware… could this have been conflicting with the one from xx-wifi ?

That could be.

Thanks for sharing…

I installed opensuse leap 15 on a friend’s HP laptop with the same wifi card from realtek, and with help of the mentioned repo from Sauerland got it to work. Now I met my friend again and saw he had not done any updating so I did that for him. And that left me without wifi!
I tried the solution mentioned here but to no avail. Wifi is somehow working because I can see all available networks, but when connecting it stays at configuring interface and keeps asking for a password.

Any suggestions on how to get this thing to work?! And then not once, but through all updates.

Is there any hope to get this wifi incorporated in the default kernel for leap 15?

Is there any hope to get this wifi incorporated in the default kernel for leap 15?

There are 2 Repos for Leap 15.0, the one for the Kernel shipped by Leap on ISO and in the OSS Repo:
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.0/

and the one for the last kernel in the OSS-Update Repo.
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.0_Update/

So please show:

zypper lr -d
zypper se -si rtl
uname -a

Thanks for the reply. I will have to check that, didn’t realize there were 2 different repo’s so don’t really know which one I created. I live an hours drive away so need to check that via desktop sharing solution or pay a visit. Will report back as soon as I know something more.

Another thing I saw in Sauerland’s repo is dkms. Would I need to install dkms? I read about that on Larry Finger’s page or somewhere else but that may only have to do with manual installation, or not?

Sorry to spam this thread again, but browsing through the repo on this computer I saw the firmware from the Sauerland repo was not installed since I removed that before. Installing it again, then rmmod rtl8723de followed by modprobe rtl8723de, and the wifi connects! All the while I am connected remotely.

Great, seems it works again, thanks a lot for the work and help

Glad to hear that it is working.

But:
if you only want the kernel-module package for wifi, please use only this one for the Updated Kernel:
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.0_Update/

In this Repo are only Kernel Module Packages (kmp) for Hardware.
I have build this Repo a few days ago.

In my “normal” Repos ( the 2 you have enabled in yor zypper lr -d list) are many packages and the “can” break your installed packkages.
So please delete them and use the above one.
Or use them without warranty.

I will change the repo as soon as I find the time to remotely connect again. Was going to write that the fix didn’t survive a reboot, but issuing the same unload reload sequence did it again. Will try if that is fixed by the other repo

My last try to switch to the correct repo was via remote control, which failed, so today I was present to restore a disk image and start anew. I changed to the new repo, and run zypper up to have all system updates installed. Before this update, with the wifi drivers installed from the update repo of Sauerland, the wifi worked. After the updates of opensuse with a new kernel and kernel firmware that I saw being installed, and after a reboot, no wifi. It would show all available connections, but connecting was impossible. After rmmod rtl8723de ; modprobe rtl8723de it connected.

I had written before I went to see the computer a systemd service that runs the rmmod - modprobe thing during boot, and voila, wifi connected! So somehow when the system loads the rtl8723de by itself it doesn’t work, removing and reinserting it then it works. Hope this helps to fix this, I don’t know if there is a way to tell the system which firmware to load, because maybe it has to do with that, as one other user mentioned. I won’t have time to see how to help fix this since remotely is just too complicated, and as long as wifi keeps working I’m ok

Please post:

zypper lr -d
zypper se -si rtl
uname -a

Here is what you requested