Really needs libstdc++.so.5 for i386 machine

Hello alls
While i installed a certain fortran compiler, it said “libstdc++.so.5(GLIBCPP_3.2) is needed”. My system is SUSE11.0 for i386, it has only libstdc++.so.6. I could not find a rpm for libstdc++.so.5(GLIBCPP_3.2)for i386 machine from the internet.

Could anyone please tell me where i can get it? Or may anyone please provide me this kind of file? I am just a beginner for programming, therefore i do not know another way to get this problem passed. :frowning:

Thank you in advance.
Amm

You will need to install compat-libstdc+±5.0.7-121.1 RPM to get libstdc++.so.5. Do reply back if you have trouble finding the RPM. Else acknowledge if it solved your issue. :slight_smile:

  • Thejaswi Raya

You should be able to get the RPM and all its dependencies from the DVD itself.

Thank you very much Thejaswi Raya. I am so sorry to reply late, i could not access internet yesterday. My computer got suck.
Yes, i really want that compat-libstdc+±5.0.7-121.1 RPM file. But it should be for i386 machine and SUSE. I could get only for x86-64, which is incompatible with my machine. I do not know that i can use the x86-64 rpm for i386 or not. I am just a newbies for programming and linux. You said i could get it from DVD. And which version is SUSE? When i install gcc by using System management via yast2, i got only libstdc++.so.6. Could you please answer me? Or anyone else please help on this issue. :frowning:

Try this:

  1. Load the openSUSE 11.0 DVD into your computer.
  2. Run this command as root user
    “sudo zypper install compat-libstdc++”

That should be it.

  • Thejaswi Raya

Thank you very much Thejaswi Raya, i will try.
Amm :slight_smile:

Hi,

I tried this on OpenSuse 11.1 and it comes up with:


Loading repository data...
Reading installed packages...
'compat-libstdc++' not found.
Resolving package dependencies...
Nothing to do.

Is this different for 11.1?

Many thanks
golpe

Try libstdc++33