Really bad connection after changing to VDSL

For the longest time I had a 24/2 Mbps ADSL line, and had zero problems in both Windows and OpenSuse 13.1.

Some time ago, however, this housing company switched to a 100/10 VDSL service (which also meant a forced change from an ADSL modem to a VDSL one).

Immediately after the switch I noticed bad connection problems both in Windows and Linux. The connection would work mostly, and pretty fast (over 85/10 Mbps download/upload rates according to, except that the connection would halt for several seconds on a semi-regular basis. The connection would work just fine, and then it would halt for a second or two, and then continue. Sometimes the pause would be significantly longer. The problem was significantly worse on Linux than on Windows, but it appeared on both.

The problem was highly perplexing, because it happened on my PC only. I did not notice any such problem with any other device using the same connection. And I tried everything I could think of (other ethernet cables, using a PCI ethernet card instead of the motherboard’s one and so on and so forth; nothing made any difference.)

Even more perplexingly, the problems seemed to vanish from Windows after some weeks. I have no idea why or how. I have not noticed any problem for months on the Windows side. The connection seems to be fast and stable, without the pauses.

Likewise the problems have diminished somewhat on the Linux side, but not gone away completely. While it’s better, it’s still so bad as to make Linux almost unusable. Just eg. watching YouTube videos is highly annoying because it will often get stuck, either just starting the video, or in the middle of it, loading it. When running the test, the connection will often show the 85+ Mbps, but sometimes get stuck in the middle of it for several seconds. It’s highly annoying to browse the internet, with the constant pauses. It’s hard to describe how annoying it is, but it makes it almost unusable, really.

I know I’m pretty much grasping at straws here, and this might be a completely hopeless endeavor, but I’m hoping that somebody could have some idea of what to do next. The problem is highly strange and perplexing, and at this moment seems to affect only Linux.

As said, I don’t believe it to be a hardware problem. As said, whether using the MB’s ethernet chip, or a separate PCI ethernet card, it makes no difference. I have tried like 4 different ethernet cables, and it makes no difference. And I have not noticed the problem in any other device than my PC, and the connection seems to be working fine on the Windows side (even though, as said, strangely the problem was similar there at first, but somehow fixed itself later for unknown reasons). I have no idea what could be causing this, or how to find out.

More details about your NIC chipset(s) and negotiation (use ethtool for that) might be helpful here. Are you sure that it’s not the router (VDSL connection/PPPoE session) itself?

You need to gather actionable information.

If you feel up to it, capture packets with an app like Wireshark.
Invoke a tcpdump.
Is this a shared line? If so, are others experiencing same?
Because DSL travels over telco wires, ask if a technician can physically inspect the box, make sure your lines are far enough from others and you have good connections (Maybe wires were moved when your service was changed).

You can run Wireshark or some other packet capture tool on your Windows box as well, partly for comparison… to possibly determine why one box might not be as affected as the other.

If you really can’t solve your problem, you might be able to mitigate the effects using a different TCP/IP Congestion Control algorithm, but this would only be a band-aid to lessen effects, you won’t be fixing your problem. For background and instructions how to do this,


I’m really at a loss about what to do about this.

Since I made my original post, I have not had any problem with this on Windows. On the Linux side, the problem is intermittent. Sometimes the internet connection works ok, but otherthimes (which means most of the time) it’s absolutely horrible. Maybe even worse than at the beginning. At its worst, just going to may take anywhere between 10 and 30 seconds (when, at the very same time, going there with another device like a tablet takes a microsecond). Watching YouTube videos is pretty much impossible; even when YouTube is able to show the video, it will show the version with the absolute minimum bitrate, which invariably looks so bad as to be almost unwatchable. Loading a page full of images may take minutes (when, once again, it will load in seconds with another device, and on Windows.) You cannot even begin to comprehend how absolutely infuriating this can be, unless you experience it first hand.

Yet, just a couple of days ago, the connection was just fine, with no discernible problems, and was so for hours at end. It seems completely random, and I can’t tell what the pattern is.

This most definitely happens only on Linux. When I use the connection at the same time with another device, there are zero problems. Also, it started happening only after the switch to the VDSL box; with the previous ADSL box there was never any kind of problem. I can’t even understand why that would make a difference on the PC side, but somehow it does. One would think that on the PC side it all looks the same, but apparently not.

Some time ago I made another thread about this odd thing that has been happening. I oftentimes get this message in Linux:

Message from syslogd@linux-8111 at Sep 4 09:44:15 …
kernel: 3702.985004] Disabling IRQ #16

I have no idea if it’s in any way related, nor have I had the opportunity to test whether the connection problems start after that message appears (because it happens so randomly and unpredictably), or whether it’s completely unrelated.

What could possibly make a difference between an ADSL and a VDSL box, on the linux side, when using a regular ethernet card (or the integrated ethernet chip in the motherboard)? How do you even approach this problem?

What could possibly make a difference between an ADSL and a VDSL box, on the linux side, when using a regular ethernet card (or the integrated ethernet chip in the motherboard)? How do you even approach this problem?

It could be a potential negotiation issue arising between the VDSL device and your PC Ethernet chipset perhaps. Constant renegotiation might be at play.